ifup cannot browse

In Network Settings in OpenSuse 11.1

while using “Traditional Method with ifup” I am able to set up a box as a server and connect via http over the net BUT Firefox cannot browse.

If I switch to “User Controlled with NetworkManager” I can run Firefox but my server is not contactable.

Please how do I do both?

When you set up with the traditional method, what is the contents of /etc/resolv.conf ? As it seems you have a DNS problem.


Name Server IP Location
ns1.tpgi.com.au Ryde, 02, AU
ns2.tpgi.com.au Sydney, 02, AU

My resolv.conf

/etc/resolv.conf file autogenerated by netconfig!

Before you change this file manually, consider to define the

static DNS configuration using the following variables in the

/etc/sysconfig/network/config file:




or disable DNS configuration updates via netconfig by setting:


See also the netconfig(8) manual page and other documentation.

Note: Manual change of this file disables netconfig too, but

may get lost when this file contains comments or empty lines

only, the netconfig settings are same with settings in this

file and in case of a “netconfig update -f” call.

Please remove (at least) this line when you modify the file!

search mydomain.com

Thaks for the response

Try this: Add both (a) the nameservers and (b) the gateway IP address into the configuration
FFI: HowTo Configure a network card in Suse/openSUSE 10, 11 for LAN and Internet Access.

My bad

I checked the nameservers again. Was working on old info. For good measure I added in the gateway. All good now.

My apologies. I promise to check everything twice before I post again.

Keep Safe