Ifolder installation

Hello world!

I’m a beginner to linux and i have managed to set up a samba fileserver for a school with the help of the incredible PV from this forum who never gave up on a beginner!

Now on to the next problem. The school also wanted Ifolder. They are running Opensuse 10.3 with Gnome installed. I am trying to set Ifolder up in a smaller environment before i go touching the server.

On to the problem: I have looked for instructions all over the internet to suit my knowledge, but i find none as detailed as i seem to need.

Here are the Ifolder-communitys installation instructions:



openSUSE 10.3

Download the following packages from Mono 1.2.6 Downloads to upgrade openSUSE 10.3
Run “rpm –Uvh mono-corerpm –nodeps" to upgrade packages
Ensure Apache is installed in worker mode and configured to work with SSL
Install xsp-1.2.6-2.novell.noarch.rpm
Install apache2-mod_mono-1.2.6-1.suse103.novell.i586.rpm
Install server rpms "ifolder3-enterprise-3.7.2.x
” and “ifolder-enterprise-plugin-3.7.2.x*”
Software is installed and ready to be configured. Follow the configuration instructions.

I have downloaded the packages and tried the command “rpm –Uvh mono-core*rpm –nodeps” which returns -nodeps: unknown option.

Tried without -nodeps and it tells me “file not found by glob”

Tried specifying the whole path to the rpm file with its full name without nodeps, and it returns error: failed dependencies from mono 1.2.5 stuff (trying to upgrade to 1.2.6)

I will post results if you need them, but this may be something simple as im really new to linux.

Maybe i need to place the rpm files somewhere special?

Isn’t it --no-deps and not --nodeps. you have to provide the full path to the rpm

A) It would be --nodeps

B) It would be a completely stupid (sorry, but other words just don’t fit) idea to use “–nodeps” for this purpose. Somebody writing this into official documentation (if this is the case) should be whacked over the head with $HEAVY_OBJECT_OF_YOUR_CHOICE for that (it obviously can’t do more damage).

C) It does not make any sense in forcing an upgrade of one component like mono -even via obviously incompatible packages- for an OS which will reach its “end of Life” in a few days

If you really want to do something sane, then do an upgrade, not only of mono but of the whole OS.

And to answer the next, most likely question/remark (aka “But I can’t because of $FOO…”)

So what? You are the administrator of that box and it is your responsibility to know the life cycles and plan such updates accordingly at the appropriate time.
If you didn’t do that months ago, you just did a bad job here, so fix it.

Thanks for the replies!

Installed opensuse 11.1, things worked way smoother there.

Got everything installed. Now the problem is when i run the simias-server-setup i cant get through because it fails to get certificate.(probably because im doing something wrong)

Im just a student trying to help out with the wishes of the management, but im in way over my head with my limited knowledge.

Can anyone point me to a better tutorial preferrably with examples because i have a hard time following the official ifolder admin guide.

Thanks in advance.