If you have problems with knetworkmanager in 11.4

An unknown problem with NetworkManager-KDE, aka knetworkmanager, will sometimes
disable wireless even when ‘rfkill list’ shows no block. My “fix” for this is to
create a small script to stop and re-start knetworkmanager. To date, this has
worked every time.

The script has the following content:

# Restart knetworkmanager to re-enable wireless
killproc knetworkmanager
knetworkmanager > /dev/null 2>&1 &

Put the above information in a file named ~/restart_knetworkmanager, then issue
the command

chmod a+x ~/restart_knetmanager

That makes it executable, When you get “Enable wireless” grayed out and it is
not caused by any rfkill switch, then enter the command ‘~/restart_knetworkmanager’.

Very nice lwfinger, thanks for the script. By the way, if you place the script into ~/bin, then you can run it as just **restart_knetworkmanager. **Anyway thanks very much.

Thank You,