If upgrade to openoffice 3.0 in YAST, first remove 2.4?

I have Open Office 2.4 on my openSUSE 11.0 (it came with it) as shown in YAST and I just added the repository: Index of /repositories/OpenOffice.org:/STABLE/openSUSE_11.1 Now I want to upgrade to Open Office 3. Should I first remove 2.4 in YAST and then add 3?

If you have enabled the repo, when you go to yast>s/ware and filter the ooo repo for open office, it should give you the list of available software. Yast will now give you the choice of upgrading if you click the software you want. Since it is a suse repo, it will upgrade and take care of uninstalling the old version.

I’ve seen it recommended in some OOo fora, when changing from 2.xx to 3. I’m still on 2.4, though.

If the worst happens you can always reinstall 2.4 from the stable repository or even from the DVD (but then you should update).

11.0 and 11.1? Don’t mix OpenSUSE versions.

I would also delete the old version first. There have been some conflicts during the upgrade from 2.4 to 3.0. In some cases Yast handled it right, in others not.

See if you can first move to openSUSE 11.1 before doing this.