idle-time out command not working


I am using HDPARM -S to spin-down my hard-drive after a certain amount of inactivity but the command does not appear to do anything on one machine.

However, on another machine with an identical openSUSE 10.3 the command spins-down the hard-drive fine.

On that machine the Yast2 ‘etc/sysconfig’ says that it is set to ‘performance’ (*), so if anything it should not work, yet it does so perfectly.

On the other machine that I can’t get disk spin-down to work no matter what I do. In the Yast2 etc/sysconfig I have set the scheme to ‘powersave’ (*), and on both schemes I have checked that DISK STANDBY MODE is set to ‘powersave’ (**)

I know you can vary the number of seconds in HDPARM -S but i tried low numbers, 50 seconds and still no matter how long i wait and nothing happens.

I even tried HDPARM -Y (immediate sleep) and even that does nothing. Each time the system reports the command has executing successfully.

Any suggestions? The machine that it works is a Dell Dimension 2200 and the one that it doesn’t work on is a Gigabyte GA-7VM400M motherboard.

Many thanks,

  • System / Powermanagement / Powersave / General
    ** System / Powermanagement / Powersave / Scheme / Performance &
    " " " " / Powersave