IDLE can't import Tkinter

I recently installed openSUSE 13.2.

I installed Python 3.5 and then discovered that I could not run idle3 because Tkinter could not be imported.

I thought I would then install ActiveTcl8.6 to resolve that problem. But that didn’t resolve the issue.
As I later learned, I used the wrong uninstall program which was unable to access the install log and therefore failed.

Anyway, I then saw some advice on the Internet that recommended

  1. Running the configure on Python3.5
  2. Running make and make install after downloading Tcl
  3. Running make and make install after downloading Tk
  4. Running make and make install on Python 3.5

I downloaded Tcl8.6 and TK8.6 and followed the instructions above except that I ran configures before the makes on Tcl and Tk also.

This still didn’t resolve my problem and the make on Python3.5 didn’t seem to go right in my estimation so…

I ran a make clean, make, and make install on Python3.5.

My problem still was not resolved.

In the way of research, I have found that the _tkinter.o module is located in a very strange-looking directory of home/garrett/Downloads/Python3.5.0/build/temp.linux-x86-64-3.5/home/garrett/Downloads/Python3.5.0/modules

I have searched the entire system and have found no trace of
I am wondering where this comes from and why it was not downloaded?

I would appreciate advice on how to proceed from here in order to get Tkinter installed successfully.

Thank you.