id:6:initdefault -- Why? How?


I have a curious question about the default runlevel set in /etc/inittab. Let me give you the scenario that just happened:

I have a file server running on OpenSuse 11 that I wanted to attach a comms cable to so it can communicate with an APC Smart 700 UPS that it’s plugged in to. I went over to the server this morning and plugged in the serial cable (bought specifically for the UPS) and enabled and started the apcupsd service using Yast. The service stopped after a short while complaining that it couldn’t communicate with the UPS. I made sure all the settings in apcupsd.conf were correct and tried starting it again with the same result. I tried again with the cable type set to ‘simple’ instead of ‘smart’ and this time the service ran but wouldn’t detect UPS events so I set it back to ‘smart’ and was about to go away and contemplate the latest weather forecast when the UPS turn off and back on by itself (all plugs and cables checked out ok). Of course, this rebooted the server and when it tried to start again, it just rebooted again and again and again… Every time it tried to start, it would get to “The system has been … setup” and then “Features skipped … boot.cycle” and then enter runlevel 6 and reboot.

I booted into runlevel 1 and after some investigation found that runlevel 6 had been set as the default in /etc/inittab with the entry “id:6:initdefault”. So, with this in mind, I have a couple of questions:

  1. Has anyone seen this behaviour with the default runlevel being set to 6 with apcupsd?
  2. Is there any reason why Suse would set the default runlevel to 6?
  3. Can I check when certain users logged on (not just the last logon but a history) because I can only think that this has been set by someone by mistake – perhaps in my week off?

Many thanks if you read all of this! Any help, ideas or thoughts appreciated.


SUSE would never set initdefault to 6. 6 is the reboot level.

Probably some human did it. Maybe to annoy you.

The program “last” is used to examine the login history, which is in /var/log/wtmp. Hopefully it goes back far enough. If not, there are the rotated logs which are compressed.

Thanks ken. I’ll give ‘last’ a go.