icons screwed up in yast Software Management

I’m running latest Tumbleweed and after the last update the icons in Yast’s Software Management are almost invisible, they are there but it looks like only the outline is visible. Its darn near impossible to tell what is selected and what isn’t. Is there any way to fix this? I have played with icon themes but it makes no visible difference.

Bug has been reported, fix is on the way. You can still use YaST in the ncurses version:


su
yast

Great - Thanks for the info.

Thanks, will wait for the update too - icons are terrible now. Hard to understand what does they mean.

Can you provide a link to that bug report? This is still a very annoying issue and as far as i can tell by searching bugzilla its not being actively worked on. Seems to me a simple regression would fix this as it worked fine before a recent update.

Don’t have much tiime today, couldn’t find the bugreport. A workaround is to install a newer version of breeze-icons, run


kdesu systemsettings5

and apply the breeze-icons icon setting. This returns the icons in YaST Softwaremanagement.

MIND: Do not use YaST to update your Tumbleweed install, use


zypper dup

as per documentation

Could You provide screenshot how icons look for You please? This is my variant:


Аutodelete, autoinstall, autoupdate icons are very good with thick lines and understandable. Others have VERY thin lines in 1 px and very hard to understand what does they mean? Is it possible to make lock, installed, install, update icons with thick 2 px crosses, arrows, locks please? Thanks!

My “yast->Software Management” icons look like the last 2 icons in your post. I tried using the systemsettings5 to change to breeze icons and it didnt change anything

Mine looks like this, Breeze icon theme.

https://i.ibb.co/x8wdJGk/Screenshot-20181204-204053.png

Hmmm… I use Oxygen icon theme in KDE. Does it impact on YAST somehow which is running under root? How to install or select icon theme for the Yast or Software Management - not clear to me?

Hurray! Now it works for me too, I run:

kdesu systemsettings5
  • to runs settings for root.

Then selected Oxygen icon theme, restarted Yast, and now I see these icons which are very good for me:

Same here, once i read your post i realized there were separate systemsettings5 settings for user vs root