icons change in the system tray

sometimes icons in the system tray changes, they becomes colored as in one of the previous suse, and I suppose it is the why something like ctrl>alt>v and smb:// in dolphin stop to work, googling and reading around it seems to be related to kded or one of its modules crash, how can I restart kded without reboot or logout from KDE???
manythanks :slight_smile: ciao :slight_smile: pier

Correct. That indicates that kded is crashing.

To restart it, press Alt+F2 and enter “kded4”.

Do you get any crash dialog?
Try to disable some kded modules in “Configure Desktop”(systemsettings)->“Startup and Shutdown”->“Service Management”.
Maybe it’s bluedevil or kscreen that causes the crashes?

Or maybe KMixD in combination with pulseaudio:

I don’t remember crash dialogs, but I didn’t paid attention on it, I discovered thi now, I will note crash dialogs if it happens again, it is quite random, so I note it only when something doesn’t works

manythanks, I will try…:slight_smile: :slight_smile: :slight_smile:

…well, today happen twice, definetly no crash dialog, kded4 works, but not from alt>F2, may be becouse kded crash involve also it, I had to open konsole and launch kded4 from there.
I will try to stop some service to see if it happens again…
ciao :slight_smile: pier :slight_smile:

I too am finding this to be an issue. Kded4 will crash on me when plugging in or unplugging AC power and I find it rather annoying to have to manually restart kded4. I have already submitted a crash report, when I did get a dialog. I don’t get the crash dialog anymore.

Until the KDE team can fix this, does anyone know of a clean way to automatically restart the daemon when it does crash?


I have exactly the same issue here. Often pluggin AC OR resuming the laptop crashes kded4. Happens a lot. I do not want to start it myself because it happens several times a day and it gets annoying.
I have tried to start a cronjob to test the daemon and restart it when it is not found, but so far I have not been succesful with this.
Does anyone, anyone have a fix for this? please!

Maybe try to disable the “Powermanagement” service in Configure Desktop->Startup and Shutdown->Service Management?

You won’t be able to suspend your laptop via KDE then any more though. Closing the lid might still work, “systemctl suspend” or “systemctl hibernate” should work in any case.