Icon Strange behaviour

Greeting All,

For the past few days I have been playing (or rather fighting) with Leap 42.1.
I addition to the numerous issues that have been reported by others, I have a strange problem with launching applications from a desktop ICON.

I run the FOLDER view on the Plasma desktop. I have a number of ICONs for various applications. These all seem to work OK when they are run
from the Desktop. However, I also have a number of folders that contain other application ICONs. If I select ANY ICON that is contained in a folder,
the application will NOT start. Originally, I was getting some pop-up message about XFCE not loaded. However, after a number of system lock-ups and crashes,
a click on one of these ICONs will send all 8 of my CPUs into yaya land (around 80% load each). When this happens, it is time for a power down, as
the system is pretty much hosed.
If I drag ANY of these ICONs to the desktop, they work as expected. This behaviour ONLY happen when the ICON is in a folder.

The Desktop folder was copied over from my Suse 13.2 installation, where it worked flawlessly. The system was installed clean (not an upgrade).
The machine I am currently on is an AMD with an Asus MB and an NVIDIA display card. I’ve also tried installing on a Lenovo Thinkpad (Intel CPU and
graphics) with similar ICON behaviour.

Is there something I’m doing wrong, or is this another bug? I’m back to my 13.2 partition for the time being, as the Leap installation is pretty much
unusable.

Thanx in advance

Richard Rosa

You may want to recreate. Using KDE4 in Plasma5 may not work as expected :’(

When you say “recreate” do you mean recreate the “.desktop” files that underlies each ICON? If so, I tried that (using “Create Link To Application”) with the same results.
To my knowledge (which sometimes is a bit sketchy) these files are just text with info on the app to run and the ICON to display.
I’m not sure how they could be tied to a specific version of KDE.

Richard Rosa

Answering my own post:

It turns out the issue was with Dolphin When the Application ICON (.desktop) is in a folder, it appears that Dolphin ( or whatever file manager is selected)
controls what you do when it is selected.

Somehow in the confusion of pop-ups on this I managed to set the action on selection to something that doesn’t work right AND to make this the default.
I’m not sure what that action was, but turning the Confirmations on for Executing scripts/desktop files allowed me to select the right thing to do.

Richard Rosa