ICH8 intel has very low/ no sound-suse 11

I have a lenovo m55 desktop with open suse 11 and I have no sound from my speakers.
My info says intel Q963 with an ich8 for sound.
I have tried with the volume all the way up on KDE 3.5 desktop.

Got it working but it’s sounds scratchy-

Well done on sorting this your self.

In general its best to keep your software volume controls down fairly low, and use your hardware volume to increase the sound level. This will reduce the scratchiness. Also, some applications (such as vlc) have audio controls that are very sensitive to scratchiness, and are best kept very low.

I had a gnome desktop and had no luck with sound. I did a fresh install and used kde 3.5 and the sound is working good now.
I had to mess around with the kmixer settings to get it working.