IBM X31 suse 11.1 No Sound with Intel ICH4 card

After installing suse 11.1 my sound no longer works. This worked OK with 10.3 and 11.0.

I have followed the solutions given in the suse SDB audiotroubleshooting but to no avail, Here is the output from the various commends and the addresses of the output from alsa commands plus card info from alsa website:

Module snd-intel8x0

Module for AC'97 motherboards from Intel and compatibles.
		* Intel i810/810E, i815, i820, i830, i84x, MX440
			ICH5, ICH6, ICH7, ESB2
		* SiS 7012 (SiS 735)
		* NVidia NForce, NForce2, NForce3, MCP04, CK804
			 CK8, CK8S, MCP501
		* AMD AMD768, AMD8111
		* ALi m5455

ac97_clock	  - AC'97 codec clock base (0 = auto-detect)
ac97_quirk    - AC'97 workaround for strange hardware
	    See "AC97 Quirk Option" section below.
buggy_irq     - Enable workaround for buggy interrupts on some
                motherboards (default yes on nForce chips,
	    otherwise off)
buggy_semaphore - Enable workaround for hardwares with buggy
	    semaphores (e.g. on some ASUS laptops)
	    (default off)
spdif_aclink  - Use S/PDIF over AC-link instead of direct connection
	    from the controller chip
	    (0 = off, 1 = on, -1 = default)

This module supports one chip and autoprobe.

Note: the latest driver supports auto-detection of chip clock.
if you still encounter too fast playback, specify the clock
explicitly via the module option "ac97_clock=41194".

Joystick/MIDI ports are not supported by this driver.  If your
motherboard has these devices, use the ns558 or snd-mpu401
modules, respectively.

The power-management is supported.

cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.17.

cat /proc/asound/modules
0 snd_intel8x0
1 snd_intel8x0m

cat /proc/asound/cards
0 [I82801DBICH4 ]: ICH4 - Intel 82801DB-ICH4
Intel 82801DB-ICH4 with AD1981B at irq 11
1 [Modem ]: ICH-MODEM - Intel 82801DB-ICH4 Modem
Intel 82801DB-ICH4 Modem at irq 11

/usr/sbin/alsa-info.sh
http://www.alsa-project.org/db/?f=64895000e18d3e1f424ba3cac3150b23bf932350

bash tsalsa
tsalsa.txt - nopaste.com (beta)

Look forward to any comments.

Bill Read

Thanks, … I note this in your mixer:

Amixer contents for card 0 [I82801DBICH4] _____________________________________
amixer set ‘External Amplifier’,0 off Does switching the external amp ON make any difference?

Also, when testing your sound, please use the following speaker test: speaker-test -c2 -l5 -twavIf your sound functions, you should heard a lady’s voice saying ‘FRONT LEFT’,‘FRONT RIGHT’ five times.

Please also try that test with root permissions.

You may also find it beneficial to install alsa-firmware. Did you try working your way through the audio troubleshooting guide: SDB:AudioTroubleshooting - openSUSE

If trying the suggestions in that does not help, then please post here the output of:
rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound
also, are you using KDE3 ? or KDE4 ? or Gnome ?

Hi oldcpu,

In answer to your questions:

Yes I tried with external amp on but with the same result.

I have been testing using the speaker test you suggested from the start.

I have worked my way through SDB:AudioTroubleshooting - openSUSE. But it did not cure the problem.

Here are the results you requested:

rpm -qa | grep alsa
alsa-1.0.18.git20090106-2.1
alsa-plugins-pulse-1.0.18.git20090106-1.5
alsa-utils-1.0.18.git20090113-1.1
alsa-oss-1.0.17.git20080715-2.9
alsa-tools-1.0.18.git20081201-1.7
alsa-plugins-1.0.18.git20090106-1.5
alsa-firmware-1.0.17.git20081202-2.3
alsa-plugins-jack-1.0.18.git20090106-1.5

rpm -qa | grep pulse
libpulse-mainloop-glib0-0.9.12-9.6
pulseaudio-esound-compat-0.9.12-9.6
libpulsecore4-0.9.12-9.6
pulseaudio-module-lirc-0.9.12-9.6
alsa-plugins-pulse-1.0.18.git20090106-1.5
pulseaudio-utils-0.9.12-9.6
pulseaudio-module-jack-0.9.12-9.6
libpulse0-0.9.12-9.6
libpulse-browse0-0.9.12-9.6
pulseaudio-0.9.12-9.6
libxine1-pulse-1.1.15-20.8
pulseaudio-module-zeroconf-0.9.12-9.6
pulseaudio-module-bluetooth-0.9.12-9.6
pulseaudio-module-x11-0.9.12-9.6

rpm -q libasound2
libasound2-1.0.18.git20090106-2.1

uname -a
Linux Read-Zimm 2.6.27.7-9-default #1 SMP 2008-12-04 18:10:04 +0100 i686 i686 i386 GNU/Linux

cat /etc/modprobe.d/sound

options snd slots=snd-intel8x0

W60f.UInOZMzYosD:82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC’97 Audio Controller

alias snd-card-0 snd-intel8x0

The only further thought I have is that ICH4 is no longer shown in the latest alsa config guide as in my first post- can thay have dropped support for this card ?

Oops sorry forgot to tell you I am using suse 11.1 with KDE 3.5

Thanks. This shows the problem. It appears to me you sent only 3 zypper commands, and not the 6 recommended. Specifically, you missed installing alsa-driver-kmp-default. Take a look again at the update URL that the troubleshooting guide provides for 11.1: Alsa-update - openSUSE

Please install alsa-driver-kmp-default.

I am having the same problem - no sound, with the same chip - ICH4, but on an HP Pavilion, instead of an IBM X31. It also worked with a previous release (10.0?). This was a clean install. I have followed the trouble shooting steps mentioned above with no luck. The output from tsalsa has been posted at tsalsa.txt - nopaste.com (beta)

Can you start a new thread on this? User BillRead had different hardware (with an AD1981B) while your PC has an ALC658D hardware audio codec. Mixing two different problems in the same thread can be very confusing.

When you start the new thread, please include the output of running the “alsa-info.sh” script twice with root permissions: /usr/sbin/alsa-info.shthe first time it will ask you to update the script. Do so. The second time you run it, the script will paste your audio setup configuration to a paste site and give you a URL. Please paste the URL in the new thread. Just the URL.

Also please include the result of the following commands (so we can see what software audio/related rpms/configuration you have):
rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound

New thread started at HP Pavilion a1209n ICH4 no sound - openSUSE Forums