i915 error at boot: timed out waiting for forcewake ack request


After a zypper dup then reboot, my laptop hanged at boot time and had the following error:

drm:fw_domains_get [i915] *ERROR* render: timed out waiting for forcewake ack request.

Do you guys know what does that mean?

I tried to boot using kernel parameter nomodeset. The error above went away but it still hanged there.

I tried using acpi=off and it successfully logged me in. I re-installed xf86-video-intel, all xorg-x11*, and even Mesa packages (although I don’t quite know what’s that for). Then I reboot again without acpi=off and it still hanged there and same error.

So my question is, what exactly does this i915 refer to? Intel GPU? Shouldn’t its driver be xf86-video-intel? I re-installed it many times and thought the error would go away but it did not.

What do you guys think? Recently I got many Intel errors, which I thought would be very unlikely. I got rid of some, but others like this one I just don’t know what it is.

Btw, I have bumblebee and bbswitch and already turned off Nvidia card. As far as I know, this method works properly, based on the opensuse tutorial.

Thank you very much!

The message comes from kernel so reinstalling user level packages is likely pointless. If you can boot with previous kernel that looks like kernel regression and you need to submit bug report to have it fixed.

Thanks for your reply. Sadly this is a newly installed tumbleweed and I have no older kernels to fall back to… Anyway I re-installed the system and wouldn’t do any zypper dup for a while and hopefully when 4.15 comes out this error could go away. If it does not, I can still fall back to the current, most-newly-installed kernel.

So sad, but it’s okay.

Thank you again.