I wish to get rid of my nomodeset dependency


I’m very new to Linux. I’ve actually made my first install today. To install I had to use “nomodeset”. I still need to use it to boot up and see anything but a black screen. I have downloaded all current updates/upgrades.

My PC specs are as follows:
Ryzen 5 3600
Radeon RX590
2 Ms.2 1TB SSDs

Any ideas on how I rid myself of this dependency?

Best regards

In grub2 press e, goto the line with the entry, remove the entry and press F10 to boot.
Does this boot into a working screen?

I’ve tried that. Sadly no dice :frowning: I’m starting to think my GPU is damaged.

If you have installed with “nomodeset”, perhaps you do not have the AMD graphics drivers installed.

I look after a couple of iMacs with similar embedded graphics chipsets. They use the “amdgpu” driver.

rayh@yoga3:~> bla01 inxi -G
12Graphics:  12Device-1 AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] 12driver amdgpu 12v kernel 
           12Device-2 Apple 12type USB 12driver uvcvideo 
           12Display 12server X.org 1.20.3 12driver amdgpu,ati 12unloaded fbdev,modesetting,vesa 12tty N/A 
           12Message Advanced graphics data unavailable in consn AMdole. Try -G --display 
rayh@yoga3:~> bla01 sudo /usr/sbin/hwinfo --gfxcard
18: PCI 100.0: 0300 VGA compatible controller (VGA)
  [Created at pci.386]
  Unique ID: VCu0.Zl1HExY7WWD
  Parent ID: vSkL.+UHC75sgwM8
  SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:00.0
  SysFS BusID: 0000:01:00.0
  Hardware Class: graphics card
  Model: "Apple Radeon Pro 570"
  Vendor: pci 0x1002 "ATI Technologies Inc"
  Device: pci 0x67df "Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]"
  SubVendor: pci 0x106b "Apple Inc."
  SubDevice: pci 0x0163 "Radeon Pro 570"
  Revision: 0xc5
  Driver: "amdgpu"
  Driver Modules: "amdgpu"
  Memory Range: 0xc0000000-0xcfffffff (ro,non-prefetchable)
  Memory Range: 0xd0000000-0xd01fffff (ro,non-prefetchable)
  I/O Ports: 0x3000-0x3fff (rw)
  Memory Range: 0x92600000-0x9263ffff (rw,non-prefetchable)
  Memory Range: 0x92640000-0x9265ffff (ro,non-prefetchable,disabled)
  IRQ: 40 (1202429 events)
  Module Alias: "pci:v00001002d000067DFsv0000106Bsd00000163bc03sc00i00"
  Driver Info #0:
    Driver Status: amdgpu is active
    Driver Activation Cmd: "modprobe amdgpu"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #13 (PCI bridge)

Primary display adapter: #18

(“bla01” is just a ssk connection yo a remote iMac)

Here is a list of the relevant packages installed – you can either use this zypper command or the YaST Software Manager to check and install them I do not know if this is optimal for you, it is just whart is installed on a working Leap-15.2 system with an AMD RX570 chipset

 #  zypper in libvulkan1  libvulkan_radeon  libdrm_amdgpu1 libdrm_radeon1 libvdpau_radeonsi  xf86-video-amdgpu

Thanks for your reply.
I’ve installed the latest drivers from AMDs page using the amdgpu-pro-install script. I cannot boot without nomodeset because I still get the black screen without it. Also suddenly every window/program I close… well the system says they crash. This is fixed by uninstalling the drivers. Strange things are a foot.

AMD-pro does not work well remove it

Add the following grub options (at grub press e to edit.) and remove nomodeset;

plymouth.enable=0 amdgpu.dc=0 amdgpu.exp_hw_support=1

During OS install you got Mesa 3D drivers.
Maybe you have to uninstall them, then install amdgpu-pro drivers.
IMHO you don’t need to install amdgpu-pro without OpenCL.

Thank you! That worked a treat.

I shall try this. I’m not sure how to do the uninstall but it will be a fun experiment. Like I said I’m very new to this.
Thank you!

Amdgpu-pro install script created special repo “AMD amdgpu Pro local repository” with its files.
You can manage packages for Mesa 3D or amdgpu-pro with YaST.

So now try removing the amdgpu.dc one, test, not sure if you want plymouth running, so try removing that. Hopefully it’s the exp one that will work and all you need.

Plymouth could be removed without issues. But amdgpu.dc had to stay. Thank you!