I was connected to router but not internet, why?

Previously it’s work well but suddenly internet go down. I don’t know why. It’s a shared connection, and all other computer are using the same version (opensuse 11.0)and they can connect to internet. The weird thing is my computer can connect to the router (when I type the router IP, it can access to the router), but it just cannot connect to internet. How can it be? Does anybody have any idea?

Possible nameserver issue? Check the output of

cat /etc/resolv.conf

Probably a good idea at the same time to report also what you get from this command
sudo /sbin/route

This are the result, hopefully it can help.
cat /etc/resolv.conf



search site

sudo /sbin/route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface * U 0 0 0 eth0
link-local * U 0 0 0 eth0
loopback * U 0 0 0 lo

ps: my router ip is

The config of the network interface needs to be restored because it’s gone.

Set these in Yast → network devices → network settings.
Routing → default gateway →
Hostname/DNS → set to: change hostname via dhcp + write to /etc/hosts + update dns via dhcp + hostname (same as command prompt) + domain name if applicable

In overview → Edit:
general → activate at boot time, firewall → external zone
Address → dhcp

That’s about it.

This is similar to a problem I am having, but I cannot use this solution.

I have tried to use opensuse 11 in a windows environment and cannot surf the internet. Network manager shows I am connected to the wireless lan.

This is happening at school and at a hotel with public wifi. I don’t know the default gateway in either of these places. At school, a proxy is used and I have set Firefox with the proper info on the proxy. The hotel has no proxy. It does redirect to a TOS page before it will allow you to surf.

If I load up Win XP, the public wifi works, including the redirect. It will not work in suse. The school network also works in Win XP.

Any ideas?

I did all of that, and it did add the line
default UG 0 0 0
to route but resolve.conf did not change (even after a reboot). I logged into the router, grabbed the 3 nameservers, unchecked update DNS data via DHCP, and hand entered them into network settings. That did edit resolve.conf and get me on the web, but as soon as my ISP changes them I’m hosed. Any Ideas? Thanks

Possibly could work if you changed the name servers to opendns – worked for me once when my ISP’s servers went down. They are IIRC