I uninstalled yast2 accidenttly

I manage to reinstall it with yast. It wont start from the menu but i can launch it from a console. But a got this message:

QStandardPaths: wrong ownership on runtime directory /run/user/1000, 1000 instead of 0

And i do not know how to fix this.

I get that message. It doesn’t seem to cause any problems. Just ignore the message.

On Tue, 01 Jan 2019 15:56:03 +0000, Asimov wrote:

> I manage to reinstall it with yast. It wont start from the menu but i
> can launch it from a console. But a got this message:
> QStandardPaths: wrong ownership on runtime directory /run/user/1000,
> 1000 instead of 0
> And i do not know how to fix this.

If you uninstalled it, you can use zypper to reinstall it.

What is the output from:

rpm -qa | grep -i yast


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

i already done it with zypper. I can launch it from a terminal. But i can not launch it from the Plasma’s menu.

Specialy when it is about a GUI interface, where nobody here can see what you do and see, detailed description is needed to give others any idea about your problem.

Isn’t the item in the Plasma menu at all?
Is it there but when you click on it YaST is not started?

Please provide the output asked for. Installing ‘yast’ is not enough.
Plus, show

rpm -qa | grep yast2

Yes, Yast is visible in the menu. But a can not lunch it from the menu. I have to open a terminal and write yast2 to have it.


You’ll need at least the following YaST packages:

  • yast2
  • yast2-add-on
  • yast2-alternatives
  • yast2-control-center
  • yast2-control-center-qt
  • yast2-core
  • yast2-packager
  • yast2-pam
  • yast2-perl-bindings
  • yast2-pkg-bindings
  • yast2-ruby-bindings
  • yast2-services-manager
  • yast2-sudo
  • yast2-transfer
  • yast2-update
  • yast2-x11
  • yast2-xml
  • yast2-ycp-ui-bindings
  • yast2_basis

Once those packages are installed, you should be able to use the following Patterns to pull in the rest of the YaST environment:

  • patterns-yast-yast2_basis
  • patterns-yast-x11_yast
  • patterns-kde-kde_yast

You may also need:

  • autoyast2-installation


The file


Which is owned by the root user, might be a good start if you want to look for the packages that has been removed.
(Just replace the remove with install to find out which packages got installed.)

NOTE: The code below assumes that you’re using the default shell which is bash.

For example If you want to look for the packages that has been remove today, a filter can be used (pattern matching)

grep "$(date -d'**now**' '+%F').*|**remove**" /var/log/zypp/history

From the last three days.

grep "$(date -d'**3days ago**' '+%F').*|**remove**" /var/log/zypp/history

From last month.

grep "$(date -d'**last month**' '+%F').*|**remove**" /var/log/zypp/history

Since GNU date is being used in the above code, I suggest you look at the info pages for more info about some examples on which words/syntax is accepted when searching for date.

info date

It’s a “GNU thing” so don’t ask me why info pages and not man pages. :wink:

When searching for just the package name which has been removed. Like for example you want to search for the word yast ANY WHERE in the package name.
(Just replace the remove with install to do the opposite.)

grep ".*|**remove**:space:]]*|**.*yast**" /var/log/zypp/history

Note that grep is using BRE by default unless you tell it to use ERE but that is another story.

man 7 regex
grep --help
man grep

for more info about BRE, and btw if I’m not mistaken Leap 15.0 does not come with the Linux man pages so you might need to install the package




I did all the reinstallation. But i have the feeling that my menu is set on a broken link. Can you tell me the directory of the binary ?

I will keep this one in mind the next time in update go south.

In your initial post you mention “QStandardPaths:” – therefore I’m assuming that, your user GUI is KDE …

For the case of KDE Plasma 5, the menu command for YaST is “/usr/bin/xdg-su -c /sbin/yast2”.

The problem is still not solved. And i really do not know what missing.

susepaste yast.txtPasted as:

I did try /sbin/yast2. And i think i found the problem:

Yast.rb is unable to import a file in “import_pure”:

Line 186.

The complete message:


internal error. Please report a bug report with logs.
run save_y2logs to get complet logs
Details: failed to load module 'PackageCallbacks' due to failed to load Module 'SignatureCheckCallbacks' due to: indefined method 'message' for nil:Nilclass caller: usr/lib64/ruby/vendor_ruby/2.5.0/yast/yast.rb: 186 in 'import_pure'

You haven’t, yet, completely restored everything needed by YaST2:

 > rpm --query --whatprovides /usr/lib64/ruby/vendor_ruby/2.5.0/yast/yast.rb
 > zypper info --requires yast2-ruby-bindings
Loading repository data...
Reading installed packages...

Information for package yast2-ruby-bindings:
Repository     : Haupt-Repository (OSS)
Name           : yast2-ruby-bindings
Version        : 4.0.6-lp150.1.1
Arch           : x86_64
Vendor         : openSUSE
Installed Size : 421.9 KiB
Installed      : Yes
Status         : up-to-date
Source package : yast2-ruby-bindings-4.0.6-lp150.1.1.src
Summary        : Ruby bindings for the YaST platform
Description    :
    The bindings allow YaST modules to be written using the Ruby language
    and also Ruby scripts can use YaST agents, APIs and modules.
Requires       : [26]
    yast2-ycp-ui-bindings >= 3.2.0
    yast2-core >= 3.2.2


  1. Please, forcibly, reinstall “yast2-ruby-bindings” and also, forcibly reinstall everything that package requires.
  2. For the case of the packages “yast2-ycp-ui-bindings” and “yast2-core”, you’ll also have to forcibly reinstall everything they require.
  3. In addition, you may have to forcibly reinstall everything that Ruby requires.
  4. In addition, with the user “root”, execute “rpm --verify --all” — take special note of all the “missing
    ” alarms — if you have things such as WordPress installed, you’ll have to dump the rpm output to a file …