I uninstalled nouveau drivers (yast sw management) and now I don't have Graphical Login (init 5)

I was trying to install nvidia quadro drivers for notebook (lenovo w series) and that requires the nouveau drivers to be uninstalled (the reverse engineering thrird party drivers for nvidia on suse). The official opensuse repository seems to have gforce drivers in place not quadro therefore i was not taking advantage of it.

My system has an internal intel graphics card besides the discreet nvidia quadro m series, and it can run nvidia optimus to switch between the two.

I selected the Intel graphics card and booted into Linux and now I could uninstall the nouveau drivers. So I tried running the official nvidia package for installtion (tty as root (init 3)) but it kept complaining about nouveau. then i restarted and on booting in again I was presented with the message that the Login files were corrupted so the desktop (i have both kde and gnome) gui cannot load, therefore I was stuck at login at init 3 (i can access as root, only no init 5 gui)…

then I tried booting with the discreet graphics, also with optimus, and with the internal intel one, whilst re-installing the nouveau packages:
zypper search nouveau
zypper install nouveau<packages>

It installed dependencies and some other packages as well but I still cannot go into full graphical mode.

It is a just installed system which I installed via network (I have the iso image but didn’t have a flash disk large enouch or a dvd to put 4.3 GB into).

So the two obvious questions are:

  1. How can I restore the Graphical login (and therefore the GUI desktops) in opensuse leap 42.3 ? that is: how can I repair my current installation that is almost error free had it not been for me messing up with nouveau?

  2. If and when i restore that system how can i install the nvidia quadro drivers?

two very wide and difficult questions i know but woulnd’t know where to start (sometimes the login into the system won’t be possible as it complains about the power management with the graphical devices, so it’s all to do with drivers and what it got messed up with
me manually removing the nouveau drivers)

thanks.

For Optimus hardware make sure that you read this guide
https://en.opensuse.org/SDB:NVIDIA_Bumblebee

What is the name of the driver installer?

Uninstalling nouveau probably isn’t necessary.
The driver installer blacklists nouveau.
The trick is to boot with “nomodeset” and “3” before installing:

https://en.opensuse.org/SDB:NVIDIA_the_hard_way

Did you try starting from another snapshot at GRUB2?

nouveau might be still blacklisted.
See if /etc/modprobe.d/nvidia.conf [FONT=arial]still exists.[/FONT]

I was trying with 4.4.114-42 and 4.4.104.39

Unfortunetly I am now getting stuck at:

bbswitch: loading out-of-tree module taints kernel
bbswitch: found discreet VGA device 000:01:00.0

and then i cannot longer boot into the perfectly previosly working system.

(I’ll try re-using the EFI bootloader entry … the one I am using I addded it myself manually with efibootmgr)

I should have read that before.

now I’m having problems to even boot into the system and thinking to re-install/go red-hat instead (I have worked proffesionally a lot with suse enterprise in the past and I can say that i like it a lot but this nvidia drivers thing has always been problematic… I will try to re-gain access and see if I can do something like that (the suse nvidia guide)…

Having said that, the grub2 edit options therein seem to be related to a MBR installation but I have a EFI System and a boot partition. I will have to check if I can boot without nouveau in uefi.

Graphics changes do not effect boot methods so not sure what is up with that

You can always try boot to nomodeset

At boot prompt press e find line starting linuxefi go to the true end (it wraps) add space and nomodeset press F10 to continue boot should then use fallback drivers for that boot.

I suppose the question is what you did actually uninstall.

You can uninstall the nouveau Xorg driver (xf86-video-nouveau), though that’s not necessary as nvidia is preferred anyway, or the Mesa nouveau OpenGL driver (Mesa-dri-nouveau).

The only thing that conflicts with nvidia is the kernel module though, which you cannot uninstall at all as it is part of the standard kernel package.

BUT: if you’d uninstall libdrm_nouveau2, it will also remove large parts of the graphical system (on my intel system here it would uninstall 1275 packages including everything related to KDE or Qt).

If that’s what happened, a reinstall (or “Upgrade”) might indeed be the best option.
You can of course manually install the missing packages in text mode, probably it would help to just install the pattern corresponding to the desktops you want to use in YaST (which should still work in text mode).

/var/log/zypp/history may be helpful in finding out what was removed.

That !

Exactly. I did uninstall the libdrm_nouveau2 and the mesa dri. however I was not prompted about the huge dependencies list you mention. I later re-installed the libdrm_nouveau2 package via zypper (and mesa packages) but the dependencies were very few.

As I moved on with the troubleshooting (actually hw reset to make it try to boot) I was stuck in the system trying to load locale

I thus have reinstalled the system but will give it another try with the nvidia quadro drivers in the not “so hard manner” to see if I can find my way around it.

It is indeed very frustrating installation to say the least the fact that the official nvidia drivers are now a huge workaround (if it works) from being successfully deployed.

I installed the suse nvidia driver from the suggested repository at Index of /opensuse/leap/42.3 adding it manually from yast-sw management, uninstalling the Backported drm kernel modules (zypper rm drm-kmp-default) and installing devel c_c++ and kernel patterns (zypper in -t pattern devel_C_C++ devel_kernel), alongside libelf (zypper in libelf-devel) all found in the nvidia hard way guide and then later as suggested by you in other post, i did zypper up and then it bringed the correct nvidia packages (although it installs geforce drivers not quadro drivers… so the nvidia installer prompts me to uninstall the current nvidia driver (specially the gfx) but anyway… I will see if I try that later on a tty init 3. As of now I will leave it like that but it is still frustrating not to be able to install the official nvidia drivers outright that are intended for CAD and GPGPU usage.)

The issue is solved for now, thanks be to God.

Thank you to all that posted and thus helped.

(note: I don’t know how to tag as solved)

What is your video card?

hwinfo --gfxcard | grep Model