I try to boot but the screen goes off - works with failsafe mode though ???

Hello there,
well, I’ve got this really huge problem, which I really want to solve, because otherwise I might even switch back to ubuntu. >:(

So here we go. Yesterday, I had a problem with mounting nfts hard drives and solved (you guys solved it actually) it by adding ntfs to the /etc/filesystems file. (I doubt, that it has anything to with that, but it might, so I will just tell you everything I did)

I added an ATI driver repository as well, which is probably the key to this problem.(or at least something with drivers) → not sure if I installed anything

So however, the problem is now, that the screen tells me, the signal would die just before the log in screen appears. (“No signal” → screen goes to standby → can’t wake it up again–> no opensuse for me)

I’m now running the system in some sort of safe mode and it works, but I think, that it is using my on board graphic card and not the actual “radeon hd 5600”, which provides much better quality.

→ just looked it up, yes it is using the crappy one (on board)

So here’s the question:
First of all why does this error occur(worked fine before) and secondly how can I fix it?

If you need more details, just ask me.

Thanks for your help :wink:

PS: didn’t know what to search for in the forums, so if another thread provides the solution, please just post the link)

This might help:
when I select “Desktop – openSUSE 11.4 - some numbers” it gives me this under Boot Options below: vga=0x345

any suggestions → I’ve got a desktop resolution of 1050x1650, but when I change it to that, there’s no difference, the screen goes off as well, shortly before the log in should come up.

well it says, this would be an undefined code, so I’ll try something else.

I tried it out, but it still doesn’t work → still says undefined
Do I have to install some sort of resolution package? → I can still access the pc using safe mode

What happens when you select the failsafe option?


Can you post the result of this command please :

hwinfo --gfxcard | grep -i -e model -e driver

Can you try booting with nomodeset enabled like this : http://en.opensuse.org/File:Nomodeset-example.jpg

Look, I can still boot ( I think I mentioned that), but just in the failsafe mode. I suggest that this command is looking for ati drivers. The problem is, that my actual graphic card isn’t recognized in the failsafe mode, or do you mean, that I should enter it, when it says: “enter a video mode or scan”?

Is there really nobody out there with some kind of solution?

Oh man, I guess I just have really bad luck…
Kubuntu is waiting…

So thanks for your efforts regarding this problem :slight_smile:

Is there really nobody with a solution? :question:

Did you tried with the nomodeset like I told you earlier ? You didn’t gave us the result of the command I told you either ?

You know, we can help, but you have to follow the advices given. :slight_smile:

You have to provide use with more info. Sorry but we just can’t see over your shoulder.

Since you can get in with failsafe, install the proprietary driver for your card. If you don’t know how read

openSUSE Graphic Card Practical Theory Guide for Users

I’m sorry, I got a bit unpolite, this just really drives me crazy.

So I’ll try to get the drivers for it, but I just really don’t understand why the system suddenly needs some drivers, because it worked fine before. Ok, that was a bit unclear. I searched(when the whole thing was still working) for drivers and noticed, that they installed themselves by default. I’m just not sure, that the drivers are the actual problem.

I’ll search for them anyway.

Please read the link I gave you. there are numerous drivers. If you do nothing you get the open source radeon driver there is also the radeonhd driver and the vga driver and the fbdev driver. Then at last there is the propritary driver from ATI(now AMD). In theory any of these should work but it appears that the new kernel may have broken the radeon driver for your card. Simply adding the AMD repo is not enough you actually have to install it.

So we need to know what driver is being actually used and the hardware etc. Otherwise we are just guessing.

All ati packages are installed, but maybe, exactly that is the problem, I will jsust deinstall them.(just a try)

I pasted your command and just nothing happened: No error, no installation…simply nothing.

I’ll tell you, if I can reboot, after deleting the ati packages(I know it soundes weird, but I found some similar problems, with my graka)

Just noticed your post, I’ll search for them
→ it#s an radeon 5670 not 5600 sry about that

thanks :slight_smile:

to use

hwinfo --gfxcard | grep -i -e model -e driver

you must become root by typing
su - (note the - )
and then the root password
then the command

I just put a sudo in front of it and it always says sudo: hwinfo → command not found

However, I looked for the drivers, but my card is not supported plus the driver was already installed.–> xorg-x11-driver-video-radeonhd

sudo does not work the same in OpenSUSE as in xbuntu. Use the su command with the dash to get the full root environment.

If your graphic card needs the latest ATI proprietary driver, you can use atiupgrade to install it:
Upgrading ATI driver with atiupgrade


  • you have to specify the driver version on the command line, as I haven’t updated the script yet:
atiupgrade 11-4
  • the script won’t work if you don’t have a network connection in console mode. As it is becoming a recurrent issue, I’m working on a new version. If you’re not using the networmanager, it should be fine.

wow, didn’t know that :smiley:
, thanks for informing me.

So here’s the result(finally :slight_smile: ):

Model: “ATI 0x68D8”
Driver: “fglrx_pci”
Driver Modules: “fglrx”
Driver Info #0:
Driver Info #1:

→ Sorry, wrote this, before you posted the driver update, so should I do the driver update now, or search for another package?

I upgraded the drivers as it was shown in the ink. Let’s have a look if it works

→ still not working…

which linux distribution would you recommend apart from openSUSE?

→ I gave up now and I have to say, that I really enjoyed the community of openSUSE. This is a really nice forum with a lot of geniuses.