I think there may be something wrong with packman

Hi all on a spare computer today I loaded openSUSE 11.3 x86_64 with KDE 4.4 on it. First thing I did after installing all updates was follow the multi-media and restricted format installation guide for 11.3 found at:

Multi-media and Restricted Format Installation Guide

Here is my zypper lr -d:

# | Alias                               | Name                                | Enabled | Refresh | Priority | Type   | URI                                                             | Service
1 | Updates for openSUSE 11.3 11.3-1.82 | Updates for openSUSE 11.3 11.3-1.82 | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/11.3/                       |        
2 | libdvdcss                           | libdvdcss                           | Yes     | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/11.3/                            |        
3 | packman                             | packman                             | Yes     | Yes     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/misc/packman/suse/11.3/            |        
4 | repo-debug                          | openSUSE-11.3-Debug                 | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/11.3/repo/oss/  |        
5 | repo-non-oss                        | openSUSE-11.3-Non-Oss               | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.3/repo/non-oss/    |        
6 | repo-oss                            | openSUSE-11.3-Oss                   | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.3/repo/oss/        |        
7 | repo-source                         | openSUSE-11.3-Source                | No      | Yes     |   99     | NONE   | http://download.opensuse.org/source/distribution/11.3/repo/oss/ |

After successfully adding libdvdcss repo, installing libdvdcss and adding packman repo I did tried to install the packages from packman:

zypper in libavcodec52 libavdevice52 ffmpeg libdvdnav4 libdvdread4 libquicktime0 libxine1 libxine1-codecs libxvidcore4 mplayer vlc w32codec-all xine-ui xvidcore

I have done this before and it works fine but today I get all these “inferior architecture” errors. I have copied and pasted these errors into pastebin:
linux-muyd:~ # zypper in libav - Anonymous - 6JtQnNDa - Pastebin.com

Does this mean that this is a problem with packman or is it just me?


I’ve seen this in the past twice.

Once when Packman had an incorrect dependency in a specific package. Try installing those packages ONE AT A TIME to see which one is causing the dependency hiccup.

The SECOND time I encountered this was when I had an inappropriate i586 package installed, and when trying to resolve the dependency problems, the openSUSE software management would have this difficulty.

How about checking to see if you have any 32-bit packages installed that could be causing this? What do you get from typing:

rpm -qa | grep 686

I get no packages from that command.

But if I get a small number if I type

rpm -qa | grep 586

In my case, I get:

oldcpu@corei7:~> rpm -qa | grep 586

Still, on a 64-bit PC, one should have very very few i586 packages. How many more do you get than those?

My guess is a packing problem ( ? ) with xine ? and its worth narrowing this down to a specific package.

Hi oldcpu thanks for your reply. I have looked in YaST at each individial package that is listed to install in the guide and when I came to libxine1 I found that there was no 64 bit version for packman under versions:

However when I browse the repo directly:


and go to the x86_64 directory there is a file called libxine1-1.1.19-1.pm.44.5.x86_64.rpm but I don’t know why it doesn’t show in YaST

To answer your other question:

andrew@linux-muyd:~> rpm -qa | grep 586
andrew@linux-muyd:~> rpm -qa | grep 686


I could not update from Packman today yet. This actually happens quite often. That updates are there but _64 bit packages are missing. All you can do is wait it out. Don’t install 32 bit in place of your 64

Hi caf thanks for reply i’ll wait it out. Hopefully it gets fixed soon. Is it a possibility to go and download and install the 64 bit rpm’s manually from the repo?

That’s also my experience. Most of the times this has happened, it was fixed in a day. Meanwhile the KDE 45 repos are flooded with KDE packages depending on Qt47, whilst that is not yet in the same repos. We’ll see.

Is it a possibility to go and download and install the 64 bit rpm’s manually from the repo
Because they are not there

With the kde45 mess as well it’s noobs nightmare out there

My guess is it may need all of its 64-bit dependencies in place before it shows up as a possible update? There may be a dependency missing so it can not yet be resolved as an update.

A agree with caf4926 and Knurpht, that it is best to wait it out.

I confess, cynical lazy person that I can be at times, I often wait for a week or more before I apply new updates. I like others to encounter the problems (if any) before I do, and hence I read their comments on the forum and thus don’t waste my time when there is a glitch :slight_smile: … (although that is not exactly true, as I often join the problem solving thread, and hence end up spending time after all … )

… ergo my wait and see approach is not really a wait and see approach. Another oldcpu self contradiction. :frowning:

Thanks for all your help caf4926, oldcpu and Knurpht. Hope the KDE 45 and Packman repos are fixed soon :slight_smile:

Just to let everyone know the packman repo is fixed. Ran ‘zypper in’ again and it worked! :smiley: