I should say "Good bye" to BackInTime?

tumbleweed release 20200902

Apparently technology has morphed past the ability of BackInTime to comprehend. It has not been updated in a few years; execution warnings have accumulated, and now, finally, it no longer can run at all on Tumbleweed (LEAP 15.2 is still ok, ish).

Here is the reason:

2020-09-07T13:17:28-0700 sma-station14l systemd[2902]: Started Application launched by gnome-shell.
2020-09-07T13:17:28-0700 sma-station14l backintime-qt.desktop[10649]: Traceback (most recent call last):
2020-09-07T13:17:28-0700 sma-station14l backintime-qt.desktop[10649]:   File "/usr/share/backintime/qt/app.py", line 35, in <module>
2020-09-07T13:17:28-0700 sma-station14l backintime-qt.desktop[10649]:     import qttools
2020-09-07T13:17:28-0700 sma-station14l backintime-qt.desktop[10649]:   File "/usr/share/backintime/qt/qttools.py", line 21, in <module>
2020-09-07T13:17:28-0700 sma-station14l backintime-qt.desktop[10649]:     from PyQt5.QtGui import (QFont, QColor, QKeySequence)
2020-09-07T13:17:28-0700 sma-station14l backintime-qt.desktop[10649]: ModuleNotFoundError: No module named 'PyQt5'
2020-09-07T13:17:28-0700 sma-station14l systemd[2902]: gnome-launched-backintime-qt.desktop-10644.scope: Succeeded

I tried adding a couple of PyQt5 modules that seemed likely with no success.

Has any one else seen this and found a way resurrect BackInTime?
Is there a decent replacement for BackInTime?

I don’t know Backintime enough to evaluate, I have not heard any complaints about it for a long time.
I remember when some people used it existensively awhile back.

If you have BTRFS installed, openSUSE uses the filesystem’s native snapshot functionality and is managed by the Snapper utility.
If you have any other filesystem installed (eg EXT4), I know that Timeshift is available, and that is the standard utility used by Arch.

Over the years, I’ve also recommended a different utility that does the same thing for EXT4 which has worked well for me.

I suppose it depends on your use and circutmstances.
If you’re using EXT4, although it’s been improved quite a bit over time its basic functionality hasn’t changed so utilities like Backintime may work just as well no as when it was first written. Maybe the best judge of its capability is to inspect its source to see if anyone is even maintaining it.


The newest article on the “Back In Time” RSS feed is dated November 2017 …
The last release (version 1.2.1) was in August 2019.

  • One could view it as being “stable” but, given the errors which are appearing, possibly “no longer being maintained” would be more appropriate …

Given that, “Back In Time” is a front end to “rsync” – which is being maintained – a better course may well be, to consider migrating to “rsync”.

  • The rsync man page is long.
  • rsync has many complex parameters.
  • But, once the needed parameters have been nailed into a script, it’s stable and, reliable.

Did you install python3-qt5? All the relevant bits are available as per the ‘provided by’ section at https://build.opensuse.org/package/binary/Archiving:Backup/backintime/openSUSE_Tumbleweed/i586/backintime-qt-1.2.1-64.3.noarch.rpm

I just did fresh install of 15.2. I have used backintime for a decade or so. I installed backintime from the opensuse repos. I have found no problem running backintime on my new 15.2 install. I did a successful backupt o to an external hard-drive using backintime just after the install.

Perhaps there is something different about how tumbleweed runs things (but I don’t think so) but I have had no problems with backintime as of two days ago.

tom kosvic

I should have added that root partition is btrfs format.

For what it is worth I use Luckybackup which is also a GUI front end to rsync. But I’m still on 15.1 so don;t know if support is dropped in higher version OS

I doubt that the file system (as long as Linux comp) would be a problem rsync should not care. Changes to GUI environment may cause GUI to fail ie maybe python???

I tested here on Tumbleweed and no issues found…

As it happens: Operator Error

The issue was a scrambled python installation. I had done something earlier to resolve an issue for another app; it was fairly questionable but the other app did work. This issue is the result.

After cleaning the python installation, BackInTime is functioning again. (And the other app does not. :frowning: )

One good result is the discovery of two other backup utilities similar to BIT: duplicity, and borg + vorta-gui. I shall be evaluating these to see which fits the best.

Thank you all for your replies.