I Screwed Up My System (Installation)

Hi, guys. This is the first time I have tried to install a linux distro alongside windows on a single harddrive (really my first linux period). I looked around and decided to try openSUSE, as it sounded good for beginners, but seems to still be great for advanced users (oneday). I had read that the installation was simple, so I didn’t think to look in the forums before installing. I created a livecd for the x86-64 version and loaded it. If I remember correctly, the check media was ok at this point. I shrank my windows partition and created one for linux, through openSUSE. I got a few errors while installing the OS, but it kept going, so I thought it was probably fine. Once installed, I would restart my machine and opensuse would give me the option of starting windows, but when I would do this, windows wouldn’t start and would reboot the system. My first thought (I’m not saying that I was acting in an intelligent manner) was that if I deleted the linux partition, windows would be the only one and would load. This assumption was way off. Now it doesn’t even attempt to launch windows. Just says

“No boot device available
SATA0: Installed
SATA1: Installed
SATA2: None
SATA3: None
SATA4: Installed
SATA5: None”

My next thought was to re-install linux. So, I did the media check again, and though the md5 checked out on my downloaded iso, when it is ran in my system it says there was an error and “md5sum wrong”. I have tried downloading the iso a few times, then tried a memorex, as I was using verbatim discs initially, but I keep getting the same msg from the check media. I’m not sure what to do know.

I can see that my windows partition is still there. Have I lost all my windows files for good?

Download Super Grub Disk Homepage - Download CDROM
it can help.

But I have to ask, do you have a windows cd? Is it XP? You need to repair the MBR, in XP this is called fixmbr. Vista is a little different and a repair disk can be found here:
Windows Vista Recovery Disc Download — The NeoSmart Files

Yes your windows stuff should be OK, except maybe you didn’t defrag before you shrank the partition?:open_mouth:

If you have the windows disc tell us first.

So you’ve deleted Linux. OK I would make these steps one at a time:

  1. get the booting back to windows going again
  2. clean off any Linux partitions with the windows partitioner
  3. Defragment the NTFS partition/s
  4. make a space on the drive to install openSUSE (empty – blank space, following the windows install)
  5. install openSUSE with a copy that doesn’t give the MD5 checksum error

As caf4926 mentioned, the repair of the windows loader varies with whether it’s xp or vista. Here’s something on that:

• Windows 2000/XP on the computer: Boot from the XP/2000 installation disk and proceed to the final screen where you have the option to Repair Your Computer. Press "R" for Repair and log onto the Windows installation. When the command prompt appears, enter the command fixmbr. Confirm "yes" and you will receive confirmation of the reinstallation of Windows bootstrap code into the MBR. Enter exit and the computer will reboot.
• Windows Vista on the computer: Boot from the Vista installation disk and proceed to the final screen where you have the option to Repair Your Computer. Select Repair but do not opt for the automatic repair plus restart. Instead select Next and then select the Command Prompt. Enter bootrec.exe /FixMbr in the console and follow that with the command exit. Then select to reboot.

Reference for the quote: Boot Multiboot openSUSE Windows (2000, XP, Vista - any mix) with Windows bootloader.

Thanks for the replies guys. Sorry, I left some info out. I have the flu and have been out of it. Yes, my windows in XP, and I have the disc. And I defraged before installing linux. So, I should be able to use the disc somehow?

Also, once I get windows running again, the only step that I am not sure how to achieve is loading a openSUSE without an md5 error. I have downloaded 3 timed from the ftp/livecd, then once as a bit torrent. The one from the torrent matched the md5 from here (the openSUSE site), but I get the same error as all the others when I check media from the disc itself. What should I do.

Wow. Holy crap. That Super GRUB is awesome. I decided to see what it does and I booted up windows! I mean, I don’t know what to do from here, but at least that worked. I am going to look for fixmbr, I guess.

Okay, I put in my XP CD. Selected Repair. Selected my windows (just the number 1) installation. Then typed fixmbr.

I got a caution message that says:
"This computer appears to have a non-standard or invalid master record.

FIXMBR may damage your partition tables if you proceed.

This could cause all the partitions on the current hard disk to become inaccessible.

If you are not having problems accessing your drive, do not continue.

Are you sure you want to write a new MRB?"

Should I proceed? I assume I should, but want to make sure that isn’t something else I should do first.

You should proceed

Okay, after doing that I get the same

“No boot device available
SATA0: Installed
SATA1: Installed
SATA2: None
SATA3: None
SATA4: Installed
SATA5: None”


When that process fails, it’s usually because the active flag has been moved by the openSUSE installer off of the windows partition to a higher partition. So you have to move it back there onto the first (windows) partition.

Here’s how: boot into windows again. Go to the windows aprtitioner in control panel (disk management – storage) and see if it says the first windows partition is Healthy (Syatem). The “(System)” tag is the key thing. Probbaly it’s missing. If it is then:

Boot to openSUSE, open a console/terminal window. run the command: su, to become root user. Then run the command: cfdisk, to open the filesystem manipulation program. BE VERY CAREFUL not to do anything extra than the following: use the arrow keys to sda1 (if that’s where windows is) and then a black bar will highlight the sda1 line. Down below the highlight is on “bootable”. (tab will move it). Press enter to toggle the “Flag” on sda1 to “Boot”. then use the tab key to move the lower highlight to “Write”. press enter and the change will save. Tab to “Quit” and press enter to quit. If you do something wild, don’t use “write”, instead use “quit” and start again.

Once you’ve got the “boot” flag fixed on the first windows partition, go back and do the fixmbr trick again with the xp install cd.

Parted Magic is great for putting the boot flag back. Less complicated IMO
Downloads - Parted Magic

That’s right – never thought of that – and come to think of it, GParted from inside the running openSUSE would do it more simply too.


once these two gurus get you safely back to a working Windows
machine…then, start anew by doing some reading before you install
openSUSE, again…it can go smoothly…

i’d strongly suggest you read closely http://tinyurl.com/6jwtg9 it can
save you a lot of wasted motion, frustration and anxiousness…

also, a look at the Step-by-step installation guide can help prepare
you for the actual install:

THEN, do a back up (always do a backup of your important data, photos,
music, email, love letters, homework, etc etc etc) and install again
confident in your ability to not screw up you system past the point of
no return…

oh, and, wait until you are over the flu…preforming such tasks need
total concentration…


Thanks, guys. Wanted to let you know that I will apply your advice soon. I have been bogged down with school work and just using my laptop. I will try to fix my desktop ASAP.