I really need a lot of help [Starting with installing wine]

I have just downloaded and installed opensuse 11.1. I thought I could manage to learn the fundamentals of linux by myself, or at least get a little right.

After 5 hours of accomplishing absolutely nothing I thought I would try and get some help from opensuse.org.

If there is anyone who has a little patience and is willing to explain some fundamentals to me I would really appreciate it.

The first thing I would to learn is how to install Wine. I downloaded the newest version but I think I downloaded the windows installer version. I think I managed 9using yast) to find a online version to install, but with the bandwidth being so expensive in this country I would really like to find out if I can install it from the version I downloaded.

I apologise if this is the wrong section to post this in and appreciate any help offered.

Dear Connaver, wine is not the best first step to take to “…learn the fundamentals of linux…”!!!
Quit the GUI, go to command line with a good book about bash wide open on the table!

Won’t you learn linux starting with windows applications … or no?

Good luck!

There’s a wine tutorial for openSUSE here:
Geoff’s Linux tips - wine

To install the contemporary RPMs, add the repository he mentions and you should have the near-latest with the added advantage that it has been tested and integrated into openSUSE.

I used Linux for three years before I felt the need to install WINE.

what exactly is it that you feel you need WINE for?

there is very real little reason to immediately try to run
Windows[tm] programs under Linux.

There are all sorts of programs to replace those. Have a look at
http://www.osalt.com/ and

if this posting is not helpful, don’t get mad…i’d give you some
fundamentals but i don’t know where to start. That is, are you coming
from Ubuntu or Win95. Are you familiar with using a command line in
OS/2 or Vista? Have you yet read any of the online information
available at openSUSE.org?


basic reading list:

If new to Linux please read this:
above includes links to these–READ THEM

Before you install SuSE 11.0 read this. If you already installed and
it all went sour, read it BEFORE you reinstall:


Ready to use Multimedia? Read:


When you get frustrated, and BEFORE you give up and go back, read
“Linux is Not Windows”:

Partitioning/Install Guide

HowTo Boot / Multiboot openSUSE and Windows (2000, XP, Vista - any
mix) using the GRUB bootloader

When you have learned all you think you need to know read “LINUX:
Rute User’s Tutorial and Exposition”

How to install and boot 145 operating systems in a PC

Fixing vista multiboot with openSUSE - openSUSE Forums


First of all I thought no one had replied. And then I couldn’t find the post (I’ve just taken a more in depth look at the search function)

Thank you for your replies, let me see if I can answer all questions.

First of all, a brief explaination as to how I got to this point:

I have played around with Fedora previously, but not on any serious scale. I run an IT business and want to offer my clients alternatives to expensive microsoft operating systems. When I heard from a friend that Suse could run windows apps I thought it was worth a look at. When I started looking I saw openSuse had a 64-bit version (that really got my attention).

My thoughts at the time were: “If there is an OS that can run windows apps with no problem and has an easy GUI that is not difficult to become familiar with then I might just work.” Unfortunately people who have worked on MS Office and have other Windows based software do not want to change from MS Windows. So an alternative would have to fulfil the requirements (i.e. easy to familiarize themselves with and can run at least office.)

But, in order to offer this choice to my clients I would have to learn how to use (and fix) Linux myself.

Then I install openSuse 11.1 on my pc, (which I thought came with wine already installed) and started playing around. The first two days I got nothing right. Eventually I found out I could download and install wine with Yast, but I wanted to install the version I already downloaded before installed openSuse. After many hours of battling and fighting I eventually gave in and installed with Yast.

As a side note after a further 3 days and much searching on the net I finally got the installer for my motherboard drivers to start up. I felt like throwing a party. Unfortunately something about the kernel did not allow me to install the drivers, but it was a start.

I cam accross the term bash but did not that that point start reading up into it. At this point, one week later I now have a rough idea of how much I must actually learn. It does not help that I still have a Windows mentality.

As a last note on that very long exaplaination as to how I got here: I have been in the IT business for over 5 years and know how to fix computers (hardware) and sort out software issues on Windows XP and Vista.

To aces:

Thank you for reply. I’ll get my hands on some media about bash commands

To swerdna:

Thank you for the links to the wine help pages and the wine repositories. It might actually help if I can get into the wine configuration menu (I looked everywhere for it but could not find it) Now I can.

To Yosuf Mossad Mohammed Vitriolus:

Thank you very much for all the links. Your effort is appreciated. To be honest I have been very busy these past few months (with the economy hurting business badly) I have not had the time to sit for a fe hours and look through the forums. The little time I was able to sit and look I did not find posts to help me.

Now I have a basic starting point to work from. I start reading everything you guys linked to and then hopefully I’ll be able to sort out the problems I currently have.

But there is one question I’ll ask right now. Through a miss click I have lost the section on my start bar that shows which windows I have open at the moment. So the only way I can see or navigate through my windows is though alt+tab. I have tried every single widget I can by right clicking on the start bar and adding widgets but that didn’t work. Does anyone know how I can put that section back?

Thanks again for all your help. Hopefully I’ll be able to get to a point to be a real contributer one day.

Quick and dirty and if not working, you can roll back.

Rename ~/.kde4 (home directory of the user who has the problem), close/restart xwindow session. Recreation of that hidden directory should be automatic and should fix the problem (maybe…)

Bye, bye.


I did a bit of snooping and found my way to the KDE irc channel. Speaking to someone there was a lot of help and I got everything to work and look right. It was just a widget “Task Manager”. I was there before and thought I had tried all the widgets but I must have missed that one.

But thanks for that suggestion. If I manage to completely mess up the task bar again I’ll give that a try, And I probably will since I’m experimenting with everything :), soehow I have already downgraded myself from KDE4 to KDE3.5 I think.

Perhaps you can answer another question for me, might save me from hours of searching.

I have another hard drive full of files that I want to access. It was a second hard drive when I still had windows XP. openSuse picks it up but does not want to allow me access to it.

This is the message it returns when I try to access the drive through the dolphin application. Clicking on the partition name in “My Computer” does not do anything.

“An error occured while accessing “Personal”, the system responded: org.freedesktop.Hal.Desktop.permissionDeniedByPolicy: org.freedesktop.hal.storage.mount-fixed Auth_admin_fixed_always ← (action,result)”

I have never encountered such a message.
The disk is USB? NTFS?
Try to log in the system as root: same message?
Did you play with HAL/UDEV and its config files?
Open a terminal as a root (if you are a normal user type su and the root’s password), type “mount”: how is the disk mounted?
You could try to umount e re-mount manually …

The drive is a 160 Gig SATA, which has been partitioned and has an NTFS file system.

On the “My Computer” page it shows the drive as having a NTFS-3G partition.

I opened a terminal and entered su + root pass but I only found the link to the drive in the /dev/disk/by-label folder. I do not know where the actual drive is located

Uhm … the rest of what you said is greek to me. I don’t know what HAL is so I am sure I have not messed around with it.

you must be careful here…there are folks who appear both helpful
and knowledgeable…but, may be one and not the other…i’ve seen
folks come here with no experience and lots of problems…a month
later they are giving advice…sometimes great, sometimes not…

in order to access any hard drive it is necessary to first “mount” it…

[strange idea to a Windows guy, huh? it comes from the OLD DAYS when
the IBM “mainframe” was in the basement (of a different building
maybe) and everyone sat at a “terminal” or “console” in their
office…and when they wanted to work on THEIR documents they had to
get an “administrator” over in the basement to walk over and pick up
a “disk pack” as big as a hat box and carry it over to a
washing-machine sized drive unit and “mount” your drive…THEN, and
only then could you the user access your data…]

so, go to a terminal/console/Konsole and type
man mount

and, you learn about the mount command…

once you have become ‘administrator’ (aka: root) you may mount the
drive so that the user (you) can access it…

CAUTION: if that hard drive contains valuable data, and it is the
ONLY copy of that data, careful what you try…like it IS possible
to mount that drive as READ ONLY (use switch -r)…which might be a
good way to begin…

and, NO you don’t actually have to mount it again after any
shutdown/restart…you can have it automatically mounted via a line
in /etc/fstab

see: man fstab


have fun

We could cut a long series of exchanges short if you return the following information to here for us to see and use to formulate advice to you. Open a console window and enter the commands listed below. Use copy/paste to return the whole dialogue here.

sudo /sbin/fdisk -l | grep NTFS

that will tell us if any NTFS partitions are detected by the operating system

cat /etc/fstab | grep ntfs

that will tell us if attempts have been made in fstab to configure mounts for NTFS partitions to mount at boot time

sudo mount | grep fuse

that will tell us if any NTFS partitions are actually mounted and if so, where

  1. Finally – tell us if the NTFS partition/s are on internal or external drives.

That might help us to sort it quickly.

As stated “I have never encountered such a message.”.

The mount command shows what’s already mounted: non danger in doing that.

Surely swerdna can help you (us) more than me: follow strictly his advice.

Bye, bye Connaver … and have fun!