I never ever get any updates in opensuse gecko

hi, im using gecko rolling linux which is basically a type of tumble weed suse, It’s pretty much frequently sponsored by the opensuse people , but i noticed that i am never ever get any software updates or any updates at all and that makes me upset>:(and i know im already behind on some updates , its obvious.
how do i check for updates on opensuse, or force it ? and opensing yast2 does nothing at all with updates, doesnt display any

GeckoLinux is just some random guy packaging things together on susestudio. You should use actual Tumbleweed instead of things packaged by completely anonymous people.

What you just said is very harsh, disrespectful, insulting and has no relevance to the question asked. What people should or shouldnt do has nothing to do with you.

to update tumbleweed and derivatives you need to run: sudo zypper dup --no-allow-vendor-change

It was none of those things and it was 100% factually correct.

GL is just a group of packages picked by an anonymous person built in SUSE Studio or with Kiwi. Someone who has no name, no contact address, offers no support, has no liability and could be injecting who knows what into those images and people running them would have no idea.

It’s no different than installing Windows from a pirate site as far as security goes.

Plase calm down. When you think a post is against our T&C, please report it and don’t start posts which might violate our T&C themselves.

As noted by Miuku, the gecko distro is someone’s private packaging of Tumbleweed.

Nothing wrong with that. But the packager might have disabled the software updater. Or perhaps it wasn’t included.

Not to worry. Get a root shell (with the “su” command), and run:

zypper dup

to update. That’s the better way of doing it. And maybe to packager turned of the update applet because he knew that using the applet is the wrong way to update Tumbleweed.

OP: if you have extra repos other than opensuse default, please add the --no-allow-vendor-change (dup alone can break your system).

Miuku: if your emphasis regards the anonymous ‘sam’ (i didnt know he was anonymous) you have a point. however when you wrote “just some random guy packaging things together on susestudio” it reads as being dismissive of the hard work of ‘sam’, who from casual observation does appear to have put considerable effort into gecko. ‘just packaging things together’ could be applied to every linux spin out there. (lets not argue further).

Note also that TW does not have updates as such and thus do not show in the updater. you install what amounts to a new distro most every week or so. USE

zypper dup --no-allow-vendor-change

to get the newest

The maintainer has build these on suse Studio. So it is a good demonstration of what SuSE Studio can do.It comes with a variety of desktops, including some that are not normally part of opensuse. Also it makes things easier for me because my internet isnt stable enough to download an iso over 3gb. and its a lot more useble out of the box , it has the software and plugins that i would always install anyway, gecko linux is like the linux mint of the ubuntu universe ,. I also had a problem of not getting updates on manjaro linux , and they gave me a command that did the same thing so that it works

it worked thanks, i knew i was way behind , i had almost 600mb worth of updates

alright it is all up to date now. After i read over all the replies a few times i was wondering so all i would really have to do is run this each week and then i’d be pretty okay right?

Depends on what you mean by ‘OK’ you will have the newest >:)

For the record, I didn’t include the updater tray applet thingy in GeckoLinux because it uses PackageKit, which in the past has caused problems by locking zypp.
I haven’t re-evaluated it since they recently fixed the bug.

As to whether I am injecting malware into it, you can see the list of overlay files and packages that are installed, and you can see the md5sum that SuseStudio generates with that exact configuration, which is reproducible by anybody who cares to do so.

oh ,how do i mark this case as solved ? i forgot

No need,

You can explain that you are satisfied, which you did.

I found this thread VERY informative aside from the obvious distraction, my GL was 1.2GB overdue! Think I will make a note and include the “sudo zypper dup --no-allow-vendor-change” syntax in the tweaks and other stuff document that I keep on each distro.

you can drop “–no-allow-vendor-change”, it is default for “zypper dup” since snapshot 20170708. Updating Tumbleweed is similar to upgrading leap 42.2 to 42.3 (minor version upgrade) just happens a few times a week (generally) and not once a year. 1.2GB overdue can happen really quickly :slight_smile:

My last update (to 20170721) came in at 1.46G. That’s probably because “texlive” was updated.