I need help! Suse update broke my internet

hello I am using Suse 11 KDE 3.5 and everything was working fine on my computer till I did a Suse critical update on my viper. When I rebooted I noticed it would not connect to the internet. So I opened up a terminal and typed /sbin/ifconfig and it showed my ip address as being which is correct. So I typed in /sbin/route and it showed my destination as when it should be . I have attempted to change it uing Yast to terminal and nothing has worked. When I failed I plugged in my dad computer and it worked fine till I updated his computer and when I rebooted hey guess what same exact problem.
So does anyone have any ideas on how to fix this? I already tried yast and route via terminal. Can anyone tell me how to revert packages in Yast? Specifically critical updates? I couldn’t find anything in the patches section that would let me uninstall them or go a package backwards, but whatever update this was was recent and it broke both mine and my dad’s internet connection to the router.

In Yast network for your device are you using DHCP?

Yes I use DHCP

What is the whole output of /sbin/route

check this thread for pointers
seting up internet - openSUSE Forums

ok lets see if I can get this right cause I can’t copy and paste or e-mail it since I can’t use the internet on the other. First I’ll do my dad’s.

Detination Gateway Genmask Flags * U
loopback * U
default WRT54GL UG

Metric Ref Use Iface
0 0 0 wlan0 (my viper is eth1)
0 0 0 lo
0 0 0 wlan

I believe I got everything in here exactly how it is.

it looked a lot nicer than that when I typed it out in my reply box. I swear…

Default should be the router IP, I think, at least it is on mine.
And yours displays WRT54GL
which is I think if I g’ correctly:
**Linksys WRT54GL 54Mbps Open Source Wireless Cable Router

**I would try a live cd. If you are hardwired and everything in the router is fine (as it seems to be from what you say) the live cd should boot with an active connection.
If this is the case, then you need to look again at Yast.
You could go as far as deleting your connection/s and starting fresh.

How do I delete it all and start fresh? and a live cd might work on my dad’s but not my viper because the dvd drive currently isn’t working? all i have is my install dvd though and it’s no a live dvd.

OK. In Yast - Network Devices - Network Settings

Your device will be listed there
Either check thru all the settings and then Finish - Maybe reboot to be sure.

If that fails - delete
then add
and configure

I tried that, it still wants to point to when it should point to Yast doesn’t seem to change anything. Even after deleting and restarting from fresh.

what IP address do you use to login to the router?

My /sbin/route

Destination     Gateway         Genmask         Flags Metric Ref    Use Iface     *        U     0      0        0 wlan0
loopback        *            U     0      0        0 lo
default         ****         UG    0      0        0 wlan0

Bold is my router IP

Yours should be:

but you get:

Is this correct

yes that is correct

I don’t know what to suggest. I find it difficult to see any updates causing this - maybe, I don’t know.

Double check everything in the router, if you are using a LAN IP range and assigning IP to specific MAC address to give access control: make sure it is all correct. Re-boot the router even.
Check your settings again and again.

Maybe someone else has an idea. But I’m away now, sorry. Work time here in the UK

ok your deleting and start fresh idea worked on the third try and my dad’s comp when I removed the gateway I tried to add before to try and fix it. However on mine, it is not working and it changed my /sbin/route to

Destination Gateway Genmask Flags Metric Ref
loopback * * U 0 0

Use Iface
0 lo

Is tis a PC card or on-board
Ho does yast see it?

what about from a su terminal