I need a compatible motherboard

I have been trying to build a Opensuse 42.1 system with an FX6350 and a Gigabyte 970a-DS3P motherboard. I am unable to get the USB 3.0 to work. I have searched forums for days and I cant find a solution.
Any suggestions for a OpenSuse 42.1 compatible motherboard that will work with the FX6360?

Thank You

Is this a duplicate?

We are running Leap 42.1 on a Gigabyte GA-970A-DS3Pmotherboard and a FX6300 processor and are happy with it.

There are problems with this board in that for example the network card does not work with IOMMU set one way in the “BIOS” and USB3 will not work the other way - changing this setting exchanges one set of problems for another.

There is however another method that we find works well. That is to use the kernel boot parameter iommu=soft. We have IOMMU set to disabled but I’m not sure that matters.

Open Yast and open System/Bootloader.
Go to the Kernel Parameters tab
Add iommu=soft to the space separated list under “Optional Kernel Command Line Parameter”.
Click OK

I suggest you try this and report back before looking for alternative motherboards.

I have added the iommu=soft setting in the boot. USBs and Nic work but no USB 3.0. My customer has asked specifically for USB 3.0. Is this issue something that will be worked out with an update.
When I plug a USB device into the 3.0 slots nothing happens, unless I disable IOMMU, then no nic or usb 2.0.
I dont know what to do. I dont want to buy another mobo with the same issue.

Thanks for the help

I had put the immou=soft in the wrong place. It works!!!
THANKS A LOTrotfl!rotfl!rotfl!rotfl!

Glad it’s solved.