I lost the internet connection on OpenSUSE 11.4

Hello,

I played with the Network Settings section in YaST, because I wanted to use the wireless network card I installed into the PCI port. OpenSUSE recognised the type of card and its MAC number, and told me that I needed to install a firmware (fwcutter something). I tried some changes on the cable internet connection (like activate on plugged) while I tried to change the wireless connection (like activate on boot).

What I have now is that my cable internet connection is not working at all (it was working just 3 days ago), my wireless internet connection is, as always, not working either. I managed to work the wireless card on Windows XP by finding its drivers.

Since the problem is with my office computer, I cannot answer the exact brand names of the ethernet card and wireless card. Shall I reinstall OpenSUSE 11.3 from the DVD I have?

Second problem: OpenSUSE does not recognise my external harddisk, it gives an error about mounting the device. Do you have a suggestion?

Thank you.

It shouldn’t be necessary to re-install

Re: The internet. Just delete any device entries you have and then reboot, then go back and try adding your wired connection again. You may have to reboot again.

The external HD, is it NTFS format?
Then you may need to edit /etc/filesystems

to look like this

vfat
hfs
ntfs
minix
reiserfs
*

Thank you for your reply. I am happy to hear that I will not have to reinstall OpenSUSE again. We are used to do so in our Windows days :slight_smile:
I will try to delete the device entries and reboot. I am not sure about “device entries” though. Is it accessible from YaST? I am considering editing network settings again.
Yes, the external HD is either in NTFS or FAT16 format (maybe FAT32, not sure). It works on Windows XP. I need it on OpenSUSE because I want to back up my files. I remember using it on OpenSUSE in the past, though.
Cheers
BA

I repeated the procedure on OpenSUSE 11.4 about my lost wired connection, and saw that the error message is that smpppd package cannot be loaded. Its url is Index of /distribution/11.4/repo/oss and openSUSE-11.4 OSS (Medium 1) is mentioned.

I switched to Windows XP to see what lies there, but I could not find anything similar in this url. Shall I move the computer to somewhere else with known internet connection?

Thank you for your interest.

So your wired connection works until you fiddle with some settings to enable wireless??

What wireless device?

/sbin/lspci -nnk

Hello,

Thank you for your reply.

Yes, it seems that since I have fiddled something to enable wireless connection, my wired connection has gone.

By the way, I have a US Robotics Wireless MAXg PCI adapter (according to Windows XP). I remember ‘Air Force One’ on OpenSUSE Network Settings page. This device works perfectly on Windows XP as I am writing this message.

I switched the network control from the Network Settings on YaST page to the system settings -> Network Settings page. Then I could create a wireless and a wired connection. But no luck.

Thank you for your interest.

Entered: /sbin/lspci -nnk

00:00.0 Host bridge [0600]: Advanced Micro Devices [AMD] RS780 Host Bridge [1022:9600]
Subsystem: Advanced Micro Devices [AMD] RS780 Host Bridge [1022:9600]
00:01.0 PCI bridge [0604]: Advanced Micro Devices [AMD] RS780/RS880 PCI to PCI bridge (int gfx) [1022:9602]
00:0a.0 PCI bridge [0604]: Advanced Micro Devices [AMD] RS780/RS880 PCI to PCI bridge (PCIE port 5) [1022:9609]
00:11.0 SATA controller [0106]: ATI Technologies Inc SB700/SB800 SATA Controller [IDE mode] [1002:4390]
Subsystem: Giga-byte Technology GA-MA770-DS3rev2.0 Motherboard [1458:b002]
Kernel driver in use: ahci
00:12.0 USB Controller [0c03]: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller [1002:4397]
Subsystem: Giga-byte Technology Device [1458:5004]
Kernel driver in use: ohci_hcd
00:12.1 USB Controller [0c03]: ATI Technologies Inc SB700 USB OHCI1 Controller [1002:4398]
Subsystem: Giga-byte Technology Device [1458:5004]
Kernel driver in use: ohci_hcd
00:12.2 USB Controller [0c03]: ATI Technologies Inc SB700/SB800 USB EHCI Controller [1002:4396]
Subsystem: Giga-byte Technology Device [1458:5004]
Kernel driver in use: ehci_hcd
00:13.0 USB Controller [0c03]: ATI Technologies Inc SB700/SB800 USB OHCI0 Controller [1002:4397]
Subsystem: Giga-byte Technology Device [1458:5004]
Kernel driver in use: ohci_hcd
00:13.1 USB Controller [0c03]: ATI Technologies Inc SB700 USB OHCI1 Controller [1002:4398]
Subsystem: Giga-byte Technology Device [1458:5004]
Kernel driver in use: ohci_hcd
00:13.2 USB Controller [0c03]: ATI Technologies Inc SB700/SB800 USB EHCI Controller [1002:4396]
Subsystem: Giga-byte Technology Device [1458:5004]
Kernel driver in use: ehci_hcd
00:14.0 SMBus [0c05]: ATI Technologies Inc SBx00 SMBus Controller [1002:4385] (rev 3a)
Subsystem: Giga-byte Technology GA-MA770-DS3rev2.0 Motherboard [1458:4385]
00:14.1 IDE interface [0101]: ATI Technologies Inc SB700/SB800 IDE Controller [1002:439c]
Subsystem: Giga-byte Technology Device [1458:5002]
Kernel driver in use: pata_atiixp
00:14.2 Audio device [0403]: ATI Technologies Inc SBx00 Azalia (Intel HDA) [1002:4383]
Subsystem: Giga-byte Technology GA-MA770-DS3rev2.0 Motherboard [1458:a022]
Kernel driver in use: HDA Intel
00:14.3 ISA bridge [0601]: ATI Technologies Inc SB700/SB800 LPC host controller [1002:439d]
Subsystem: ATI Technologies Inc SB700/SB800 LPC host controller [1002:439d]
00:14.4 PCI bridge [0604]: ATI Technologies Inc SBx00 PCI to PCI Bridge [1002:4384]
00:14.5 USB Controller [0c03]: ATI Technologies Inc SB700/SB800 USB OHCI2 Controller [1002:4399]
Subsystem: Giga-byte Technology Device [1458:5004]
Kernel driver in use: ohci_hcd
00:18.0 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration [1022:1100]
00:18.1 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map [1022:1101]
00:18.2 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller [1022:1102]
00:18.3 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control [1022:1103]
Kernel driver in use: k8temp
01:05.0 VGA compatible controller [0300]: ATI Technologies Inc Radeon HD 3200 Graphics [1002:9610]
Subsystem: Giga-byte Technology GA-MA78GM-S2H Motherboard [1458:d000]
Kernel driver in use: radeon
01:05.1 Audio device [0403]: ATI Technologies Inc RS780 Azalia controller [1002:960f]
Subsystem: ATI Technologies Inc RS780 Azalia controller [1002:960f]
Kernel driver in use: HDA Intel
02:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller [10ec:8168] (rev 02)
Subsystem: Giga-byte Technology GA-EP45-DS5 Motherboard [1458:e000]
Kernel driver in use: r8169
03:06.0 Network controller [0280]: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller [14e4:4318] (rev 02)
Subsystem: U.S. Robotics Device [16ec:011a]
Kernel driver in use: b43-pci-bridge
03:0e.0 FireWire (IEEE 1394) [0c00]: Texas Instruments TSB43AB23 IEEE-1394a-2000 Controller (PHY/Link) [104c:8024]
Subsystem: Giga-byte Technology GA-EP45-DS5 Motherboard [1458:1000]
Kernel driver in use: firewire_ohci

This is your wired device

02:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd.  RTL8111/8168B PCI Express Gigabit Ethernet controller [10ec:8168] (rev  02)
        Subsystem: Giga-byte Technology GA-EP45-DS5 Motherboard [1458:e000]
        Kernel driver in use: r8169

This is your wireless

03:06.0 Network controller [0280]: Broadcom Corporation BCM4318  [AirForce One 54g] 802.11g Wireless LAN Controller [14e4:4318] (rev 02)
        Subsystem: U.S. Robotics Device [16ec:011a]
        Kernel driver in use: b43-pci-bridge

But if your wired connection is not working now, you have problems, because you really need it working to install the wireless.

You don’t need the Network Settings in Yast to configure any of this.

So if it was that your wired connection was working. This is how to set up your wireless.

sudo /usr/sbin/install_bcm43xx_firmware

When it’s done do the following:

sudo /sbin/modprobe -rv b43
sudo /sbin/modprobe -v b43

Hello,

Yesterday I moved the computer to another room to see if they have internet connection too, but the result was same; I could only access the Internet via the installed wireless card. However, today we have the internet connection, so I presume this was a failure lasted for 4-5 days.

I have typed the commands you wrote in the last post. It downloaded something, and listed something (I don’t understand, sorry). There is no icon about wireless connection on my tray though; so I am not sure it succedded.

Thanks.

For the icon visibility problems try reading thorugh this thread :
knetworkmanager is not starting automatically on start up - Page 2

There is some very valuable advice there.

Best regards,
Greg