I lost flash vdpau acceleration

the vdpau video acceleration stopped working and I don’t know how to bring it back.

What I think can be the cause:

  • I installed the latest NVidia driver manually ( the one downloaded from the website) because I observed that the one installed from the nvidia repo is not the latest one, and I have some problems which I thought a new driver may fix
  • the new driver did not fixed my problem, but I observed that there is no flash acceleration
  • uninstalled the nvidia driver ( the one downloaded and installed manually )
  • reinstalled all the nvidia packages and vdpau packages that I have installed, so basically I should be in the same state as I was before installing the driver manually, and where flash acceleration worked
  • but flash acceleration still not working

I run openSUSE 11.4 32bit, up to date, no buildservice repos.
I have the /etc/adobe/mms.cfg file, containing EnableLinuxHWVideoDecode=1.
I can play videos in mplayer/smplayer using the vdpau video output.

Can somebody help me with this? Is there a way to debug the flash player to see what is missing?

Thank you!