I installed Leap 15.2 and after upgrading I had no keyboard

Hello everyone!

I just installed Leap 15.2, with everything working … And after the first update I had no keyboard.

The usb keyboard works.

I had to determine by yast, the boot from the previous kernel, but I would like to try to fix this, and use the most current kernel.

My machine is an Acer E5-511 laptop - 4gib ram - Intel Celeron N2940 - Bay Trail.

Can someone help me?

Hello again!

I don’t know if what I did is right, but it worked …

I went to /etc/x11/xorg.conf.d

I deleted all files except touchpad …

I rebooted with the current kernel, and it worked …

This solution was terrible, I only made things worse

Hi
Force the reinstall the following and they should come back;


zypper in -f xorg-x11-server xorg-x11-driver-video xf86-input-libinput

Thank you for responding, Mr Malcolmlewis. Unfortunately it had no effect.

Hi
They files you deleted are back though in /etc/X11/xorg.conf.d/ directory?

They are, but I found out that the problem was in a ‘shin’ update, after the update I was unable to start the system with the 5.3.18-lp152.19.2 kernel, which gave an error:
error: bad shin signature
Loading initial randisk
error: you need to load the kernel first

In time…
I opened a bug report. The person who is helping me asked me for some information, such as output from kwinfo, and dmesg from the kernel that was 5.3.18-lp152.33 - which I deleted the files from - and dmesg from the kernel 5.3.18-lp152.19.2 - o kernel that the keyboard works.
Before sending the information there was an update, where this package, the ‘shin’ was updated and I was unable to enter any kernel … Everyone gave that error message that I mentioned. Only after I downgraded this package, I was able to enter.

Hi
The package is actually the ‘shim’ :wink: Normally when this is updated the MokManager enrol screen shows up to enroll the new key, don’t continue as you need to enroll this, when it asks for the password you use the password for root user.

Good clarification!
I used to let the countdown end. It was the first time that this error occurred.

t seems that there was a problem even the ‘shim’.
https://bugzilla.opensuse.org/show_bug.cgi?id=1175575#c3
https://www.reddit.com/r/openSUSE/comments/idh5n7/cant_boot_kernel_latest_leap_update_bad_shim/

Hi
See here as well;
https://forums.opensuse.org/showthread.php/543493-After-an-update-‘Press-any-key-to-enter-mok-management‘-during-the-restart

For me I saw no issues with the update as I enrolled the key…

Today it updated ‘shim’ again, and some more packages. It gave error when booting with the older kernel, however with the most current kernel everything works fine, except the keyboard. So I disabled secure boot, to have a keyboard using the previous kernel.
Curiously that mokmanager screen did not appear, but in the next opportunity I will certainly follow your guidance.

Mr. Malcolmlewis, could you help me? I know that tty3 works with the laptop keyboard. The next step is to go through tty3 for the graphical interface, and test the keyboard
Could you guide me how I do this?
I log in as root, and ‘rcxdm start’ is not working.

Hi
When you get to tty3 the keyboard works normally? If so then it’s the desktop issue, whet desktop environment are you running? What graphics card?


/sbin/lspci -nnk | egrep -A3 "VGA|Display|3D"

I am using KDE. My graphics card is the terrible Intel Bay Trayl.
This command was not found, can I use inxi?

Sorry…

00:02.0 VGA compatible controller [0300]: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Graphics & Display [8086:0f31] (rev 0e
)
Subsystem: Acer Incorporated [ALI] Device [1025:0905]
Kernel driver in use: i915
Kernel modules: i915

Hi
So keyboard actually works then in the tty, just not getting to your desktop? I have no experience with Plasma, I’m a gnomeite :wink:

Yes, the keyboard works normally on tty3.
However, mr. do you know how to get from tty3 to the graphical interface?
It looks like there is no startx …

In time…
If my machine were not so weak, I would be using gnome. I love that arid environment …

Hi
Can you check the system is set to boot into the graphical environment, as root user from tty run the following command?


systemctl set-default graphical.target

If set there should be no output.

Hopefully Forum Plasma users can offer more advise.