I have no sound after upgrading from 12.2 to 13.1

Well done with getting your audio working. Lee’s (oldcpu) experienced guidance was of real value here. You could edit the title with ‘[Solved]’ but in general, we don’t mark as such.

EXCELLENT !! And thankyou for sharing the information on the success.

For the curious, the diagnostic approach adopted was (in the exact order necessary to localize the problem):

(1) use the diagnostic script " /usr/sbin/alsainfo-sh " to obtain detail on the audio configuration and look for mixer settings that were wrong , look at the dmesg content at the end of that script, and look for other indicators of a problem. In jlturriff’s case everything that I could see looked ok,

(2) have the test commands, that bypass pulse-audio, run as a regular user and also as root in a terminal. If both commands work for user root in a terminal, but neither work as a regular user, then it could be a permissions issue. But if any one command works for a regular user, then it suggests the issue could be desktop or pulse audio related. In parallel, testing audio with a new user, helps also point to the issue being a desktop or an individual users pulse audio settings at issue. The test commands tried in this thread were:

speaker-test -c2 -D hw:0,0 -l3 -twav
aplay -vv somewavefile.wav

where the " hw:x,y " really depends on information from the diagnostic script " /usr/sbin/alsainfo-sh " to obtain the exact value for x and y.

(3) renaming or removing the /home/username/.pulse directory helps reset the pulse audio settings , where it is necessary to restart pulse audio afterward (and also possibly log out/in again after this). I confess to being fuzzy as to the precise way to do this, but a general GNU/Linux restart will achieve the necessary activity.

Hopefully users who know more than I about audio can polish the above approach more.

Its always a good feeling when a user successfully sorts such an annoying problem such as no sound.

click here

click here