I have just installed Opensuse 13.2 on my laptop but it does not recognize Wireless LAN

Hello everyone ,
It is my 1st time using Opensuse
I have installed Opensuse 13.2 on my Lenovo E531 Laptop , everything seems to be fine except it does not recognize my WLAN and I should connect to internet via Ethernet cable every time i want to connect to the internet.
Any advice will greatly appreciated, regards trying lspci -nn| grep 0280
gives back:
04:00.0 Network controller [0280]: Broadcom Corporation BCM43142 802.11b/g/n [14e4:4365] (rev 01)

Also it may be of some use to know that i had the same problem after installing Ubuntu a few years ago. I solved that problem with ubuntu using these tips : https://answers.launchpad.net/ubuntu/+question/252499

Thanks

have you tried running the commands in the release notes?

1.2. Network After an Update With YaST

this will ensure NetworkManager is correcly activated after any change

Thank you dear keellambert](https://forums.opensuse.org/member.php/29992-keellambert) for your reply
yes i tried it, but unfortunately it does not work
I suppose it is a driver issue
As i said i had quiet the same problem in UBUNTU but after i installed bcma wireless driver “bcmwl-kernel-source” it fix my issue .
I don’t know how to do the same thing at Opensuse
i would appreciate it if somebody gives me a hint about it .

I tried it , but it seems not to be my problem, because I can connect to the internet via Ethernet Cable. The problem is about wireless driver, i suppose, However thanks for your kind reply

As I said, I had quiet the same problem in UBUNTU, but after I installed bcma wireless driver “bcmwl-kernel-source” it fixed my issue .
I don’t know how to do the same thing at Opensuse .
i would appreciate it if somebody gives me a hint about it .
I also forgot to mention that i am using GNOME desktop .

04:00.0 Network controller [0280]: Broadcom Corporation BCM43142 802.11b/g/n [14e4:4365] (rev 01)

This chipset is supported by the proprietary ‘wl’ driver. Install the appropriate broadcom-wl package (from Packman repo) as mentioned here:

http://opensuse-guide.org/wlan.php

Thanks alot , it worked for me :slight_smile:

Enjoy the learning. :slight_smile: