I have ipv6 enabled yet I don't have ipv6 access

I have 12.3 KDE 4.10. So I bought a new modem that is Ipv6 capable. Now in windows(hate to say that) it works i have an address there.
the turtle on this site dances:
The KAME project

Then I re install Opensuse with ipv6 enabled I go to the above site no dance.
I also use opendns the Ipv 4 addresses I wrote in Yast I have Opendns.
However I have no ipv6 in Opensuse what!? Why!?
How do I get ipv6 access in Opensuse?

I am still waiting for my ISP to provide IPv6. So I have no experience with this.

You did not mention whether you are using NetworkManager or “ifup” settings.

I am pretty sure that NetworkManager defaults to IPv4 only. So you would have to go into the connection settings and change that for each configured connection.

With “ifup”, my recollection is that the default does support IPv6. But you should check. There’s a setting to use DHCP for v6 as well as v4.

Nick,
Thanks for replying, after posting I called my ISP it turns out IPV6 is not yet in my area as well. I don’t know what I saw on windows but so far for me at least the ISP Nazis tell me, " no Ipv6 for you!"

On 2013-05-29 08:06, Sagemta wrote:
>
> Nick,
> Thanks for replying, after posting I called my ISP it turns out IPV6 is
> not yet in my area as well. I don’t know what I saw on windows but so
> far for me at least the ISP Nazis tell me, " no Ipv6 for you!"

If in Windows you can browse to IPv6 places, then you do have IPv6
available, no matter what the people at your ISP desk say. They often
know nothing.

However, that kame place has both IPv4 and 6 addresses:


cer@Telcontar:~> host www.kame.net
www.kame.net is an alias for orange.kame.net.
orange.kame.net has address 203.178.141.194
orange.kame.net has IPv6 address 2001:200:dff:fff1:216:3eff:feb1:44d7
cer@Telcontar:~>

And I can also see the turtle in Linux - absolutely no IPv6 used here.
Try this one instead:


test-ipv6.com/‎


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

Carlos E. R. wrote:
> And I can also see the turtle in Linux - absolutely no IPv6 used here.

But do you see the moving version?

On 2013-05-29 15:08, Dave Howorth wrote:
> Carlos E. R. wrote:
>> And I can also see the turtle in Linux - absolutely no IPv6 used here.
>
> But do you see the moving version?

Nope.
As the test site says, I have no IPv6.


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

Carlos E. R. wrote:
> On 2013-05-29 15:08, Dave Howorth wrote:
>> Carlos E. R. wrote:
>>> And I can also see the turtle in Linux - absolutely no IPv6 used here.
>> But do you see the moving version?
>
> Nope.
> As the test site says, I have no IPv6.

I think you’re missing the point of the turtle. Everybody can browse to
the site, but only those who use IPv6 see the moving turtle. That is how
it tests whether you are using IPv6 or not, AFAICT. So the site is not
broken just because you can see a [static] turtle using IPv4.

On 2013-05-30 11:01, Dave Howorth wrote:
> Carlos E. R. wrote:
>> On 2013-05-29 15:08, Dave Howorth wrote:
>>> Carlos E. R. wrote:
>>>> And I can also see the turtle in Linux - absolutely no IPv6 used here.
>>> But do you see the moving version?
>>
>> Nope.
>> As the test site says, I have no IPv6.
>
> I think you’re missing the point of the turtle. Everybody can browse to
> the site, but only those who use IPv6 see the moving turtle. That is how
> it tests whether you are using IPv6 or not, AFAICT. So the site is not
> broken just because you can see a [static] turtle using IPv4.

Ah. But not everybody knows that. It is better to try “test-ipv6.com
instead, which tests several things and it tells you in clear words :slight_smile:


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

Carlos E. R. wrote:
> On 2013-05-30 11:01, Dave Howorth wrote:
>> Carlos E. R. wrote:
>>> On 2013-05-29 15:08, Dave Howorth wrote:
>>>> Carlos E. R. wrote:
>>>>> And I can also see the turtle in Linux - absolutely no IPv6 used here.
>>>> But do you see the moving version?
>>> Nope.
>>> As the test site says, I have no IPv6.
>> I think you’re missing the point of the turtle. Everybody can browse to
>> the site, but only those who use IPv6 see the moving turtle. That is how
>> it tests whether you are using IPv6 or not, AFAICT. So the site is not
>> broken just because you can see a [static] turtle using IPv4.
>
> Ah. But not everybody knows that. It is better to try “test-ipv6.com
> instead, which tests several things and it tells you in clear words :slight_smile:

Bah! Why let mundane facts and reality get in the way of great art :slight_smile:

On 2013-05-30 15:20, Dave Howorth wrote:
> Bah! Why let mundane facts and reality get in the way of great art :slight_smile:

X’-)


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

If your equipment or your ISP doesn’t support IPv6, use a tunnel broker for your part of the world
https://en.wikipedia.org/wiki/List_of_IPv6_tunnel_brokers

Each tunnel broker has a different procedure how to connect. The idea is simple… You create a VPN through the tunnel broker, when you pop out the other side you have an IPv6 address and will route using IPv6.

Also,
You need to verify your DNS supports IPv6.
Google “DNS Tier 1” and browse the lists and availability of DNS and whether they support only IPv4 or both.

HTH,
TSU

On 2013-05-31 01:46, tsu2 wrote:
>
> If your equipment or your ISP doesn’t support IPv6, use a tunnel broker
> for your part of the world
> https://en.wikipedia.org/wiki/List_of_IPv6_tunnel_brokers

Yes, I know of that possibility, but AFAIK, /I/ do not need IPv6 :slight_smile:

> Each tunnel broker has a different procedure how to connect. The idea
> is simple… You create a VPN through the tunnel broker, when you pop
> out the other side you have an IPv6 address and will route using IPv6.

I have to replace my router tomorrow, and it supports IPv6 and VPN. I
still have to see how true that is.

> Also,
> You need to verify your DNS supports IPv6.
> Google “DNS Tier 1” and browse the lists and availability of DNS and
> whether they support only IPv4 or both.

It does support IPv6, at least according to the test site.

Actually, I would prefer the DNS chain not to return IPv6 addresses,
as I can not connect to them. It would solve some little problem :slight_smile:

Yes, I know that v6 is the future, but this is the present.


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

On 2013-05-31 02:43, Carlos E. R. wrote:
> Yes, I know that v6 is the future, but this is the present.

(that’s a joke :slight_smile: )


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

On 2013-05-29 03:36, Sagemta wrote:

> I have 12.3 KDE 4.10. So I bought a new modem that is Ipv6 capable. Now
> in windows(hate to say that) it works i have an address there.
> the turtle on this site dances:
> ‘The KAME project’ (http://www.kame.net/)

I got a new router myself. It is IPv6 capable, it says. But the ISP doesn’t give it an IPv6 address.
The router has provisions to activate a tunnel using “DS-Lite” or “6RD” or “6to4”, whatever they
are. The DHCP server does not have IPv6 settings that I can see. …] No, it does, on another page.

I still have to read the manual.

However, my local machines have an IPv6 address, and they work:


> cer@rescate1:~> ping6 -I eth0 FE80::21E:BFF:FE08:4CCB
> PING FE80::21E:BFF:FE08:4CCB(fe80::21e:bff:fe08:4ccb) from fe80::221:85ff:fe16:2d0b eth0: 56 data bytes
> 64 bytes from fe80::21e:bff:fe08:4ccb: icmp_seq=1 ttl=64 time=0.150 ms
> 64 bytes from fe80::21e:bff:fe08:4ccb: icmp_seq=2 ttl=64 time=0.145 ms
> 64 bytes from fe80::21e:bff:fe08:4ccb: icmp_seq=3 ttl=64 time=0.152 ms
> ^C
> --- FE80::21E:BFF:FE08:4CCB ping statistics ---
> 3 packets transmitted, 3 received, 0% packet loss, time 2000ms
> rtt min/avg/max/mdev = 0.145/0.149/0.152/0.003 ms
> cer@rescate1:~> ping6 -I eth0 bilbos
> PING bilbos(bilbos) from fe80::221:85ff:fe16:2d0b eth0: 56 data bytes
> 64 bytes from bilbos: icmp_seq=1 ttl=64 time=0.150 ms
> 64 bytes from bilbos: icmp_seq=2 ttl=64 time=0.153 ms
> 64 bytes from bilbos: icmp_seq=3 ttl=64 time=0.145 ms
> ^C
> --- bilbos ping statistics ---
> 3 packets transmitted, 3 received, 0% packet loss, time 1999ms
> rtt min/avg/max/mdev = 0.145/0.149/0.153/0.010 ms
> cer@rescate1:~>

> cer@rescate1:~> ping6 FE80::21E:BFF:FE08:4CCB%eth0
> PING FE80::21E:BFF:FE08:4CCB%eth0(fe80::21e:bff:fe08:4ccb) 56 data bytes
> 64 bytes from fe80::21e:bff:fe08:4ccb: icmp_seq=1 ttl=64 time=0.295 ms
> 64 bytes from fe80::21e:bff:fe08:4ccb: icmp_seq=2 ttl=64 time=0.142 ms
> ^C
> --- FE80::21E:BFF:FE08:4CCB%eth0 ping statistics ---
> 2 packets transmitted, 2 received, 0% packet loss, time 999ms
> rtt min/avg/max/mdev = 0.142/0.218/0.295/0.077 ms


I’m pinging my printer on IPv6, using Linux.

Although… I can not browse to it with Firefox, but the blame is on FF. The syntax should be:


http:///[FE80::21E:BFF:FE08:4CCB%eth0]

But it does not work, the blasted thing instead goes to google to find it. Go ahead, you will find
an email where I asked about this in 2011, and then it worked. Today it does not, using the same
syntax. Go figure.


Cheers / Saludos,

Carlos E. R.
(from oS 12.3 “Dartmouth” GM (rescate 1))