I have IP address via DHCP but no connection, very odd


I’ve just installed opensuse 11.2 with the network installation iso. During the installation, it has got the IP via DHCP without any problem, and I has downloaded all the needed packets without problems… But when the installation finish… I have no network connection :’(

It’s strange, because I have IP address, I get the IP from the DHCP server, and I can see the IP addreess if I do “ifconfig”, the default route and even the DNS servers in the resolv.conf file; but I cannot ping my gateway (that is the DHCP server as well!!), I cannot ping anything in my network and either anything in internet.

I see a network error at the start, but it finally gets the ip address. what could be the problem?


In the dmesg, the last message repeats over and over. The machine is a Hyper-V virtual machine, but as I said… I worked very well during the installation, I don’t know what is going on. I’ve tried to reinstall, but it doesn’t make any difference :’(

Try deleting the resolv.conf and restart the network(or reboot)

sudo rm /etc/resolv.conf
sudo /sbin/rcnetwork restart

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 11 days 21:24, 4 users, load average: 1.00, 0.95, 0.60
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.53

Please, post the result of:
sudo /usr/sbin/iptables -L

and do you really need ipv6 in eth0?