I have dual boot.When I use WIndows partition,after restart GRUB error 1

Please help me with booting …
I have dual boot - openSUSE and Windows 7. First, I had only linux on the notebook, then I formatted a piece of a disk as ntsf and installed Windows 7. Then the GRUB was lost so I have used live CD - but the Boot loader utility from Yast wasn’t able to write a new GRUB (still it wrote me “can’t mount device (hd0,0)” so I have used a full install DVD and “updated” the system - it did nothing because it was 12.1 DVD and 12.1 system on my notebook but it installed the GRUB properly. And then I was happy, everything seemed to work. I could use openSUSE and WIndows too.
Then I realized I need more space for Windows and made a new one partition formatted as FAT. I didn’t mount it in openSUSE. Then after I used WIndows and restarted the notebook, GRUB was lost. I didn’t understood why. It didn’t write me any error code, only “please wait” for hours. So I downloaded openSUSE 12.3 yesterday and updated the system. It installed GRUB as well and everything ok. But after that I went into Windows and after restart GRUB wrote me error code 1.
So I don’t know what is wrong. I “updated” the system with DVD oSuse 12.3 once again, Grub works, openSUSE works but I didn’t try to log into windows any more.
I need Windows because of some software but obviously I don’t know how to do it and after restart not to see a error in GRUB…
please can you help me?

why don’t you install windows in a virtual machine under openSUSE 12.3? that way you don’t worry about the partition size(in virtual is can be set to increase according to your needs and grub doesn’t change(hopefully) unless a new installation/update occurs.

I have had it but it was not so efficient when my notebook not the best is - I mean it was sometimes quiet slow. As a standalone installation it is much more better.
What can I do now?

Can you run your windows programs under WINE?
The problem is that you installed openSUSE and then Windows which will not care about grub or anything else installed. I would install Windows first and then openSUSE but keeping in mind how much of the diskspace from Windows you want to give up for openSUSE as to not resize again. or having windows on an external drive?

So the last things you did were to updated to openSUSE 12.3 which installed grub2 and then you were able to boot both systems? Did you try booting into windows again or not??? If windows is listed in the openSUSE grub2 menu and you boot to it and get a boot 1 error I think that you have probably broken the “system reserved” partition that windows needs to boot. I have done this before and have recovered from it about 50% or the time depending on what you did.

Using gparted or some other method please make sure you still have the system reserved partition.
If the partition is still there then I would try

Via Yast you can search for boot and then open (click) on Bootloader then.

  1. move the grub2 boot area to /root via yast (tick the second option in the yast bootloader )
  2. click on Boot Loader Options and make sure you have a check mark in “probe foreign os” and “set active flag…” but Not “write generic boot loader code …” Click ok and close out of yast
  3. make sure you can reboot into openSUSE after this and make note if the windows shows up in the boot menu. Hopefully this all went well and now you can shut down the computer and try to boot windows but it probably will not work.
  4. Try booting into windows again, did it work?
  5. If you are still getting the same or similar error then you need to boot from windows rescue cd and run chdsk /fixmbr ( please google this I am going off of 5 year old memories) basically you want the command to “fix master boot record”.

Hope this is helpful, let me know.

many thanks - I have done what you had written, installed grub2 on root and the whole point 2) and then reboot. There was no problem to go to openSuse, then I rebooted once again and went into WIndows, then I rebooted and I could boot into openSUSE— I hope this was no luck and it will be so next time as wel… :wink: