I have deleted mesa

How do I get back to textmode, When I get to the X login screen I cant do anything

Normally you could by pressing Ctrl+Alt+F1, but I guess this won’t work now as you can’t use your keyboard.

Which version of openSUSE are you using? 12.3?
Well, here’s a guide how to boot into textmode:

I have mouse and keyboard control in X, I have tried to instal xorg-x11-server xdm and xf86-driver-intel from Yast as you recommended, but there are none such packages.
What should I do now?

Of course there are and they must be on your system, otherwise you couldn’t start X.

So it works now again, or is there still some problem left?

Which openSUSE version do you have?

OpenSUSE 12.2

The problem is that all I have is this unusual desktop, not KDE (I don’t know how its called)

You mean the login screen?
Maybe you are missing the kdm package. Try to install it.

Also please check the file /etc/sysconfig/displaymanager, there is a line DISPLAYMANAGER= in there.
What does this line look like?

This is my current situation: Image codes: 20130427 132432
I can’t install Kdm I also can not check /etc/sysconfig/displaymanager (No such folder exists is what I get in the console, I tried with less /etc/sysconfig/displaymanager)

Yes. That file is included in the kdm package. Since it is not installed that file does not exist and you get the other login screen.
On your picture I see that you have a 32bit Mesa package installed. A mixture of 32bit and 64bit packages could have been the cause of your original problem.
Are you running a 32bit or a 64bit system?
I guess 64bit, since yast wants to install the 64bit kdm package.
If yes, then please select the first option in the conflict dialog in yast (“deinstallation of libGLU1-9.0.0-14.1.i586”).

Ok, so KDE is now running, I see I am still missing a lot of packages, for instance the component folderview was not found so most plasma applets are not working, The system has asked if It should forget about HDA Intel PCH, ALC270 analog (Default audio device) I also can not use the laptop mouse pad. Is there a option to instal all the usual packages one needs?

And thank you for all the help.

Just a thought, all this started with an attempt to upgrade mesa to version 9, if you upgrade to openSuse 12.3 you’ll get mesa 9!

That sounds like a good idea, just how do I update to 12.3 without deleting half the the packages or even worse by deleting all my data (That was a mostly a satirical remark upon my computer illiteracy, but I wold appreciate some help also) :slight_smile:

How much data are we talking about ? External USB hard drives are incredibly cheap and it makes a lot of sense to backup the data on one’s /home partition before spending 1 second messing around with X or the kernel or any other critical application.

If you have not done so, with respect to yourself and desire to fix the problem you noted in this thread, you really should pause, take a breath, and make yourself a backup. It is incredibly easy to do so. Simply plug in an inexpensive external usb drive, and drag and drop the contents you wish to back up to the external drive.

The trouble is, well I have a lot of Applications missing, There is for instance no application Installed that can open a File. So even making a backup is not the easiest thing to do right now. That is why I was asking if there was a option to reinstall the crucial applications/add-ons in one go. As it turns out I have deleted a whole lot more than I thought somehow.

OK maybe do a zypper dup. But before you do that please post output of

zypper lr

so we can see what repos are enabled and advise you from there.

folderview and most other plasmoids should be in the package “kdebase4-workspace”. Install that.
And “plasma-addons”.
You may have to add the missing plasmoids to your desktop again.

For the touchpad (you mean that, right?) you may need xf86-input-synaptics.

Oops, folderview is of course in the package “plasmoid-folderview”, so install that…
But you should have “kdebase4-workspace” installed as well anyway.

You could try to reinstall the KDE pattern.
Click on the “View” button in the upper left in YaST->Software Management and select “Schemata” (should be the first one).
Look for “KDE4 Desktop Environment” in the left list, right-click on it and select “Install”.
All your missing packages should then be installed again…