I have deleted mesa

Ok, I am terribly unskilled when it comes to computers in general, to be honest after what I just did I think I am a total idiot.
What happened was I wanted to play the Linux version of team fortress 2, I installed the game and it didnot run. I saw a thread on the steam forum of someone having the same problem in opensuse. I found a link to the opensuse wiki. On the site it said that I should update mesa to version 9 or higher. I added the needed repository in YaST. I then wanted to switch the repository to active i did that using: zypper dup --from “X11:XOrg”. When I tried to do this, I got an error asking me if I wanted to break, uninstall some things, and I uninstalled them. Then I uninstalled mesa in a attempt to update mesa to version 9 in the YaST software manager. After that YaST stopped working. I then rebooted the machine and now only I can only use the console. I tried fixing the issue by using the zypper commands, trying to re install mesa, I have also disabled all other repositories and I think the machine is not connected to the internet, because usually when I started the computer it did not connect via wlan, I had to disable the wireless connection and then enable it again.

I would appreciate any help, I know I made a huge mistake.

All part of the learning curve :D.

There’s a couple of options you have:

  • Reinstall, if you followed the defaults you should be able to import the current partitioning and thus keep /home untouched (plus import the users when installing from DVD)
  • Leave just the OSS, Non-OSS, Update, Update-non-oss and Packman active and run

zypper dup

For the second option you will have to have a network connection active. From what you describe I get that you’re using the Networkmanager, i.e. have no network until after the start of the desktop, which you can’t reach now. To change this, login on the console with your username and password, then do

su -c yast

You will see the ncurses version of Yast as you know it from the desktop. Navigation is done by the TAB and arrrow keys. Go Network devices - Network settings, set it to use ifup (traditional method), then configure the wireless card. Add the IP of your router in the Route tab. Proceed until done. Use

ip addr
ping google.com

to see if the networking is ok.

BTW Steam (and the games it provides) should run fine on the stock openSUSE libs. Your issue may have been missing 32bit Mesa and/or X libs.

I have to take the second option, I have the DVD at home. I have the ncurses version of Yast, and have set ifup option on. But I do not know the IP of my router, and the problem is half of the text is translated to my native language half is in English, could you be a little bit more specific on how to set the wireless card. I guess the card: INTEL WLAN controller. It is written here that it id not connected, the MAC add., Bus id, and that the IPn address assigned using DHCP.

Hi gax333,

Just some suggestions:
Do you, by any chance, have the option to plug in a LAN cable rather than the wlan?
When troubleshooting I just find this easier to handle.
That network interface (usually eth0) can also be setup via yast (to ifup). If you have a DHCP running, that should not be too difficult.
With DHCP you should not need to enter the router / gateway IP addresss, neither LAN nor WLAN, AFAIK.
When trying to change the repo setting in yast, you will see if you have internet access.

I am away from home i.e. my linux machines so I can’t be very precise.
Just in case you can’t get either network interface running maybe for having deinstalled cruxial dependencies - you could (re-)add the DVD as repository with yast (ncurses). If you have installed from the DVD you may try to see if you can re-install at least some basics. But if you have already run a couple of updates or online installations you may run into further missing (i.e. outdated) dependencies. The DVD also offers a “repair” option in the setup menu. AFAIK it offers the option to test the internet connection BEFORE software packet are dealt with. Otherwise, be aware of the dependencies…

Good luck!


Thank you both . I plugged the cable in and set eth0 to cable only (That was probably unnecessary). I activated OSS, Non-OSS, Update, Update-non-oss and did zypper dup, Mesa is now installed as far as I can tell form the add or remove programs section. I still only get the console when I start the computer so there is still something to fix I guess.

Here is the link that that said I should upgrade mesa, I didn’t see the warning at the end saying not to remove either fbdev or vesa drivers, and I carelessly deleted them. So might that be an issue?

If you were using one of those drivers before, it would be the issue if it is not installed. Just install them, it won’t do harm.

You can see why the graphical system doesn’t start in the file /var/log/Xorg.0.log .
Maybe upload it somewhere (eg. SUSE Paste) and post a link here.

And what graphics card are you using? If you were using the proprietary nvidia or fglrx driver, you could try to reinstall that.

I can’t acces /var/log/Xorg.0.log (permission denied).
Do I have to use something like sudo?

The computer has a intigrated intel card.

Any user should be able to access /var/log/Xorg.0.log. Root permissions should not be needed.

Normally you should be able to access it as a normal user.
But yes, try to use sudo.

For an intel card, you would need to have xf86-video-intel installed.
Please check that this is the case.

And do you still have the X11: XOrg repo enabled?

All I get is -bash: /var/log/Xorg.0.log: Permission denied.
As I try to accces the computer is ofline, but that can’t be an isssue.

You’re trying to run it, that doesn’t work.

less /var/log/Xorg.0.log

The file should be shown then and you can scroll down by pressing the space bar or the arrow down key.
It would be nice if you could post at least the last few lines or so. (maybe take a picture with a camera?)

View image: 20130426 221312

There’s no error in there. I guess that it is from your last successful boot, so won’t help us.

What happens when you type

sudo /etc/init.d/xdm start


Also, do you still have the X11:XOrg repo enabled?

The X11:XOrg repo is disabled, but I can’t use

sudo /etc/init.d/xdm start

All I get is sudo /etc/init.d/xdm start comand not found

Hm. You typed normal spaces between “sudo”, “/etc/init.d/xdm” and “start”? Not Alt-Space or something like that?

Yes, I have. I am going to instal the drivers that are probably missing now.

Are you sure you get this?

If you get “sudo: command not found” you would need to install sudo.
If you get “/etc/init.d/xdm command not found” you should install xdm.

Please try:

sudo zypper in -f xorg-x11-server xdm xf86-driver-intel

Sudo is installed, I have installed: xf86-video-intel, fbdev and vesa. Now all I get is this:

The problem is I can’t use the keyboard or mouse.

OK, that’s xdm, the X login screen. So X is running again.

You can’t use mouse or keyboard?
Well, I guess the input drivers are not installed then.
Go back to textmode, and enter:

sudo zypper in -f xf86-input-evdev xf86-input-keyboard xf86-input-mouse