I have an issue with my sound setup on TW/KDE

Since I reinstalled a few days ago and the zypper dup’d I have been having sound issues, my sound is not working as it used to and the sound output is on some apps really bad quality or volume is so low as to not be able to hear it despite the settings showing at 90%.

My setup is:-

inxi -Aa
Audio:
  Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 2a:00.1 chip-ID: 1002:15de class-ID: 0403
  Device-2: AMD Family 17h/19h HD Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 2a:00.6 chip-ID: 1022:15e3 class-ID: 0403
  Device-3: Logitech QuickCam E 3500 driver: snd-usb-audio,uvcvideo
    type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-8:2
    chip-ID: 046d:09a4 class-ID: 0102 serial: 2C6EAB20
  API: ALSA v: k6.9.5-1-default status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: PipeWire v: 1.0.7 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl

lspci -k | grep -i audio
2a:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Raven/Raven2/Fenghuang HDMI/DP Audio Controller
2a:00.6 Audio device: Advanced Micro Devices, Inc. [AMD] Family 17h/19h HD Audio Controller

For example I have Thunderbird set to play a sound when I get new mail but it does not work correctly (volume almost zero) but when I go to settings in Thunderbird and select to test the sound the first time it is quiet and then a second test it is normal volume, then it works the next time I get mail!

Any ideas please as to wheat to look at next?

Stuart

What happens when you boot up the snapshot from before the distribution upgrade?

I don’t use btrfs never have done so not an option.

Stuart

Use pavucontrol (install it if necessary) to check that the relevant levels are set appropriately, especially when a given application is playing a sound (as you can set per application volumes as well.

Have you checked all sound volumes? If you are in KDE Plasma there is also a sound test in sound configurations.

It worth trying a live distribution, Kubuntu is a good one.

All the levels are set ok to 90% in pavucontrol. It seems like there is a delay before the sound starts to play so if a short sound nothing gets heard.

Stuart

I just did the test where you click on the two speakers and the first one I did was Front Right but all I heard was Right it missed the Front bit, however then trying either speaker you hear all of the voice saying Front Right or Front Left every time. If I close the test and reopen it the exact same thing happens on the first speaker I test!

Stuart

If you open a terminal and run

 play -qn

This will effectively play a continuous “silent” audio stream. It is just a workaround for testing purposes that should prevent a sink from being suspended by preventing it from being idle. Try this test, and see if short notification sounds are then heard completely, and at the desired volume.

To stop PipeWire from suspending, the session.suspend-timeout-seconds property needs to be set to 0. Have a read of this Fedora discussion on disabling the unwanted behaviour…

Hopefully this does the trick for you.

Thanks I will try that and have a read of that thread.

Stuart

I tried the play -qn which resolves the issue but reading that thread none of the files mentioned are present in my TW install at least not in the places referred to in the thread.

Need to do some more looking!

Stuart

FWIW, I’m using Leap 15.6, and have /usr/share/wireplumber/scripts/ as mentioned in that discussion, and within that directory is a “node” subdirectory with “suspend-node.lua” present (the file of interest here).

It does seem that a lot of things have changed with wireplumber…
https://pipewire.pages.freedesktop.org/wireplumber/daemon/configuration/migration.html#locations-of-files
Try making a a user config file eg ~/.config/wireplumber/wireplumber.conf.d/51-disable-suspension.conf with

monitor.alsa.rules = [
  {
    matches = [
      {
        # Matches all sources
        node.name = "~alsa_input.*"
      },
      {
        # Matches all sinks
        node.name = "~alsa_output.*"
      }
    ]
    actions = {
      update-props = {
        session.suspend-timeout-seconds = 0
      }
    }
  }
]

as per this ArchWiki page section.
Restart ‘pipewire.service’ and ‘wireplumber.service’ to apply changes.

I tried that but when I went to restart the services neither of them exist I get service not found on the systemctl command. Looks like even more has changed!

Stuart

You realise that they run as user services right?

To be honest no I had not realised that. Now I do and yes I can restart it OK. However this morning my booting up obviously started it OK and now sound does seem to work OK.

I appreciate your patience and help with this.

Stuart

Glad to have been of guidance.