I have an internet connection but I can't use the address bar!

Hi everyone. I was trying the KDE version of openSUSE 12.2 in a live environment and I had a very odd thing happen. I can open the openSUSE website using firefox, navigate the internet by clicking links in that page (I went to the forums and the distro’s G+ page) and use the google search bar. HOWEVER, I can’t reach a website by typing its address (CNN.com - Breaking News, U.S., World, Weather, Entertainment & Video News, for instance) nor can I navigate to any of google’s results. This is a problem because it severely limits the usefulness of the browser.

The error I get says “unknown host” or something along those lines. I am honestly stumped as to what the source of the problem could be because I usually when I have internet issues I simply can’t connect to anything, but here I can open links from the G+ page and google myself to prove that there is a connection, even if I can’t then click on my facebook page.

Any thoughts? Also, if it’s a bug, how do I report it?

Thank you for your time.

Might be dns? Try opening a terminal. Run the command: ping google.com and see if it fails. If yes, try ping instead. If the latter works the issue might be with DNS. You might try setting up an alternate dns such as google dns or open dns. Before we go there though obviously confirm that is the issue.

Google doesn’t like firefox :slight_smile:
On another note can your try disabling ipv6 in your firefox using “about:config”
I would also turn off all addons and check whether any addon is causing the issue

Sounds like you have a name resolution (DNS) problem. You can browse only sites where the information is cached (unless hard coded, even those will fail when the cache entries expire).

Recommend changing to another network if you aren’t managing your own Internet gateway.
Inspect your DNS settings to verify are correct, then ping or nslookup the DNS to verify they’re working.
Manually specify alternative DNS servers if your gateway an/or ISP DNS are bad, but this requires your gateway router passing DNS requests.


Thanks for all the replies. I tried the ping command on the terminal and it seemed to work (I kept getting 64 bytes from dfw06s17-in-f1.1e100.net ( icmp_seq=1 ttl=52 time=25.9 ms as output ). Disabling ipv6 in about:config worked, but now I would like to know why that would be the case. any thoughts?

Thanks again for your help.

Your ISP probably doesn’t support IPV6 well. If that is the case, you should turn off ipv6 in YaST==>network settings==>ifup too.
Or you can do the same in your network manager.