I have a puzzlement. I cannot drag and drop to a USB drive.

Opensuse 13.2

So weird. I have some music files that I am working on in a directory on sda2 and after I mess with them, using Dolphin split window, I click and drag them to a USB drive.

Sometimes the copy will fail and say.

Could not write to /run/media/hexdump/staples/some folder name…(The folder name is a really really long name with embedded spaces. I tried just copying the individual files and that also failed.

The folder name gets written but I get the error when it tries to copy the files.

The odd thing is that I can copy other folders, or copy the folder in question to another location on sda2.

Very confusing.

Can you help ?

You probably need to inspect and possibly compare the permissions at the target location to other similar locations that work.

ls -l *directory *

If you don’t want to analyze and may not care what the differences might be,
Just delete(or mv/rename temporarily) the existing problem folder and create a new one, and verify the folder properties are identical to any other that works.

BTW - I’ve often found that there can be random issues in GUI file managers, likely because they seem to operate by overlaying their own file “view” over the actual file system. If the problem is related to the file manager, you can always perform the file operations using a command line. I don’t know if a command line ncurses file manager that supports a mouse might work, that’d be an interesting option.

TSU

Are you copying to a Windows file system (NTFS or FAT perhaps)?

There are some file names that are valid for unix file systems, but not allowed for Windows file systems. For example, the “:” character (colon) is not allowed for Windows file systems.

That was it nrickert, the darned ::::::: is not permitted. Changing it to a ----- worked wonders.
I am forever in your debt and something to file away to be promptly forgotten the next time it happens. The format is fat32.