I get a CLI instead of a desktop after uninstalling the graphic card driver

I installed openSuse 11.2 64bit (DVD version).
Later I installed the graphic card driver. Then I noticed that it’s not working well due to an improper installation (didn’t use the manual that you provided here).
So I uninstalled the driver. Then, after reboot, instead of a regular desktop, I get a CLI and I’m requested to enter my login information.
But in the boot menu, if I enter to the failsafe option, then everything works fine.

How can I change the CLI to the regular desktop?

Thank you!

It would be of help if you posted which graphics card you have. If it worked before installing the driver, do this :

At the “login:” enter your username
Enter password and do:

su -c 'mv /etc/X11/xorg.conf /etc/X11/xorg.conf.olddriver'
(enter rootpassword)
su -c 'init 6'
(enter rootpassword)

The system will reboot (init 6) and start with autodetection and configuration. That should bring back the desktop.

My graphic card is: GV-R575D5-1GD
The graphic card driver download page is: ATI Catalyst™ Display Driver

Before trying executing the command you’ve written, I searched for the files, but I found only this file: “/etc/X11/xorg.conf”
The following file doesn’t exist: “/etc/X11/xorg.conf.olddriver”

Here’s a list of my files at /etc/X11/:

$ ls -1

Thanks man! :slight_smile:

I think that is an ATI RadeonTM HD 5750 Graphics Accelerator card.

Looking at the release notes for the ATI Catalyst-10.4 its not clear to the that the HD 5750 is supported by that proprietary ATI driver. The 5700 series is supported, but there is no mention of the 5750 series, although that is not conclusive.

Its possible the RadeonHD driver is trying to be applied by Xorg when you do a normal boot, and that may be causing the problem. Its also possible you still have an old fglrx rpm installed that may need be removed.

My recommendation is to:

  1. search for and remove any fglrx rpm. If there was such an rpm, after removing it, reboot and see if that works. In either case if normal boot is not working, go to next step;
  2. boot to run level 3 (see guidance here: openSUSE Graphic Card Practical Theory Guide for Users - openSUSE Forums ) and try the radeon and VESA driver. To try radeon driver you type with root permissions:
sax2 -r -m 0=radeon

and then type “shutdown -r now” and see if that works.
If thata fails, then again reboot to run level 3 and try Vesa driver you type with root permissions:

sax2 -r -m 0=vesa

and then type “shutdown -r now” and see if that works.

I think that is an ATI RadeonTM HD 5750 Graphics Accelerator card.

That’s… good?

search for and remove any fglrx rpm.

How do I do that? Should I execute the following command:

rpm -e fglrx


To search for it, you can just type:

rpm -qa '*fglrx*'

and to remove it, you could type:

rpm -e $(rpm -qa '*fglrx*')

Before reading on: please stick to oldcpu’s advice and suggestions, he’s by far better in the ATI matter than I am.

I just reply, because I want to explain the command. It “moves” xorg.conf to xorg.conf.olddriver, renames it. So it’s a good thing the xorg.conf.olddriver does not exist, otherwise we would be overwriting the orininal file :).
If you don’t trust linux commands (IMHO you have every right to check them), open a terminal and do a ‘man $COMMAND’, where $COMMAND in this case would be ‘mv’, so ‘man mv’.

Its a nice card.

While I could not find a specific mention in the Catalyst-10.4 release note, I did find posts on the Phoronix forum that notes that this HD 5750 will work with the ATI proprietary Catalyst graphic driver.

So after you get your nominal graphics working again with the VESA or Radeon driver, you could once again try to get the proprietary ATI Catalyst 10.4 working, because purportedly it does work with an HD-5750 (per posts I saw on Phoronix and also on the Arch Linux forum).

The following command worked but didn’t find any rpm:

rpm -e $(rpm -qa '*fglrx*')

Later after boot, I entered run level 3 and executed:

sax2 -r -m 0=radeon

but it didn’t work. It left a log file somewhere in a path that I forgot.

Later, executed the following command:

sax2 -r -m 0=vesa

And it worked! :slight_smile:

Now I just need to re-install the ATI driver, but I don’t know which guide should I use among the following guides that I’ve found:

Re: openSUSE Graphic Card Practical Theory Guide for Users
openSUSE Graphic Card Practical Theory Guide for Users
openSUSE Graphic Card Practical Theory Guide for Users
ATI/The Hard Way
ATI drivers

The first 3 guides have the same title, but they’re actually different. Having so many guides makes this confusing :s

Please advice which one should I use :slight_smile:

Thanks :slight_smile:

There are many ways to do this that work. Everyone has their preference.

I prefer “the hardway” (which is not hard). For the “hardway” go to Graphics Drivers & Software which takes you here ATI Catalystâ„¢ Proprietary Display Driver and download the ati-driver-installer-10-4-x86.x86_64.run file to /home/yourusername.

Also go to YaST > Software > Software Management and select the “pattern” called “base development” which will install many applications, such as gcc and make. And also go to the “search” in Software Management and search for and install “kernel-source” and “kernel-syms” and “linux-kernel-headers”. Ensure the version number of the “kernel-source” and “kernel-syms” PRECISELY matches the kernel version of your kernel.

With that in place reboot to run level 3. You do that by rebooting and when the boot/splash menu shows up, where you select a normal boot or a failsafe boot, please select a normal boot and press “3” (no quotes) such that a 3 appears in the options line (with a space between it and the existing entry in the options line). Then press < enter > for the normal boot to take place.

This will boot to a full screen text mode. :slight_smile: Login as a regular user and enter the regular user password. Then type “su” (no quotes) or “su -” (no quotes) and type the root password. Then do the following:

  1. backup/move your /etc/X11/xorg.conf file with:
mv /etc/X11/xorg.conf /etc/X11/xorg.conf.vesa.backup
  1. build the rpm you need for the proprietary graphic driver by typing:
sh ati*.run --buildpkg SuSE/SUSE112-AMD64
  1. then install the rpm that was built by typing:
 rpm -Uvh fgl*.rpm
  1. then (as a precaution) ensure pointers/links are up to date by typing:
  1. then use the ATI program that was built and installed as part of the rpm to create a new custom xorg.conf file with:
aticonfig --initial
  1. and then restart with:
shutdown -r now

and that should ideally work.

If it does not work, just remove the fglrx rpm like before, and move the backed up /etc/X11/xorg.conf.vesa.backup file to /etc/X11/xorg.conf. BUT that takes you back to the VESA driver so ONLY do that if the proprietary driver completely fails.

Good luck and as noted, there are MANY ways to do this. I just happen to like the above.

Edit: In case you are curious, this is what I use as a reference: http://en.opensuse.org/ATI/The_Hard_Way … I do NOT like some of the new wiki changes on this in some of the other links you quoted as they delete reference steps that I think are very useful to know for reference.

Thanks for the newbie-friendly explanation! I’m new to linux so it helps a lot.

I managed to get until here:

And also go to the “search” in Software Management and search for and install “kernel-source” and “kernel-syms” and “linux-kernel-headers”. Ensure the version number of the “kernel-source” and “kernel-syms” PRECISELY matches the kernel version of your kernel.

I found out that my kernel version is:

$ uname -r

And the kernel-source version is:, as you can see in the image here.

What should I do?

BTW, how linux “knows” where is the installation file in the next command:

sh ati*.run --buildpkg SuSE/SUSE112-AMD64

Because that the path of the file is: “/home/yourusername” ? (my username is “dor”, so it actually located in “/home/dor”)

You need to either download and install the 2.6.31-5.0.1 kernel-source version and 2.6.31-5.0.1 kernel-syms version or you need to update your kernel to

It knows because I told you to download that file to /home/yourusername (where yourusername IS your user name). When you open a terminal : the terminal automatically starts in the directory /home/yourusername.

I tried to update my kernel version to, but I managed (with this reply) to update it to:

$ uname -r

(uname executed after reboot)

How can I update it to the latest version?
Or, is it OK for me to continue with the ATI driver installation?

Thanks :slight_smile:

Cool man, it works great!!! THANK YOU! :slight_smile:

I installed it anyway, despite that the kernel version received by uname wasn’t, because that via YaST I could see that the kernel version IS and not as written by uname. So I thought that maybe uname trimmed the version number or something similar.

oh and how can I configure the driver?
I found that writing in terminal “sax2” should open the configs GUI but it doesn’t seem to be right (too few configuration options were available)

Don’t run sax2. If you run sax2 it will delete the xorg.conf created by “aticonfig --initial” and you will lose the configuration you had created with “aticonfig --install”. So don’t run sax2 unless you are willing to accept that loss.

What are you trying to configure? If you are trying to reduce your resolutation you can do it with xrandr. If using KDE (and assuming the proprietary driver is running) you can boot to X and then type in a terminal: “krandrtray” (no quotes) and then look for a small “monitor” icon in lower right corner. Right click on that and select “configure display”. Use that to configure things.

For the lxde desktop, I think the app is called “lxdrandr”. I’m not familiar with the gnome GUI version of the app.

By default, Gnome adds the ‘Configure Desktop Display’ icon in the
system tray which is the CLI command gnome-display-properties.

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.2 (i586) Kernel
up 11:13, 2 users, load average: 0.07, 0.15, 0.21
ASUS eeePC 1000HE ATOM N280 1.66GHz | GPU Mobile 945GM/GMS/GME

I already run sax2 by mistake, would you recommend running “aticonfig --initial” to correct that mistake?

Indeed, I’m using KDE. I prefer a GUI but any other method is OK too.
I tried running “krandrtray” in “normal mode” (init 5, I guess) but to no avail. Also tried running “krandrtray” after clicking CTRL + ALT + F1 (a shortcut to text mode) but didn’t help either: executing that command did nothing. nothing appeared, not even an error.
How to “boot to X” ? I’ve searched on that for the last 20 minutes but couldn’t find any info :s

IMHO if it works, don’t fix it.

What do you mean by “how to boot to X” ?

If one is in run level 3 there are many ways to start X.