I don't get prompted for root password anymore.

Hi!

Something weird happened lately (more probably I messed something up). I don’t get prompted for root password anymore, for example while installing updates or software. It’s not like the system remembers the password and does everything without asking for credentials, it simply doesn’t ask and states that it can’t do anything because of lack of privileges.

I use GNOME and can run YaST and Software Installation - I get asked for root password when running these. I can’t set privileges when doing thing’s outside those, like for example installing updates through that update icon on the bottom toolbar, or trying to install something by clicking on *.rpm.

What might be the cause of the problem is that I was trying out KDE lately, and because I didn’t like it I uninstalled it’s packages. System asked what to do with dependencies and I chose to save most of them, but I might have uninstalled a bit too much.

I use openSUSE 11.2.

Any help will be appreciated :slight_smile:

I suspect you are right you uninstalled too much.

Try going to Yast and select the gnome pattern and see if you can find what you need there. It will list the gnome requirements.

Have you, by any chance, changed your file permissions to “paranoid?”

I installed all remaining packages in GNOME base and desktop environment patterns and it’s still the same :confused:

Do you think REinstalling all GNOME packages might help?

I don’t think so, but just to be sure, how can I check that?

I checked in YaST2->Local Security and it states that file permissions are set to ‘simple’.

The application responsible for my problem is gnome-keyring, right? I have all it’s packages installed.

kszaq wrote:

> The application responsible for my problem is gnome-keyring, right?

ah yes, the why is this happening question is a good one: here is my
guess

-use YaST to add a new user named (say) Test

-log out of Gnome and back in as Test

-see if you are now asked for the root password when you try to do
something requiring it (btw, what are those things?)

if it works okay as Test, post again…along with the answer to this
question:

how often have you been logging into Gnome or KDE as root?


DenverD (Linux Counter 282315)
CAVEAT: http://is.gd/bpoMD
posted via NNTP w/TBird 2.0.0.23 | KDE 3.5.7 | openSUSE 10.3
2.6.22.19-0.4-default SMP i686
AMD Athlon 1 GB RAM | GeForce FX 5500 | ASRock K8Upgrade-760GX |
CMedia 9761 AC’97 Audio

I created a new user like You said, downloaded an *.rpm package (with flash player plugin for browser) and tried to install it by double-clicking on it. Sadly nothing changed - I didn’t get prompted for admin credentials and installation was aborted due to lack of privileges :confused:

I never logged in directly as root - I use sudo or su while working in the terminal (sudo mostly, I guess I su’ed to root once when configuring postgresql server).

Does anyone else has any guesses what can I do to fix this issue?:confused:

Maybe this logs info will help:

May 22 13:18:05 komput0r gnomesu-pam-backend: The gnome keyring socket is not owned with the same credentials as the user login: /tmp/keyring-sg3FWG/socket
May 22 13:18:05 komput0r gnomesu-pam-backend: gkr-pam: couldn’t unlock ‘login’ keyring: 255
May 22 13:18:08 komput0r gnomesu-pam-backend: The gnome keyring socket is not owned with the same credentials as the user login: /tmp/keyring-sg3FWG/socket
May 22 13:18:08 komput0r gnomesu-pam-backend: gkr-pam: couldn’t unlock ‘login’ keyring: 255
May 22 13:18:08 komput0r gnomesu-pam-backend: pam_env(gnomesu-pam:setcred): non-alphanumeric key ‘alias aumix=padsp aumix’ in /etc/environment’, ignoring
May 22 13:18:08 komput0r gnomesu-pam-backend: pam_env(gnomesu-pam:setcred): non-alphanumeric key ‘alias sox=padsp sox’ in /etc/environment’, ignoring
May 22 13:18:08 komput0r gnomesu-pam-backend: pam_env(gnomesu-pam:setcred): non-alphanumeric key ‘alias timidity=timidity -Oe’ in /etc/environment’, ignoring
May 22 13:18:24 komput0r /usr/bin/crontab[20010]: (root) DELETE (test)
May 22 13:33:50 komput0r gnomesu-pam-backend: The gnome keyring socket is not owned with the same credentials as the user login: /tmp/keyring-sg3FWG/socket
May 22 13:33:50 komput0r gnomesu-pam-backend: gkr-pam: couldn’t unlock ‘login’ keyring: 255
May 22 13:33:50 komput0r gnomesu-pam-backend: pam_env(gnomesu-pam:setcred): non-alphanumeric key ‘alias aumix=padsp aumix’ in /etc/environment’, ignoring
May 22 13:33:50 komput0r gnomesu-pam-backend: pam_env(gnomesu-pam:setcred): non-alphanumeric key ‘alias sox=padsp sox’ in /etc/environment’, ignoring
May 22 13:33:50 komput0r gnomesu-pam-backend: pam_env(gnomesu-pam:setcred): non-alphanumeric key ‘alias timidity=timidity -Oe’ in /etc/environment’, ignoring
May 22 13:36:06 komput0r gnomesu-pam-backend: The gnome keyring socket is not owned with the same credentials as the user login: /tmp/keyring-sg3FWG/socket
May 22 13:36:06 komput0r gnomesu-pam-backend: gkr-pam: couldn’t unlock ‘login’ keyring: 255
May 22 13:36:06 komput0r gnomesu-pam-backend: pam_env(gnomesu-pam:setcred): non-alphanumeric key ‘alias aumix=padsp aumix’ in /etc/environment’, ignoring
May 22 13:36:06 komput0r gnomesu-pam-backend: pam_env(gnomesu-pam:setcred): non-alphanumeric key ‘alias sox=padsp sox’ in /etc/environment’, ignoring
May 22 13:36:06 komput0r gnomesu-pam-backend: pam_env(gnomesu-pam:setcred): non-alphanumeric key ‘alias timidity=timidity -Oe’ in /etc/environment’, ignoring

kszaq wrote:
> I created a new user like You said, downloaded an *.rpm package (with
> flash player plugin for browser) and tried to install it by
> double-clicking on it. Sadly nothing changed - I didn’t get prompted for
> admin credentials and installation was aborted due to lack of privileges

well, there is your problem right there…several things you doing not
the way we do them…

double clicking an rpm should not work to install a program in any
flavor of Linux that i know of…i guess you do not have a lot of
Linux experience, huh?

FIRST: to install a browser flash plug in you do not have to download
any rpms…that is the so-last-century way of installing stuff (go
here and there and HOPE to download stuff without a built in virus,
and double click)…NO NO…

instead use YaST and the official repositories (aka: repos) just full
of programs all ready for easy installation into your new openSUSE,
read this: http://tinyurl.com/32njbkq and make sure you have ONLY
the four repos enabled (by using the YaST > Community Repositories)…

then, if in YaST you go to Software Management, and search on flash
you should find

for the codecs you need to listen to mp3 and etc go to the multimedia
forum http://forums.opensuse.org/get-help-here/multimedia/ and read
the sticky at the top of the list, it will tell you about restricted
formats and other things to get you going…

double click–nope! i’ve only describes one of several ways to install
programs…another is to use Zypper…and, still another is to sing
right click the rpm and then select Actions > Install with YaST…BUT,
always install directly from a squeaky clean community repo, if you can…

>> how often have you been logging into Gnome or KDE as root?
>>
>
> I never logged in directly as root - I use sudo or su while working in
> the terminal (sudo mostly, I guess I su’ed to root once when configuring
> postgresql server).

good! do not ever log into a Linux DE (like KDE, Gnome, etc) as root
because it is always unsafe and never required to get done what the
admin needs to do, read more here:

http://en.opensuse.org/SDB:Login_as_root
http://docs.kde.org/stable/en/kdebase-runtime/userguide/root.html
http://tinyurl.com/6ry6yd
http://tinyurl.com/ydbwssh

> Does anyone else has any guesses what can I do to fix this issue?:confused:

i wasn’t guessing, i was asking trying to learn enough about what
exactly you were doing to know how to answer…

or, were there other times you thought you should be asked for the
root password and you were not asked


DenverD (Linux Counter 282315)
CAVEAT: http://is.gd/bpoMD
posted via NNTP w/TBird 2.0.0.23 | KDE 3.5.7 | openSUSE 10.3
2.6.22.19-0.4-default SMP i686
AMD Athlon 1 GB RAM | GeForce FX 5500 | ASRock K8Upgrade-760GX |
CMedia 9761 AC’97 Audio

Well my experience says it actually does work… it is not the appropriate way, but it works for me (via single-clicking actually, as I am using KDE).

kszaq, I might have missed something, but can you still switch to root in a console via ‘su’?

I used YaST for installing all the time, I did this test with *.rpm package to see if the system would ask me for root password (it didn’t as I already said).
Still I had some additional repos switched on, I removed them and have only 4 repos You mentioned now.

Yes, there is another situation and it’s in fact the one that made me see something is wrong. It’s automatic software update - the one that automatically checks for updates from time to time. When it finds updates, a red star with an exclamation mark shows up on the toolbar. Previously, when I clicked on that icon it opened a list of available updates (the same one that is in YaST->Software Update) and I was able to install them that way - I clicked Install Updates, it prompted for root password and began dling/installing.
Now when I click on Install Updates I don’t get prompted for root pass and nothing happens.
When I open Software Update through YaST (which asks me for root pass before it starts) I can install updates without any problems.

Yes, that works fine.

kszaq wrote:
> Yes, there is another situation and it’s in fact the one that made me
> see something is wrong. It’s automatic software update - the one that
> automatically checks for updates from time to time. When it finds
> updates, a red star with an exclamation mark shows up on the toolbar.
> Previously, when I clicked on that icon it opened a list of available
> updates (the same one that is in YaST->Software Update) and I was able
> to install them that way - I clicked Install Updates, it prompted for
> root password and began dling/installing.
> Now when I click on Install Updates I don’t get prompted for root pass
> and nothing happens.
> When I open Software Update through YaST (which asks me for root pass
> before it starts) I can install updates without any problems.

i think if i were you i’d first remove and then reinstall the YaST
Online Updater (YOU) or openSUSE Updater, one of those is, i think
is the official name of that automatic updater you speak of…

to do that, open YaST and search for “you”, then scan the list that
results, and right click and select remove for the two YaST2 - Online
Update (YOU) entries, then when finished reinstall them both again…

maybe that does the trick for you, otherwise i have no idea what may
have gotten jumbled up when you had more repos enabled…

if the YOU won’t ask for the root pass and do its thing just ignore
it, or right click and turn it off…BUT, if you do that then you
have to remember to occasionally go YaST > Online Update, and install
the new stuff that has not been installed…(there are several here
who do not use YOU, so…)


DenverD (Linux Counter 282315)
CAVEAT: http://is.gd/bpoMD
posted via NNTP w/TBird 2.0.0.23 | KDE 3.5.7 | openSUSE 10.3
2.6.22.19-0.4-default SMP i686
AMD Athlon 1 GB RAM | GeForce FX 5500 | ASRock K8Upgrade-760GX |
CMedia 9761 AC’97 Audio