I destroyed my sound!

I’m pulling my hair out right now. Why? I just tried to install the realtek sound drivers because I was experiencing some sound quality issues with the integrated sound chip. It turns out that the installer wrote over all the ALSA stuff and then it didn’t complete because it couldn’t detect my sound card. (because I don’t have a “card”) I later found out that my original problem is that that line out causes feedback, and all I had to do was mute it. :\

Now I have no sound and I need to get it back because I do not want to break anything more.


Sorry about the double post, but I can’t find the edit button. :stuck_out_tongue:

Here is a little more info about my problem: When I try to click on volume control I get this message:

The volume control did not find any elements and/or devices to control. This means either that you don’t have the right GStreamer plugins installed, or that you don’t have a sound card configured.

You can remove the volume control from the panel by right-clicking the speaker icon on the panel and selecting “Remove From Panel” from the menu.

I think I need to reinstall alsa, but I don’t know how.

Try going into YaST - Hardware - Sound,delete your device,reboot ( to make sure nothing is retained in memory ), then,after the reboot, go back & see if that sorts it


Yast will not let me edit/delete/remove anything, even if I try it through terminal.
Still no luck.

Time to re-install.

What version of openSuSE are you running???

the newest
I think i will just reinstall

Even though in the past I have done it myself, re-install is not the real Linux way. Nine times out of Ten there are ways. I had a sound problem back in the 9.x era and it turned out that all I had to do was properly set the volume. I am not an expert or a guru of any kind but I have experienced a couple of these problems. Its the way we learn and share.
Try this:
su (get into root)
rcalsasound start
set_default_volume -f
aplay /usr/share/sounds/alsa/test.wav
The first command will either start alsa or say it is already running. The second sets the volume. The third, obviously, plays a test file. If you get sound we are cool. If not then we have to look at other areas… via lsmod and lspci … etc.