I can't use SweetHome3D on OpenSuse 12.2

Hi everybody,

I try to use SweetHome3D on OpenSuse 12.2, but it didn’t work. I downloaded SweetHome3D version from OBS (home:adra). It installed SweetHome3D 3.7 version + java3D 1.5.x. But I’ve got an error message when I try to launch the software :

A fatal error has been detected by the Java Runtime Environment:

SIGSEGV (0xb) at pc=0x8d559d67, pid=3322, tid=2367482688

JRE version: 7.0_09-b30

Java VM: OpenJDK Client VM (23.2-b09 mixed mode linux-x86 )

Problematic frame:

C [libj3dcore-ogl.so+0xed67] Java_javax_media_j3d_X11NativeConfigTemplate3D_isStereoAvailable+0x4e

Failed to write core dump. Core dumps have been disabled. To enable core dumping, try “ulimit -c unlimited” before starting Java again

If you would like to submit a bug report, please include

instructions on how to reproduce the bug and visit:

Bugzilla Main Page

The crash happened outside the Java Virtual Machine in native code.

See problematic frame for where to report the bug.

Have you got an idea ? Why i’ve got this error message ?

Thanks for your help.

Hi,

I found another solution. :wink:

I’ve found the same error.
Can I ask you how you solved it?