I can't ping nodes from opensuse they can't ping me either

This really makes absolutely no sense.
I can assign an ip address manually.
The machine gets on internet fine.
but I cannot ping other nodes nor can they ping me.
These are other nodes on my subnet.
A while back I had my server on another subnet
and i was able to vnc and ssh to it fine.
now I have it on same subnet I cannot ping or be pinged
Someone help.>:(

Hi,

Could you post the subnet info, and assigned static ip info for the relevant machines ?

cheers
J

eth2 Link encap:Ethernet HWaddr 00:0D:60:EC:00:0F
inet addr:10.41.10.100 Bcast:10.41.10.255 Mask:255.255.255.0
inet6 addr: fe80::20d:60ff:feec:f/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:4155 errors:0 dropped:0 overruns:0 frame:0
TX packets:3122 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:3041587 (2.9 Mb) TX bytes:511845 (499.8 Kb)

Host Name inscsuse
Gateway 10.41.10.1

DNS1 10.21.30.51 and 52>:(

Network insc.local

DG is not pingable but don’t think it is relevant for the machines on this same subnet, but still nothing is pingable.

other nodes with xp pro 10.41.10.53 and 54. Same other network settings.

Your netmask looks too tight and is for the wrong class of network. You’re using 255.255.255.0 and you should be using 255.0.0.0.

gonna try that one i think i got mixed up with a virtual adapter. I’ll post back sunday night if it works.
This is a samba server with open likewise.
do you know anything about openlikewise.
got a feeling puttin correct mask in prob solve my pinging problems. but haven’t been able to find a likewise person to help me integrate it with samba. so far it’s trial and error. I got more info googling on the web. the likewise forum is sometimes useless because people don’t always answer questions.

I rechecked that isn’t a good answer
Oh brother this is not my network, and the mask is 255.255.255.0 on the stations. I don’t have a right to change them what now? and how come the xp stations work fine that way? >:)

I can’t answer that. Maybe they’re all on the same subnet (ex., they’re all 10.10.10.xx)? The netmask tells your network layer whether an address is local (and can be resolved through ARP) or whether it must be reached through the default gateway.

Basically, without getting into Classless routing (CIDR, look it up on Wikipedia if you’re curious), and using your “10.x.x.x” IP addresses as examples:

255.255.255.0 - small class C network, ex., any machine in the group “10.40.1.???” is considered “local”

255.255.0.0 - medium-sized class B network, any machine in the group “10.40.???.???” is considered local

255.0.0.0 - large class A network, any machine in the group “10.???.???.???” is considered local.

See what I’m saying? Whoever originally set up your network wasn’t thinking correctly. You’ve got some routing work to do, unless you can change the netmasks.

(Hint: if your network uses DHCP, you can tell the DHCP server to assign a “larger” netmask.)

Sorry, don’t know anything about openlikewise.

Well … if you’re SURE that every computer on that local network is in the range 10.41.10.1 to 10.41.10.254, then yes, 255.255.255.0 should work for the netmask. I didn’t read your IP addresses as closely as I should have.

CRAP. I just remembered that, by default, the SuSEFirewall disables ping, too – but IIRC, that should only prevent others from pinging YOU, it should stop you from pinging out.

While putting this box on the same subnet I have this stupid problem. but when i had the box on a different subnet in insc.local it was pingable from this one. I cannot ping with a static or a dhcp address cause i tried both.
Weird thing is I can ping the DCs on a different subnet in the same INSC.local domain but not the PCs on my subnet.
the stupid xp prp stations have no problem. The netadmin
is stubborn and will not change the mask cause the xpstations are working. I have an idea I will figure out the subnet the dcs are on and put that subnet on a wireless laptop and see if i can ping my suse server. It might because I can ping the machines on the network from the suse box. then i could administer it with the wireless laptop. This really makes no flamin sense.>:(

No, it doesn’t. It’s going to be something weird. (Or even silly.) (Not necessarily your mistake, either, just something … … weird. :slight_smile: )

Don’t forget to go into the file /etc/sysconfig/SuSEfirewall2 and change the lines with “PING” in them to “enable” or “yes.” The comments should guide you.

Of course, if you can ping your SuSE machine with that set to “disable,” I throw my hands up. :slight_smile:

(Seriously. If that’s the case, something is fundamentally wrong – even to the point that you’ve got the same IP as someone on the network and are pinging the wrong machine or something like that.)

If one of the other network guys here (ken_yap, are you lurking?) has ideas, maybe they could pitch in.

Hi,

so what is your default gateway ? Is it a hardware router, PC etc.

Just to clarify, you have machines on the

10.41.10.x subnet and machines on 10.21.30.x subnet.

What is the gateway for the machines on 10.21.30.x subnet ??

How the two subnets linked ? (physically )

If the machine on 10.41.10.100 cannot ping 10.41.10.1 and no firewall is blocking icmp then a fundamental network problem is likely.

Can you print the arp table for the 10.41.10.100 machine please.

just “arp” from a command line.

The only entry should be the default gateway, unless you are communicating with other machines on that subnet.

Post back the answers, I am sure we can sort this out fairly quickly.

cheers
J

Go back to something you said earlier:

Yes … and no. It’s not USED to access local machines, but you still need to define one. You SHOULD be able to ping it. Find out why you can’t and your problem is well on the way to being solved.

On Fri February 27 2009 06:26 am, bperrotta wrote:

>
> eth2 Link encap:Ethernet HWaddr 00:0D:60:EC:00:0F
> inet addr:10.41.10.100 Bcast:10.41.10.255
> Mask:255.255.255.0
> inet6 addr: fe80::20d:60ff:feec:f/64 Scope:Link
> UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
> RX packets:4155 errors:0 dropped:0 overruns:0 frame:0
> TX packets:3122 errors:0 dropped:0 overruns:0 carrier:0
> collisions:0 txqueuelen:100
> RX bytes:3041587 (2.9 Mb) TX bytes:511845 (499.8 Kb)
>
> Host Name inscsuse
> Gateway 10.41.10.1
>
> DNS1 10.21.30.51 and 52>:(
>
> Network insc.local
>
>
bperrotta;

Do you have:
mdns off
in /etc/host.conf?

See: man host.conf for an explanation


P. V.
“We’re all in this together, I’m pulling for you.” Red Green

I really hate this.
I can ping any machine on the subnet i originally installed
this box . But I can not ping any machines on the subnet I have the box on. the subnet I currently have the box on.
This isn’t making sense. does anyone have a satisfactory answer?
>:) The boxes on the other subnet are all 10.21.30.x

Why in craps name can i ping all boxes in 10.21.30.x
but not on my own subnet in range 10.41.10.x?

If I wasn’t able to ping any it would make more sense.

I have a flamin connection i am posting to the forum from this box.
the ip currently on thisz box is 10.41.10.60. i changed it to see if it made any difference absolutely not.

I don’t see any MDNS statement in /etc/host.conf

What should it look like so I can manually add it?

i do not know the gateway for the 10.21.30.x subnet I just
know that i can ping them all. What is the arp syntax? so i can try it on the xp pc, since this linux box cannot ping the gateway.
to recap the gateway on this subnet is 10.41.10.1

on this linux box when i type arp i get

ddress HWtype HWaddress Flags Mask Iface
10.41.10.1 ether 00:21:55:ba:cf:8e C eth2
10.41.10.1 (incomplete) eth0

I am using eth2

arp -a returns this on xp

Interface: 10.41.10.53 — 0x4

Internet Address physical Address type
10.41.10.1 00-21-55-ba-cf-8e dynamic

I don’t think this can be an ip conflict. if you pick the address of a machine already running you won’t get a signal.
this is not the case because with both the 100 and 60
node address i got the internet fine and could ping
the 10.21.30.x network. and on top of that i pinged those addresses before using them and no one else was. so that is not the answer.>:(

been there done that all lines with ping enabled.
still no dice.

now I’m getting this from the linux box with arp

Address HWtype HWaddress Flags Mask Iface
10.41.10.1 ether 00:21:55:ba:cf:8e C eth2
nocpc02.insc.local (incomplete) eth0

Well, that’s a clue, though. The “incomplete” means that ARP was unable to resolve it.

(If you ever watch an ARP conversation with a network sniffer like Wireshark, you’ll see “who has 10.41.xx.xx?” The correct response will be a MAC address, something like, “10.41.xx.xx is at [MAC address].”)

Did you ever try changing YOUR netmask to 255.0.0.0? I can tell you this: if your IP address is 10.21.xx.xx and you’re on a subnet in the range of 10.41.xx.xx, you will NOT be able to ping anything in 10.41.xx.xx (or vice-versa) with a mask of 255.255.255.0. You CAN’T.

If that doesn’t help, go ahead and post everything you did, starting with when you first connected the Linux machine to the first subnet, then moved it to the second. We’re missing something here. That’s why I said it’s going to be something fundamental.

More importantly, it CAN be fixed. If you can get onto the internet with the machine, you know your NIC and cabling are working correctly.