I cant install thunderbird 3

Hello, i have installed the opensuse 11.2 64 in my pc.
I have downloaded Thunderbird 3 which was released yesterday but i cant install it. Can anyone help me??


You should wait until it’s released as a SuSE .rpm and not download it from Mozilla.

Thank you very much!
How much time does usually take from the official release to build a suse rpm?

konstantinoskyritsoglou wrote:

> Hello, i have installed the opensuse 11.2 64 in my pc.
> I have downloaded Thunderbird 3 which was released yesterday but i cant
> install it. Can anyone help me??
> Thanks

Alberto García Baladía

Hey I still have the mentioned problem with that new .rpm-package.

While installing there comes an error… it seems there’s something wrong with the version of Thunderbird I’m using at the moment but take a look at yourselves:


Packet “/Folder/MozillaThunderbird-3.0.0-12.1.x86_64.rpm” cannot be installed.

Subprocess failed: Error: RPM failed: error: Failed dependencies:
MozillaThunderbird = is needed by (installed) MozillaThunderbird-devel-
MozillaThunderbird = is needed by (installed) MozillaThunderbird-translations-"

But I cannot select those versions to install in YaST. In addition to that why should I downgrade to an (it seems at least) older version of Thunderbird?

I also tried to install Thunderbird 3 via YaST by selecting version 3 on the “Version”-panel.
It says the installation was successful but when I try to open Thunderbird it appears indeed and there’s a jumping Thunderbird-icon besides my cursor but after a short time of loading it closes by itself without any influence of me. When I click on the Thunderbird-task-button on my taskbar it happens nothing, just that it disappears after about 20 seconds like I said.

Sounds kinda strange to me and hopefully you can help me out with that.

I’m using: openSUSE 11.1 64bit… maybe there’s a compatibility-problem with 11.1?

Does anyone have any idea to my problem described in my last post?

still ??? Is this not your first post in the thread ?

Did you add this repository to install version 3.0 of thunderbird:


What other repositories do you have ? Note you should not use an 11.2 repository with 11.1.

Stick with ONLY OSS, Non-OSS, Update and Packman repositories. Add that above Mozilla repository. Install thunderbird. Then remove that mozilla repository.

Hey there,

yes it’s my first post actually and “still” was the wrong word. I wanted to say “also” instead, please note my native language isn’t English. :wink:

The repository you mentioned is already added… the other repositories do all have a “11.1” in their URL, except of 2 “factory”-repositories.

Here’s a complete list of the repositories that are mentioned in the box:

-> openSUSE 11.1-Update
-> ATi Driver (I added this one 'cause I own an AMD/ATi graphics solution)
-> Packman Repos
-> devel:languages:python (don’t know what this one’s good for but I think I can remember that I added this one for python because python is needed for my WLAN-USB-Stick)
-> home: anubisg1 (dont know what this ones good for)
-> home:kzjeef:branches:mozilla
-> mozilla
-> mozilla:Factory

-> + 7 openSUSE-Repo’s like OSS, Non-OSS, Source, Factory (once again), NonFree, Debug

As you maybe see I’m pretty new on openSUSE (Linux in general) but I don’t think my problem has something to do with them repositories that are not needed for Mozilla, because when I want to install a mozilla product YaST tells me which repositories are needed and those who have nothing to do with mozilla aren’t mentioned. So I don’t think it stands in a connection to my problem but go ahead. :wink:

Hopefully it helps… well I’m pretty fine with the old Thunderbird but the new one provides some options that are kinda useful for me though.
If you want any further information just reply to my post!

I recommend you disable ALL except for OSS, Non_OSS, Update, Packman and Mozilla that I noted above. No others. None. Only those. And after Thunderbird is installed, remove Mozilla. Again, ONLY those that I recommended.

Oh yeah I did it the way you told me and disabled all the repo’s including the Mozilla repo (after installing) and wow it works now!

Do I have to deactivate those repo’s everytime after installing something? What exactly is that good for? Is there a general problem with activated repo’s after installing new software?

Well actually imho you should keep the repo enabled as you’ll get the latest version from there always.

The advantage of keeping the repos enabled is you will get the latest version.

The disadvantage of keeping the repos enabled is:

  • the updated version may be cutting edge and break an already nicely functioning version - note these are cutting edge repositories, not repositories with fully tested applications
  • the repos you keep enabled may have other applications, that will be inadvertently grabbed when you update other applications. That may not be your intention (to grab cutting edge other apps from that repos) and that can cause problems.

Enabling and Disabling a repos is so fast and so easy, and its also so easy to check if newer versions are available, that I always recommend only OSS, non_OSS, Update and Packman repositories. And I enable and disable repositories on an “as required” basis.

I find keeping my enabled repositories “lean and mean” gives me nice functionality with minimal breakage with my software. I could write an essay on the rants I have read from users who refuse to listen to my advice, and they then put down openSUSE package management because of their own stubborness. Anyway, thats a soap box pet peeve of mine that does not below in this forum.

Glad to read that thunderbird 3 installed and best wishes in your use of openSUSE.