I cant install rpm files

Every time I download a rpm file from the web and I try to install it despite it says the installation was succesfull I can’t find the program also it’s not on yast i tried this command: rpm -qa --last | head but it doesnt show me the program someting is wrong can anyone help me?

One usually does not download packages from god knows where to install them, but rather use the package manager and trusted repositories for that - the chance of grabbing an incompatible .rpm is huge.

Anyway, which .rpm do you try to install? Where did you get it? How did you try to install it?

LIke @gropiuskalle, I think also you must definitely provide more factual information. It sounds as if you are downloading and installing RPMs a lot, which is (like gropiuskalle explains) mostly not needed as most software is available on repos.

And when you post factual information (read: computer text) do so please between CODE tags: Posting in Code Tags - A Guide

To install some “stray” RPM packages put them into a dedicated directory and then enable this directory as an RPM-only repository in yast. I do this sometimes for stuff I packaged myself locally. For everything downloaded from the web the warning from post #2 applies.

I try to install a game named Toribash… I also tried it with wine via the opensuse web page and I always get the same result. I double click on the rpm file insert my password and after some seconds it says the installation was successful but then I can’t find it…

I would try to use the rpm query function to ask what files the RPM should install. But I can’t give you the exact command (may be others know a good combination of options by hart) and I do not have an RPM here to test. In any case

man rpm

contains the needed information (but it may not be easy to understand, thus experiment a bit).

Got it. Use

rpm --query --package --filesbypkg <file>.rpm

where *<file>.rpm *is of course to be replaced with your file name. It gives al the files that will be (or are allready) installed by the package. Thus you can at least check if they are there. (And when they are there, you have found them :wink: )

Gnome or KDE? If KDE, are you using KPackageKit or Zypper? If KPacakge, then try Zypper. KPackageKit seems to have a lot of problems, not least installing programs but not ACTUALLY installing them. God knows what it thinks it’s doing when it says installation complete…
On a side note, I really don’t think avoiding web based .rpm’s is particularly useful. I’ve found repos to be frequently out of date and had to go find the latest .rpm myself to get rid of bugs (I’m referring specifically to the NVidia drivers hosted on opensuse repos).

Toribash will not create any menu entry. You can start it via a terminal


…or create you own menu entry (in KDE → rightclick the K-Menu-button and choose to edit the applications).

i am sitting here looking at the tar file .It is from 2008
it’s is a bit OLD
– on suse 11.3 —
first run - errors

~/Download/toribash-3.50-amd64> ./toribash
./toribash: error while loading shared libraries: liblua5.1.so.0: cannot open shared object file: No such file or directory

newer lua is installed - let’s see the normal; easy fix might do it

su -
ln -s /usr/lib64/liblua.so.5.1 /usr/lib64/liblua5.1.so.0

let’s see
runs but errors

~/Download/toribash-3.50-amd64> ./toribash
failed to load texture data/textures//award_igf
failed to load texture data/textures//award_pcformat
failed to load texture data/textures//award_pcgamer
failed to load texture data/textures//award_sga
failed to load texture data/textures//award_slamdance
Unable to retrieve login information

ok the folder is not in $PATH but the data folder in that file should be seen ?
no they ARE MISSING and not data/textures folder
but it runs .

to add to the above
** WARNING ** this program will crash gnome
and can lock up the system

well I found the problem I had to install flash player but why i need flash? also when I was trying to install a rpm it says to accept the flash player license but it wasnt installing it… any ideas?

At least I (but reading the other posts, I guess more people) do still not quite understand what you tried, let alone where you succeeded. You are very vague in saying things like " I was trying to install a rpm" instead of a precise and exact description (preferably the command you gave to the system and the answer you got between CODE tgas). But I have the idea I told you this earlier (and I am still waiting for the reaction on that).

That means that I do not even dare to make any suggestion on your new question. Sorry.

Speaking of trusting download sights…I just installed 11.4 KDE, no more dual boot windows!

Anyway about 4-5 days later, KPackageKit showed up in my task bar and said 93 updates are available :\ . So which ones can I trust? There is alot there, to try and decide which ones are needed.

Are these updates coming from trusted repositories? What is all that stuff in the update list?

that is a bit off topic but
the answer
All of them
the rpms are singed with an encrypted file if the key dose not match they are not installed
that is why most every one STRESSES ** use the package manager **

On 07/23/2011 04:16 AM, Keith EE wrote:
> Are these updates coming from trusted repositories? What is all that
> stuff in the update list?

kpackage kit is broken…do not use it…

instead, open YaST Software Repositories and set them so that only these
repos are enabled (see the paragraph beginning with “IMPORTANT!” here


then close that repo module and open YaST > Online Update and accept
everything it says to install…

read lots more on the repos in the wiki en.opensuse.org
learn loads on the ‘system’ in doc.opensuse.org

welcome…next time start your own thread, with a descriptive subject
(it will attract the helper you need)

openSUSE®, the “German Engineered Automobiles” of operating systems!

when I say I try to install an rpm file I mean that I download it from the web and double click on it…

I assume then you are doing this from a Desktop (hence the double click, although I never have to double click, then it would start two times). What is the program that starts then to install the RPM, YaST or PackageKit? You should not use PackageKit!

When you want an easy to copy/paste in a post here (thus we can see what happens), piece of computer text, use

su -
rpm -i ....rpm

Where you have to replace the …rpm with the path to and the name of the RPM file.