I can't install opensuse on my laptop!!!

Hi there everyone. I’m in need for some solution for my prob. I’ve been using opensuse for quite some time now. & love the way it works. I’ve downloaded the latest version 12.1 (full version AMD64 4.3 GB ISO, no Live CD), n tried to install it on my new laptop. All i had was the first welcome screen. then when i select installation, the screen flickers once & then goes black. I kept it like that for long, hoping to see any display,but I got nothing at all. I tried it several times, hoping again for any different outcome, but ended up with the same black screen. & after every failed trial, I have to press & hold the power button to force shut the comp. Please advise how should I proceed with theinstallation.

My laptop specs-
Model: HP Pavillion g6 1313ax
CPU: AMD QuadCore A6 3420M
GPU: AMD Radeon HD 6520G + AMD Radeon HD 7450M (Dual GPU in CrossFire, x64)
Existing OS: Windows 7 Ultimate x64

Here’s the link for the full specs of the laptop-
HP Pavilion g6-1313ax Notebook PC Product Specifications HP Pavilion g6-1313ax Notebook PC - HP Customer Care (India - English)

Did you check the media

A live cd is available, but you have to choose between kde or gnome, here are 2 direct links

If your DVD media checks OK
Try this: After highlighting ‘Installation’, use your keyboard and type: nomodeset
then hit enter
Does that help

Or try pressing F3 and try vesa

Thanx caf4926, Actually the disc is fine. I had it cheched out before the way you said. In fact i triedit out on other comps n had it running flawless. However I havn’t tried the VESA before (never had such a prob before :)). So will this effect the graphics after installation, or do I have to install the graphics driver manually?

Am I to understand correctly from the info you posted that this has switchable graphics?

Yeah it have switchable graphics!

If you manage to install I suggest you start a new thread, or start a new one anyway if it will help you install. Use a title like ‘Switchable Graphics - help installing and more please’

I don’t really know anything about this except that it can be troublesome. The word Bumblebee comes to mind on this subject.

Wait for help from someone who has a better understanding of this subject.

Well then, sure I can do that. But anyway, I installed it right now with the ‘nomodeset’ option, n completed the installation. However the display resolution is still 1024x768. I think I have to upgrade the video driver. I tried it out in the conventional way, but found it failing again. & now I’m sure about the reason, ‘switchable graphics’. Still thanx 4 all the help, man!

A quick search I find

Yeah but that’s about nvidia, I got radeon.

I can’t really advise you further.
I’m just avoiding this kind of hardware - I bought a laptop for a friend last week and purposely avoided all that.

On 2012-05-29 08:06, caf4926 wrote:
> JackHamm3r;2465933 Wrote:
>> Yeah but that’s about nvidia, I got radeon.
> I can’t really advise you further.
> I’m just avoiding this kind of hardware - I bought a laptop for a
> friend last week and purposely avoided all that.

switchable graphics is an absolute no-no with Linux, at least until the
devs start buying them and developing for them. My advice would be to
return the computer and buy another one.

Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

Even with switchable graphics, I think the latest proprietary AMD graphic driver should work with the HD 7450M.

How much experience do you have installing the AMD proprietary graphic driver from openSUSE GNU/Linux ?

Check out post #22 and #24 in this thread, to see if it helps: http://forums.opensuse.org/forums/english/get-technical-help-here/laptop/445072-i-have-problem-switchable-graphics-laptop.html

That’s allright, I Understand. Anyway I installed it with full resolution n drivers. Still the graphics not working perfectly, but I’ll find a way.

Anyway I installed it with ‘nomodeset’ at installation prompt, n also changed the resolution to highest available (F3), n selected drivers as ‘yes’ (F6). It nearly solved every prob. Even the sound driver is also working flawless. What’s left is the graphics n the touchpad driver.

I thot I shud let u know, it might help you out! Thanks for the help again!!! :slight_smile:

Don’t want to sound stupid - but sometimes in the past I’ve had to set ACPI=OFF and/or NOAPIC as boot options for some laptops. I thought those days were over. But you might try booting from the DVD and adding these and see if it makes any difference. Usually without them, my laptops would hang early in the install, or immediately (before the installer loaded).

This is just the solution I was lookin’ for!!! Thanks to ‘oldcpu’, ur solution worked perfectly for me. Apparently this works with dual AMD graphics as well. I was successful to install the switchable graphics drivers. Even the GUI has the option of switchable graphics as well. ‘oldcpu’ thanks for the help man!!!