i cant contanct any repostry!! plz help

Hi, i’m a new user of opensuse (11.2 64 bits) i was using kubuntu until yesterday, ive installed opensuse, and now i cant make any update or network installation from yast i have those errors (sorry they are in frensh coz my installation is frensh)

yast2 fichier’/content.key’ introuvable sur le media ‘http://download.opensuse.org/debug/distribution/11.2/repo/oss/

and

Une erreur s’est produite lors de l’initialisation du dépôt. ‘repo-update’: |] Meta-donnée valide non trouvée à l’URL spécifiée Historique: - Can’t hardlink/copy /var/adm/mount/AP_0x00000001/repodata/79581be65823e7846d963dbdef92cf8834199194-susedata.xml.gz to /var/cache/zypp/raw/repo-updateiSGB78 - Can’t provide ./repodata/79581be65823e7846d963dbdef92cf8834199194-susedata.xml.gz : Can’t hardlink/copy /var/adm/mount/AP_0x00000001/repodata/79581be65823e7846d963dbdef92cf8834199194-susedata.xml.gz to /var/cache/zypp/raw/repo-updateiSGB78).

please can u help me configure the right way my repo so i can update and install things
thinx a lot

Welcome to openSUSE forums.

Please post the output of:

zypper lr -d

thx mma
i was desperate so i reintalled the system, i still get the second error

the output of the zypper commad is this:

trinity:/home/ahmed # zypper lr -d

| Alias | Nom | Activé | Rafraîchir | Priorité | Type | URI | Service

–±----------------±----------------------±-------±-----------±---------±-------±----------------------------------------------------------------±-------
1 | openSUSE 11.2-0 | openSUSE 11.2-0 | Oui | Non | 99 | yast2 | cd:/// |
2 | repo-debug | openSUSE-11.2-Debug | Non | Oui | 99 | NONE | Index of /debug/distribution/11.2/repo/oss |
3 | repo-non-oss | openSUSE-11.2-Non-Oss | Oui | Oui | 99 | yast2 | Index of /distribution/11.2/repo/non-oss |
4 | repo-oss | openSUSE-11.2-Oss | Oui | Oui | 99 | yast2 | Index of /distribution/11.2/repo/oss |
5 | repo-source | openSUSE-11.2-Source | Non | Oui | 99 | NONE | Index of /source/distribution/11.2/repo/oss |
6 | repo-update | openSUSE-11.2-Update | Oui | Oui | 99 | rpm-md | Index of /update/11.2 |

after the error occure, nothing apper in the “correctif” zone (the updates) i dont think a fresh installation has nothing ot update! any way, every time i run even after i have reinstalled the system, every time tye yast2 tell me that i havent configured any repo, and ask me to do then the error occure :’(

Please disable the 1st repo with description of CD.
Can you reproduce the error after performing the above step. You can refresh the repos.

zypper refresh

thx mma again

after deseabling the CD i got this:

trinity:/home/ahmed # zypper lr -d

| Alias | Nom | Activé | Rafraîchir | Priorité | Type | URI | Service

–±----------------±----------------------±-------±-----------±---------±-------±----------------------------------------------------------------±-------
1 | openSUSE 11.2-0 | openSUSE 11.2-0 | Non | Non | 99 | yast2 | cd:/// |
2 | repo-debug | openSUSE-11.2-Debug | Non | Oui | 99 | NONE | Index of /debug/distribution/11.2/repo/oss |
3 | repo-non-oss | openSUSE-11.2-Non-Oss | Oui | Oui | 99 | yast2 | Index of /distribution/11.2/repo/non-oss |
4 | repo-oss | openSUSE-11.2-Oss | Oui | Oui | 99 | yast2 | Index of /distribution/11.2/repo/oss |
5 | repo-source | openSUSE-11.2-Source | Non | Oui | 99 | NONE | Index of /source/distribution/11.2/repo/oss |
6 | repo-update | openSUSE-11.2-Update | Oui | Oui | 99 | rpm-md | Index of /update/11.2 |

and the with the zypper refresh i got this:

trinity:/home/ahmed # zypper refresh
Recupération des méta-données du dépôt ‘openSUSE-11.2-Non-Oss’ [erreur]
Le dépôt ‘openSUSE-11.2-Non-Oss’ est invalide.
Can’t provide /content : Can’t hardlink/copy /var/adm/mount/AP_0x00000001/content to /var/cache/zypp/raw/repo-non-ossNyHl6V
Veuillez vérifier que l’URI définie pour ce dépôt pointe bien sur un dépôt valide.
Saut du dépôt ‘openSUSE-11.2-Non-Oss’ à cause de l’erreur du dessus.
Recupération des méta-données du dépôt ‘openSUSE-11.2-Oss’ [erreur]
Le dépôt ‘openSUSE-11.2-Oss’ est invalide.
Can’t provide /content : Can’t hardlink/copy /var/adm/mount/AP_0x00000001/content to /var/cache/zypp/raw/repo-osslSusPR
Veuillez vérifier que l’URI définie pour ce dépôt pointe bien sur un dépôt valide.
Saut du dépôt ‘openSUSE-11.2-Oss’ à cause de l’erreur du dessus.
Recupération des méta-données du dépôt ‘openSUSE-11.2-Update’ [erreur]
Le dépôt ‘openSUSE-11.2-Update’ est invalide.
Can’t provide ./repodata/79581be65823e7846d963dbdef92cf8834199194-susedata.xml.gz : Can’t hardlink/copy /var/adm/mount/AP_0x00000001/repodata/79581be65823e7846d963dbdef92cf8834199194-susedata.xml.gz to /var/cache/zypp/raw/repo-update5jEs2W
Veuillez vérifier que l’URI définie pour ce dépôt pointe bien sur un dépôt valide.
Saut du dépôt ‘openSUSE-11.2-Update’ à cause de l’erreur du dessus.
Impossible de rafraichir les dépots à cause d’erreurs.

Try this to rebuild the db for rpm’s.

rpm --rebuilddb

If that did not work, then we can remove all the repos and add from scratch.

thx again

after the rpm --rebuild

nothing appear, i think it has done it job
but i tryed to refresh with zpper and got same output like before

tryed with the graphical interface of yast and got the same original error!!

its strange, i dont get the reason of such thing?!!! may it because of my region? may it because i need somme account or thing? i’m under dhcp proxy can this be the cause? still i can connect to the net nromally and with my old kubuntu i was able to update???! it should not be so difficult

thx mma, can we do the last solutions u gived me?

Strange though.
It can be regional settings, not so sure about that.

Ok, delete all the repos from software repositories. Open YaST and point to software repositories and delete one by one.
Now add these repos. and refresh the repos with zypper refresh.

OSS Index of /distribution/11.2/repo/oss
Non-OSS Index of /distribution/11.2/repo/non-oss
Update Index of /update/11.2

Accept and import the key signatures after adding the repos.

NOTE: BTW are you running the update applet the same time with terminal update commands and YaST2. If so, 1st close update applet from system tray.

sorry i hope i’m not do too much, but i cant figure out how i do it, i ve gone with graphical interface at aaplication → system → administration parameter (im translating it in EN)

after that i choose the “confugure the update on ligne” it try to refresh it and then prompt me to import a GnuPG non-secure key i choose Import then prompt me to a window where is a botton “advance” where i can configure my repos
there i deleted all the repo execpt the CD (wich is deactiveted from before)
then cliced on “add” the yast prompt me to choose the type of support i leave it at deafault (specifiy IP) i choose “NEXT” then it ask me the name of the deposit and it URL, where i put the url of the ones u gived to me (not exactly what u write but i copied their URL) i may be wrong but puting them like u gived me it not pass (coz logically not valid url)
ive done it with the three one with no import key question, but i dosent pass, and when i clic on “ok” it try to refresh again and an error occure refusing them, when i quit, and reopen it all what ive done is earased restoring default one

sorry if i cant explain more cleary then this coz my distrib is frensh, and even i tryed to make print screen i cant manage to make it work (first steps on suse:shame:)

Take a good look at the home page of the forums, we have a french subforum !! You could post there in your native language.

In the meantime, I suggest you remove all the repos, incl. the CD one, then apply this, leave the repo manager, start it again. Now re-add the repos, import any keys it asks for (if so), apply, leave repo manager, start software manager and see what it does now.

Can you use the internet without errors?

sure i’m using the net, i was writing from the start form my opensuse machine, that’s why its strange! and after tow installations too!
any way i havent seen the frensh part of this forum, i thought it would be more rich content in the EN part, any way, now i cant test any thing, coz i leaved my office, thx every one for the help, ill try again monday, and i hope u’ll help again

Don’t worry about getting help, you will. Have some nice days off.

Good morning

i’m back and still get the same problem
plz any one can guide how to reconfigure all the repo from the start? and get the online repo?

Welcome back.

At the left downside corner there is kickoff menu, click on it and type YaST at the search bar above, when appear click on it and enter your root password upon request. Now click on software repositories and follow the steps in my last posts to remove and add new repos.