I can't change screen resolution in suse 11.3

If this is 11.3 and you have no xorg.conf, then why not instead edit (as appropriate) one of the files: /etc/X11/xorg.conf.d/50-device.conf, or 50-monitor.conf or 50-screen.conf ?

What video driver? For ATI one can be using the proprietary Catalyst video driver (of which there are different versions), there is the openSource radeon video driver, the openSource radeonhd video driver, and also the FBDEV and VESA video drivers. I know this is intuitively obvious to you as to what video driver you are using, but its difficult for other’s reading your post to tell.

Sorry to be so ambiguous, I tried using the proprietary Catalyst video driver from the ATI website and that didn’t work. I am currently using the FBDEV driver. From what I’ve read, I would like to remove that and replace it with the radeonhd driver as it should offer better performance. I realize the gain may not be overwhelming, but to be able to get my native resolution would be amazing.

-ck

My brief research suggests the radeonhd driver should work on your Radeon 4330.

When pondering your post, I first typed in a console “man radeon” to see what cards are supported by the radeon driver. I did NOT see the radeon HD4330 supported. However when I typed “man radeonhd” I noted the Radeon HD4330 is supported by the radeonhd. … Now the radeonhd driver is NOT supported as much (by developers) as the Radeon driver, … still, … one needs to go with what works.

The radeonhd driver is provided in the rpm xorg-x11-driver-video-radeonhd .

Assuming that rpm is installed, to load/configure the driver, one should first remove any reminants of the proprietary driver (if one had attempted an install of that previous). So in that case, type:

rpm -qa '*fglrx*'

and if that lists any rpms, those rpms must be 1st removed.

After the fglrx rpms are removed, then change the /etc/X11/xorg.conf.d/50-device.conf file, so that it looks something like:


Section "Device"
   Identifier "Radeon"
   #Driver "radeon"
   Driver "radeonhd"
EndSection

and then reboot and test. If that fails, try rebooting again, but this time in addition to that 50-device.conf change, also type the boot code ‘nomodeset’ in the grub boot menu.

I ran rpm -qa ‘fglrx’ and it gave no results, so I assumed i was free to load/configure the driver. after opening the /50-device.conf file, it displays the following:

Section "Device"
  Identifier "Default Device"

  #Driver "radeon"

  ## Required magic for radeon/radeonhd drivers; output name
  ## (here: "DVI-0") can be figured out via 'xrandr -q'
  #Option "monitor-DVI-0" "Default Monitor"

EndSection

xrandr -q gave the following:

Screen 0: minimum 1024 x 768, current 1024 x 768, maximum 1024 x 768
default connected 1024x768+0+0 0mm x 0mm
   1024x768       76.0* 

Im unsure as to where the magic referenced in the comments from the /50-device.conf is located in the xrandr -q.

Additionally, should i add the lines

Driver "radeonhd"

Thanks!

-ck

edit: changed the conf file to

Section "Device"
  Identifier "Default Monitor"

  #Driver "radeon"

  Driver "radeonhd"

  ## Required magic for radeon/radeonhd drivers; output name
  ## (here: "DVI-0") can be figured out via 'xrandr -q'
  #Option "monitor-DVI-0" "Default Monitor"

EndSection

Im going to restart now and i’ll post the outcome!

appears to have changed nothing :(.

What is the “appearance” assessment based on? What driver is loaded ? (noting you advised you had the FBDEV driver loaded before). Also, do not forget my advice, where I recommended you boot with two different settings (1) with a normal boot , (2) with the boot code “nomodeset”.

I am still left with the same resolution and no option to change it. I have yet to try with the nomodeset, I will be able to later tonight and I will post results.

Thanks for the patience and help thus far.

-ck

The output of my xrandr (after having temporarily fixed the problem with Kicker -> Configure Desktop -> Display) is:

Screen 0: minimum 320 x 200, current 3040 x 1050, maximum 8192 x 8192
DVI-0 connected 1680x1050+0+0 (normal left inverted right x axis y axis) 433mm x 271mm
   1680x1050      59.9*+
   1280x1024      75.0     60.0  
   1280x960       60.0  
   1152x864       75.0  
   1024x768       75.1     70.1     60.0  
   832x624        74.6  
   800x600        72.2     75.0     60.3     56.2  
   640x480        72.8     75.0     66.7     60.0  
   720x400        70.1  
DIN disconnected (normal left inverted right x axis y axis)
DVI-1 connected 1360x768+1680+0 (normal left inverted right x axis y axis) 160mm x 90mm
   1360x768       60.0*+
   1280x720       50.0     60.0  
   1024x768       60.0  
   800x600        60.3  
   720x576        50.0  
   720x480        59.9  
   640x480        60.0  
   720x400        70.1  

What are my "display name"s?

There is no xorog.conf file in etc/X11/.

Currently I have the standard setup after installing 11.3 from scratch: 2D-driver: radeon; 3D-driver: R600 classic (7.8.2). I tried installing ATI Catalyst and ended up with a black screen and had to reinstall 11.3! And I have used Catalyst for previous openSUSE versions with success.

Your answer is greatly appreciated!

...................:/etc/X11/xorg.conf.d> cat 50-monitor.conf 
Section "Monitor"
  Identifier "Default Monitor"

  ## If your monitor doesn't support DDC you may override the
  ## defaults here
  #HorizSync 28-85
  #VertRefresh 50-100

  ## Add your mode lines here, use e.g the cvt tool

EndSection
................:/etc/X11/xorg.conf.d> cat 50-screen.conf 
Section "Screen"
  Identifier "Default Screen"

  Device "Default Device"

  ## Doesn't help for radeon/radeonhd drivers; use magic in
  ## 50-device.conf instead
  Monitor "Default Monitor"

EndSection

Sounds like a splendid idea? What do I write?

Btw… are you guys saying that everyone installing openSUSE 11.3 are either a) running with **** settings, b) going Configure Desktop -> Display etc at every boot or c) editing text files as root?

Fortunately this all ‘just works’ for many of us. But some unfortunately, likely yourself, have hardware where it does not work as well. Hence the efforts of us in this volunteer support community, is to propse methods/work arounds that can be attempted to get it functioning, … and to also encourage those so inflicted to write bug reports in order to encourage/motivate the packagers and developers to make this more automatic (like it is for the rest of us) for the next openSUSE release.

What are my "display name"s?

Your display names are DVI-0 and DVI-1.

Since you’re using the proprietary (fglrx) driver, you may also find useful info in this thread:

http://forums.opensuse.org/english/get-help-here/hardware/442773-how-make-laptop-primary-monitor-11-3-a.html

It concerns using the proprietary configuration tools avaialable for ATI graphics.

This saved me a lot of headache; just wanted to say thanks man :wink:

Emon

Glad it worked for you.

Here’s a radical thought. Its called a “Save” button in Display Settings. I swear, I think you developers purposely create the need to go into your beloved command line.

When I try to modify the file I am told that it can’t be saved because I don’t have access. I am the only user and I am logged in with my password.

When I try to modify the file I am told that it can’t be saved because I don’t have access. I am the only user and I am logged in with my password.

You need root privileges to edit system files. In a graphical environment, you can type

kdesu kwrite /etc/X11/xorg.conf

For Gnome

gnomesu gedit /etc/X11/xorg.conf

Here’s a radical thought. Its called a “Save” button in Display Settings. I swear, I think you developers purposely create the need to go into your beloved command line.

There is a KDE utility called krandrtray which can be used to dynamically switch disaply modes (via xrandr). Its a much more elegant way to set the desired resolution etc. I’ve been following this bug report:

https://bugs.kde.org/show_bug.cgi?id=183143

Looks like the developers have finally implemented a long-awaited (and requested) ‘save’ feature:

SVN commit 1170315 by lunakl:

  • move the somewhat long krandr setup code from startkde
    into its own separate script that is called from startkde
  • use properly krandrrc instead of kcmrandrrc in the script
  • implement support for randr1.2 (non-legacy) setup, which
    is done by kcm_krandr simply saving a list of CLI xrandr commands
    and those are executed by the script
  • add a buttom to kcm_krandr to save the current setup
    as the default to be used during desktop startup

I dont’ know which KDE4 version it will be implemented in though.

I have tried to go through kwrite and even went to the “etc” file through Dolphin to directly put in the code. No dice on both. How do I give myself root privileges?

I checked out the patch link. Waaaaay too complicated. I wouldn’t know what to do with the patch even if I had it. I obviously know nothing about code, but would it not be simpler to just develop a freakin’ “Save” button for Display Settings and and put it out as an update?

I have tried to go through kwrite and even went to the “etc” file through Dolphin to directly put in the code. No dice on both. How do I give myself root privileges?

Did you use the kdesu command (with root password)? Thats how you run graphical programs (like kwrite) with root privileges. Not sure whats not working for you here. Be careful with typos. If you need to illustrate, consider copying and pasting what you typed, along with any errors/results etc, so that we can see where you may be going wrong.

The link to the bug report I provided was simply to inform you (and others) of the krandrtray ‘save’ feature being implemented.

I have just read that the new krandrtray ‘save’ feature is going to be implemented in KDE4.6. This should provide a nice graphical method to make display mode changes permanently.:slight_smile: