I can't change screen resolution in suse 11.3

hello to everyone
I upgraded my opensuse from 11.2 to 11.3 , but after it , i have several problem with it >:(
firstly : my graphic cart is intel hd4500 and motherboard chip’s is intel G41 . after upgrading , I understood suse 11.3 didn’t have sax2 . at a result , i have problem with graphic cart driver and consequently can’t change screen resolution, therefor after each restart , my resolution automatically fix to 1600x1200 but i would like to set it in 1280x1024 ?? . what can i do to change it permanently ?

secondly : i installed vmware workstation 6.5 and after it, i see a message that say vmware need to Kernel Header 2.6.34-12- desktop . i install kernel-syms
kernel-source , gcc and make but doesn’t run yet . what happen for it ??

please help and tanx .

hello
I install opensuse 11.3 , but after it , i have several problem with it
firstly : my graphic cart is nvidia 6200 and my monitor LG910. after install , I understood suse 11.3 didn’t have sax2 . at a result , i have problem with graphic cart driver and consequently can’t change screen resolution, therefor after each restart , my resolution automatically fix to 2048 x1536!!!, but i would like to set it in 1280x1024 ?? . what can i do to change it permanently ? Auto: resoluton > of the monitor? .

please help and tanks .

In the KDE desktop:

Kickoff Launcher (the green circle in the lower left corner) -> Configure Desktop -> Computer Administration section -> Display -> Size & Orientation … there you will find a place to change the screen resolution!

Same problem. But when I restart the pc resolution come back to “automatic resolution” that I didn’t choose!

Same here :frowning:

after restart, my screen resolution come back to 1600x1200 ?? why and what can i do ??

Open a terminal and type

xrandr

to display your display device name(s) and available display modes.

Create/edit a minimal xorg.conf with an editor like this for KDE:

kdesu kwrite /etc/X11/xorg.conf

For Gnome:

gnomesu gedit /etc/X11/xorg.conf

Create/adjust the monitor section like this for example:

Section "Monitor"
   Identifier "LVDS"
   Option "Preferred Mode" "1280x800"
EndSection

You can see I’ve used my laptop display name LVDS. (You’ll need to use the display name as per your xrandr output). When done, save the file, and restart the X-server. Now your desktop should start up in your preferred display mode.

tanx. my screen resolution is fixing now.

Works!!! Tnx

this for me :smiley:

Section “Monitor”
#DisplaySize 310 230 # mm
Identifier “VGA-0”
VendorName “SAM”
ModelName “SyncMaster”
HorizSync 30.0 - 71.0
VertRefresh 50.0 - 160.0
Option “Preferred Mode” “1280x1024”
EndSection

My pleasure:)

went looking out for this solution a lot. finally ended up here.

working well. thanks a lot…

Any one try to configure with two monitors?

Any one try to configure with two monitors?

You should search for threads concerning multiple or dual monitors. What graphics card and driver are you using? (That might affect the best approach for your situation). IMO, it is a good idea to start another thread for this.

Quick Question…

my Xorg.config file looks like this

Section "Monitor"
	Identifier   "aticonfig-Monitor[0]-0"
	Option	    "VendorName" "ATI Proprietary Driver"
	Option	    "ModelName" "Generic Autodetecting Monitor"
	Option	    "DPMS" "true"
EndSection

would I just add in

Option    "Preferred Mode" "1280x1024" 

to make mine start the way I want or dose it already have to have that command line in there?
ATI-RAdeonHD Series 4xxx

~Jenn

Whole Config

 Section "ServerLayout"
	Identifier     "aticonfig Layout"
	Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Files"
EndSection

Section "Module"
EndSection

Section "Monitor"
	Identifier   "aticonfig-Monitor[0]-0"
	Option	    "VendorName" "ATI Proprietary Driver"
	Option	    "ModelName" "Generic Autodetecting Monitor"
	Option	    "DPMS" "true"
EndSection

Section "Device"
	Identifier  "aticonfig-Device[0]-0"
	Driver      "fglrx"
  #BusID       "PCI:1:0:0"
EndSection

Section "Screen"
	Identifier "aticonfig-Screen[0]-0"
	Device     "aticonfig-Device[0]-0"
	Monitor    "aticonfig-Monitor[0]-0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection


xrandr:

 jennifer@Artista3:~> xrandr
Screen 0: minimum 320 x 200, current 1024 x 768, maximum 8192 x 8192
DVI-0 connected 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768       60.0* 
   800x600        60.3     56.2  
   848x480        60.0  
   640x480        59.9     59.9  
DIN disconnected (normal left inverted right x axis y axis)
DVI-1 disconnected (normal left inverted right x axis y axis)

ok I messed up a little. When I restarted all affects took change.
xandr:

Section "ServerLayout"
	Identifier     "aticonfig Layout"
	Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Files"
EndSection

Section "Module"
EndSection

Section "Monitor"
	Identifier   "aticonfig-Monitor[0]-0"
	Option	    "VendorName" "ATI Proprietary Driver"
	Option	    "ModelName" "Generic Autodetecting Monitor"
	Option	    "DPMS" "true"
EndSection

Section "Monitor"
	Identifier   "0-DFP2"
	Option	    "VendorName" "ATI Proprietary Driver"
	Option	    "ModelName" "Generic Autodetecting Monitor"
	Option	    "DPMS" "true"
	Option	    "PreferredMode" "1280x1024"
	Option	    "TargetRefresh" "60"
	Option	    "Position" "0 0"
	Option	    "Rotate" "normal"
	Option	    "Disable" "false"
EndSection

Section "Monitor"
	Identifier   "0-CRT2"
	Option	    "VendorName" "ATI Proprietary Driver"
	Option	    "ModelName" "Generic Autodetecting Monitor"
	Option	    "DPMS" "true"
	Option	    "PreferredMode" "1280x1024"
	Option	    "TargetRefresh" "60"
	Option	    "Position" "0 0"
	Option	    "Rotate" "normal"
	Option	    "Disable" "false"
EndSection

Section "Device"

xorg.conf:

Section "ServerLayout"
	Identifier     "aticonfig Layout"
	Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Files"
EndSection

Section "Module"
EndSection

Section "Monitor"
	Identifier   "aticonfig-Monitor[0]-0"
	Option	    "VendorName" "ATI Proprietary Driver"
	Option	    "ModelName" "Generic Autodetecting Monitor"
	Option	    "DPMS" "true"
EndSection

Section "Monitor"
	Identifier   "0-DFP2"
	Option	    "VendorName" "ATI Proprietary Driver"
	Option	    "ModelName" "Generic Autodetecting Monitor"
	Option	    "DPMS" "true"
	Option	    "PreferredMode" "1280x1024"
	Option	    "TargetRefresh" "60"
	Option	    "Position" "0 0"
	Option	    "Rotate" "normal"
	Option	    "Disable" "false"
EndSection

Section "Monitor"
	Identifier   "0-CRT2"
	Option	    "VendorName" "ATI Proprietary Driver"
	Option	    "ModelName" "Generic Autodetecting Monitor"
	Option	    "DPMS" "true"
	Option	    "PreferredMode" "1280x1024"
	Option	    "TargetRefresh" "60"
	Option	    "Position" "0 0"
	Option	    "Rotate" "normal"
	Option	    "Disable" "false"
EndSection

Section "Device"

I want to take out the one monitor and just use 0-DFP2. Now the problem with this is when I disconnect the other one and restart the computer it resets everything in this script and the monitor goes black with the green line. I am trying to make this one work stand alone.

Solved it finally… sorry to have burned up this post. I get over eager to get things fixed. Example I worked on conky for 8 straight hours yesterday until I had it do exactly what I wanted it too >.<

I have the same problem. I installed opensuse 11.3 on a laptop, my screen resolution should be 1366x768 but in the menu “Configure Desktop -> Display -> Size & Orientation” it suggests 1240x768 as the only option for screen resolution.

I created the xorg.conf file (it wasnt there in the beginning), but it didn’t change anything. Does anyone know another way to change screen resolution?

I have the same problem currently. I’ve installed my video driver but still don’t have a choice for resolution beyond 1024x768 and Disabled.

After following the suggestion above, my xrandr came out to this:

Screen 0: minimum 1024 x 768, current 1024 x 768, maximum 1024 x 768
default connected 1024x768+0+0 0mm x 0mm
   1024x768       76.0* 

and my xorg.conf that im currently editing was blank. I’m a little hesitant to save the currently blank xorg.conf with

Section "Monitor"
   Identifier "Screen 0"
   Option "Preferred Mode" "1366x768"
EndSection

If anyone could just let me know what my worst case outcome from this is, I would appreciate it! Thanks.

Edit: The driver did not properly install for some reason. After visiting Hardware - cchtml.com it seems that the HD4330 is not supported. Would someone be able to point me in the right direction to getting that fixed (im sure this is responsible for my resolution issue).

-ck

Edit: The driver did not properly install for some reason. After visiting Hardware - cchtml.com it seems that the HD4330 is not supported. Would someone be able to point me in the right direction to getting that fixed (im sure this is responsible for my resolution issue).

-ck