I cannot install Suse. Please help me

Hello everyone. I have a computer with 3 hard drives. 2 for files and 1 HDD for the operating systems. I have installed debian and windows xp.
These days I wanted to install opensuse 11.1 but during the instalation I received an error from yast2:

An error occurred while installing GRUB
GNU GRUB version 0.97 (640K lower / upper memory 3072)
[Minimal BASH-like line editing is supported. For the first word, TAB lists possible comands = Completions. Anywhere else TAB lists the possible Completions of a device / filename.]
grub> setup - stage2 - force-was (hd0) (hd0, 6)

Error 17: Can not mount selected partition
grub> quit

And I have to choose OK or CANCEL
If I choose cancel, the instalation stoped.
If I choose OK the instalations finish but when I restart, I don´t see suse in my grub menu. (I have gurb menu because of the instalation of debian before)
I tried with SUPER GRUB DISK, but no results.

Well this is the problem. Now I have opensuse 11.1 installed in my computer, but I have no idea how to boot it. Meybe I can add it in my menu.lst, bot what I have to add it?
Plese, hope for help.
miros84 is online now
Tag This Post

HowTo Boot into openSUSE when it won’t Boot from the Grub Code on the Hard Drive

I am not sure that this would have anything to do with your problem. The best bet is just checking out that link caf4962 posted and taking it from there.

When I had my three sata’s and an IDE I use to have problems with some Linux Distros seeing the IDE as the fourth drive, while others saw it as the first one. My BIOS would only keep the IDE HD as the first one no matter what changes I made in the BIOS itself.

I noticed that during the install it would see the hard drive set up in one order but after the install that order changed. It was a weird problem.

So what I did was unhooked the IDE or the satas, depending on where I was installing the OS, and making sure Grub installed on the root partition as well as the MBR of that HD. After I hooked up all the HD’s and just installed (The lazy way) GAG bootloader.

Though at times I did have to make a change in menu.lst, for exmaple root (hd0,1) to something like root (hd3,1)

Like I said I am not sure this is your problem or anything close to it.

Yes, suse_amd64x2
meybe that is the problem
I am not sure, but I have to try
I have no choose

Check this:

 	 	 	 	 	  *If you have a Linux Live CD*, boot from it and log in. Then open a console window and enter su and you will be at the command prompt with root powers and ready to proceed.

If on the other hand you have the openSUSE install DVD, boot from it and on the first menu of options select the Rescue System option. That will start an elementary Linux Live operating system and bring you to the login prompt. Enter the username root and you will be at the command prompt with root powers and ready to proceed.
Whichever way you started (the openSUSE install DVD or a Linux Live CD) when you are at the root command prompt, first you find the partition containing openSUSE’s bootloader. Then you reinstall Grub with a pointer to that partition.
First find the openSUSE installation:
You enter this ---------------- grub
Computer returns like this ---- grub>
You enter this ---------------- find /boot/grub/menu.lst
Computer returns like this ---- (hd0,5)
Here, (hd0,5) is Grub’s pointer to my openSUSE installation. Your pointer will be different from my example (hd0,5). Substitute your values for my example (hd0,5). Now that you have the pointer, proceed like this:
You enter this ---------------- root (hd0,5)
Computer returns like this ---- Filesystem type is ext2fs, partition type 0x83
You enter this ---------------- setup (hd0)
You see several lines like this — Checking if /boot/grub/stage1 exists … yes
Computer finally returns this-- Succeeded…Done
You enter this ---------------- quit
You enter this ---------------- reboot

Thank you caf4926
I tried all methods in the link you gave me above.
I try every method and no results.
I explain you.
I have debian in sda4 and suse in sda7, and supergrindisk found only debian. The method you toldme above found only as toor partition sda4. No way to find suse or sda7 as root partition.
The only thing I didnot try yet, is to remove all my hdd, and try to install it with only one HDD.